summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-style-qtcurve/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-extra/tde-style-qtcurve/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-style-qtcurve/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/arch/tde-extra/tde-style-qtcurve/PKGBUILD b/arch/tde-extra/tde-style-qtcurve/PKGBUILD
new file mode 100644
index 000000000..e5bc33437
--- /dev/null
+++ b/arch/tde-extra/tde-style-qtcurve/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: e1z0 <justinas at eofnet dot lt>
+
+pkgname=tde-style-qtcurve
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="TDE Style QTCurve"
+arch=('i686' 'x86_64')
+url='http://scm.trinitydesktop.org/scm/git/applications/tde-style-qtcurve'
+license=('GPL')
+groups=('tde-extra')
+depends=('tde-tdebase')
+makedepends=('pkgconfig' 'cmake')
+#provides=('tde-style-qtcurve')
+#conflicts=('tde-style-qtcurve')
+#replaces=('tde-style-qtcurve')
+options=('staticlibs' 'libtool' '!strip')
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/applications/tde-style-qtcurve-R${pkgver}.tar.bz2")
+md5sums=('43e7e865807d966890663e511837b616')
+# install=''
+
+build() {
+ ## Generate config files and update with autoreconf
+ cd ${srcdir}/applications/${pkgname}
+
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ msg "Starting cmake..."
+
+ cmake ${srcdir}/applications/${pkgname} \
+ -DCMAKE_INSTALL_PREFIX=${TDEDIR} \
+ -DSYSCONF_INSTALL_DIR=${TDEDIR}/etc \
+ -DBUILD_ALL=ON \
+ -DWITH_GCC_VISIBILITY=ON
+
+ make $NUMJOBS
+
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+ cd ${srcdir}/build # use for libtool
+
+ make -j1 DESTDIR="${pkgdir}" install
+}