summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-tdegames/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-extra/tde-tdegames/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-tdegames/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/arch/tde-extra/tde-tdegames/PKGBUILD b/arch/tde-extra/tde-tdegames/PKGBUILD
index d3d4d5b00..cce98cd89 100644
--- a/arch/tde-extra/tde-tdegames/PKGBUILD
+++ b/arch/tde-extra/tde-tdegames/PKGBUILD
@@ -1,10 +1,10 @@
# Contributor: e1z0 <justinas at eofnet dot lt>
pkgname=tde-tdegames
-pkgver=14.0.5
+pkgver=14.0.10
pkgrel=1
arch=('i686' 'x86_64')
-url='http://scm.trinitydesktop.org/scm/git/tdegames'
+url='https://scm.trinitydesktop.org/scm/git/tdegames'
license=('GPL')
groups=('tde-extra')
pkgdesc="Trinity Desktop Games"
@@ -14,21 +14,24 @@ provides=('tdegames')
conflicts=('trinity-tdegames' 'trinity-kdegames')
replaces=('trinity-tdegames')
options=('staticlibs' 'libtool' '!strip')
-source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/tdegames-R${pkgver}.tar.bz2")
-md5sums=('8832d778231615da0dc6b4d1e083f9ba')
+source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/core/tdegames-trinity-${pkgver}.tar.xz")
+md5sums=('870352e848a991f1ff0045ef5590bc47')
# install=''
+[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
+
build() {
cd $srcdir
msg "Creating out-of-source build directory: ${srcdir}/build"
mkdir -p build
cd build
+ export PKG_CONFIG_PATH=${TDEDIR}/lib/pkgconfig:${PKG_CONFIG_PATH}
+
msg "Starting cmake..."
- cmake ${srcdir}/${pkgname#*-} \
+ cmake ${srcdir}/${pkgname#*-}-trinity-${pkgver} \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX=$TDEDIR \
- -DWITH_SPEEX=ON \
-DWITH_ARTS=ON \
-DBUILD_ALL=ON