summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/development/kscope/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/development/kscope/debian')
-rw-r--r--debian/_base/applications/development/kscope/debian/cdbs/debian-tde.mk251
-rw-r--r--debian/_base/applications/development/kscope/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/development/kscope/debian/changelog97
-rw-r--r--debian/_base/applications/development/kscope/debian/compat1
-rw-r--r--debian/_base/applications/development/kscope/debian/control44
-rw-r--r--debian/_base/applications/development/kscope/debian/copyright62
-rw-r--r--debian/_base/applications/development/kscope/debian/docs3
-rw-r--r--debian/_base/applications/development/kscope/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/development/kscope/debian/rules17
-rw-r--r--debian/_base/applications/development/kscope/debian/source/format1
-rw-r--r--debian/_base/applications/development/kscope/debian/source/options6
11 files changed, 501 insertions, 0 deletions
diff --git a/debian/_base/applications/development/kscope/debian/cdbs/debian-tde.mk b/debian/_base/applications/development/kscope/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/development/kscope/debian/cdbs/versions.pl b/debian/_base/applications/development/kscope/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/development/kscope/debian/changelog b/debian/_base/applications/development/kscope/debian/changelog
new file mode 100644
index 000000000..f197361ae
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/changelog
@@ -0,0 +1,97 @@
+kscope-trinity (1.6.2-1ubuntu1) maverick; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Sat, 07 Sep 2013 23:43:53 +0200
+
+kscope (1.6.2-1ubuntu1) maverick; urgency=low
+
+ * Port to Ubuntu.
+
+ -- Eugene San (eugenesan) <eugenesan@gmail.com> Fri, 04 Feb 2011 22:02:59 +0200
+
+kscope (1.6.2-1) unstable; urgency=low
+
+ * New upstream release (bugfix release).
+ * Bump Standards-Version to 3.8.0 (no changes needed).
+
+ -- Fathi Boudra <fabo@debian.org> Sat, 09 Aug 2008 10:20:14 +0200
+
+kscope (1.6.1-1) unstable; urgency=low
+
+ * New upstream release.
+ * Refresh patches.
+ * Bump Standards-Version to 3.7.3.
+ * Use Homepage, Vcs-Browser and Vcs-Svn fields.
+ * Switch to quilt patch system.
+ * Remove embedded copy of GFDL as it can be found in common-licences.
+
+ -- Fathi Boudra <fabo@debian.org> Sat, 01 Mar 2008 19:33:31 +0100
+
+kscope (1.6.0-1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 12 Jul 2007 21:22:32 +0200
+
+kscope (1.5.2-1) unstable; urgency=low
+
+ * New upstream release. (Closes: #420874)
+
+ -- Fathi Boudra <fboudra@free.fr> Tue, 15 May 2007 19:47:50 +0200
+
+kscope (1.5.1-2) unstable; urgency=low
+
+ * Upload to unstable
+
+ -- Mark Purcell <msp@debian.org> Sat, 3 Mar 2007 13:23:12 +0000
+
+kscope (1.5.1-1) experimental; urgency=low
+
+ * New upstream release.
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 15 Feb 2007 18:56:31 +0100
+
+kscope (1.5.0-1) unstable; urgency=low
+
+ * New upstream release
+ * Add ./debian/rules get-orig-source for http://buildserver.net
+ * Build-Depends: autotools-dev fixes outdated-autotools-helper-file
+
+ -- Mark Purcell <msp@debian.org> Wed, 7 Feb 2007 21:08:10 +0000
+
+kscope (1.4.2-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 16 Oct 2006 22:03:21 +0200
+
+kscope (1.4.1-2) unstable; urgency=low
+
+ * Add patch to load default config
+
+ -- Fathi Boudra <fboudra@free.fr> Fri, 8 Sep 2006 18:13:30 +0200
+
+kscope (1.4.1-1) unstable; urgency=low
+
+ * New upstream release
+ * Remove 11_crashfix.diff, merged upstream
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 24 Aug 2006 12:24:23 +0200
+
+kscope (1.4.0-1) unstable; urgency=low
+
+ * New upstream release
+ * Merge kubuntu patches, thanks to Tom Albers <tomalbers@kde.nl>
+ * Add kscope manpage from kubuntu package,
+ thanks to Jonathan Patrick Davies <jpatrick@ubuntu.com>
+ * Update copyright file: add kscope manpage license
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 10 Aug 2006 14:42:31 +0200
+
+kscope (1.3.4-1) unstable; urgency=low
+
+ * Initial release (Closes: #309669)
+
+ -- Fathi Boudra <fboudra@free.fr> Fri, 28 Apr 2006 08:05:15 +0100
+
diff --git a/debian/_base/applications/development/kscope/debian/compat b/debian/_base/applications/development/kscope/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/_base/applications/development/kscope/debian/control b/debian/_base/applications/development/kscope/debian/control
new file mode 100644
index 000000000..73542706b
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/control
@@ -0,0 +1,44 @@
+Source: kscope-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
+Uploaders: Fathi Boudra <fabo@debian.org>, Mark Purcell <msp@debian.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, bison, flex, tdebase-trinity-dev
+Standards-Version: 3.8.0
+Homepage: http://kscope.sourceforge.net
+Vcs-Browser: http://svn.debian.org/wsvn/pkg-kde/kde-extras/kscope/?op=log
+Vcs-Svn: svn://svn.debian.org/pkg-kde/kde-extras/kscope/trunk
+
+Package: kscope-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, cscope, exuberant-ctags, graphviz
+Description: source editing environment for TDE
+ KScope is a TDE front-end to Cscope. It provides a source-editing environment
+ for large C projects. KScope is focused on source editing and analysis.
+ .
+ KScope is built around an efficient mechanism for code-navigation, which
+ allows the user to run queries on the code.
+ .
+ The types of queries KScope can run include:
+ * Get all references to a symbol
+ * Find the definition of a symbol
+ * Find all functions called by or calling to a function
+ * Find an EGrep pattern
+ * Find all files #including some file
+ .
+ These queries are handled by an underlying Cscope process. KScope simply
+ serves as a front-end to this process, feeding it with queries, and parsing
+ its output into result lists. The items in those lists can later be selected
+ to open an editor at the matching line.
+ .
+ Main Features:
+ * Multiple editor windows (using your favourite TDE editor)
+ * Project management
+ * Front-end to most Cscope queries
+ * Tag list for every open editor
+ * Call-tree window
+ * Session management, including saving and restoring queries
+ * Works with externally-built cscope.out files
+ .
+ Homepage: http://kscope.sourceforge.net
diff --git a/debian/_base/applications/development/kscope/debian/copyright b/debian/_base/applications/development/kscope/debian/copyright
new file mode 100644
index 000000000..6149f4244
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/copyright
@@ -0,0 +1,62 @@
+This package was debianized by Fathi Boudra <fboudra@free.fr> on
+Tue, 11 Apr 2006 11:44:04 +0200.
+
+It was downloaded from http://kscope.sourceforge.net
+
+Copyright Holder: Elad Lahav <elad_lahav@users.sf.net>
+
+The kscope manpage is © 2006 Jonathan Patrick Davies <jpatrick@ubuntu.com>
+and is licensed under the GPL, see below.
+
+manpage license:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
+kscope license:
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+On Debian systems, the complete text of the BSD License can be
+found in `/usr/share/common-licenses/BSD'.
+
+The documentations provided with kscope is distributed under
+the GNU Free Documentation License (FDL). They are considered free with
+regards to the Debian Free Software Guidelines (DFSG) because they don't
+contain any unmodifiable parts (invariant sections).
+
+On Debian systems, the complete text of the GNU Free Documentation
+License can be found in `/usr/share/common-licenses/GFDL'.
diff --git a/debian/_base/applications/development/kscope/debian/docs b/debian/_base/applications/development/kscope/debian/docs
new file mode 100644
index 000000000..76c3076c9
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/docs
@@ -0,0 +1,3 @@
+AUTHORS
+README.md
+TODO
diff --git a/debian/_base/applications/development/kscope/debian/patches/series b/debian/_base/applications/development/kscope/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/patches/series
diff --git a/debian/_base/applications/development/kscope/debian/rules b/debian/_base/applications/development/kscope/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/development/kscope/debian/source/format b/debian/_base/applications/development/kscope/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/development/kscope/debian/source/options b/debian/_base/applications/development/kscope/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/development/kscope/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*