summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kerry
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kerry')
-rw-r--r--debian/_base/applications/kerry/debian/cdbs/debian-qt-kde.mk115
-rw-r--r--debian/_base/applications/kerry/debian/cdbs/kde.mk89
-rw-r--r--debian/_base/applications/kerry/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kerry/debian/changelog99
-rw-r--r--debian/_base/applications/kerry/debian/compat1
-rw-r--r--debian/_base/applications/kerry/debian/control19
-rw-r--r--debian/_base/applications/kerry/debian/copyright35
-rw-r--r--debian/_base/applications/kerry/debian/kerry.1.docbook109
-rw-r--r--debian/_base/applications/kerry/debian/patches/series0
-rw-r--r--debian/_base/applications/kerry/debian/postinst13
-rw-r--r--debian/_base/applications/kerry/debian/postrm12
-rwxr-xr-xdebian/_base/applications/kerry/debian/rules35
-rw-r--r--debian/_base/applications/kerry/debian/source/format1
-rw-r--r--debian/_base/applications/kerry/debian/source/options6
14 files changed, 553 insertions, 0 deletions
diff --git a/debian/_base/applications/kerry/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kerry/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..91a547ea9
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,115 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/opt/trinity/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kerry/debian/cdbs/kde.mk b/debian/_base/applications/kerry/debian/cdbs/kde.mk
new file mode 100644
index 000000000..1ac26c4b7
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/cdbs/kde.mk
@@ -0,0 +1,89 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kerry/debian/cdbs/versions.pl b/debian/_base/applications/kerry/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kerry/debian/changelog b/debian/_base/applications/kerry/debian/changelog
new file mode 100644
index 000000000..3f36fe40e
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/changelog
@@ -0,0 +1,99 @@
+kerry-trinity (1:0.2.1-0ubuntu6) lucid; urgency=low
+
+ * Trinity Lucid rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 14 Aug 2010 10:00:00 -0600
+
+kerry (1:0.2.1-0ubuntu5) hardy; urgency=low
+
+ * Add patch kubuntu_08_libbeagle1_transition.patch to make configure
+ use libbeagle1, so binary objects are built. (LP: #211591).
+ * Add patch kubuntu_09_remove-sh.patch to remove .sh extension
+ from beagled-shutdown script.
+ * Add postinst and postrm scripts to run ldconfig when kerry is
+ installed or removed.
+ * denian/rules: remove rpath from the binary and library files.
+ * debian/control:
+ - set minimum version of libbeagle-dev to 0.3.0 in build-depends.
+ - add chrpath to build-depends.
+ - bump standards-version to 3.7.3, no further changes needed.
+ - move Homepage from description to control fields.
+ * Update kubuntu_04_no_core_kmenu_entry.desktop.patch to remove
+ deprecated encoding field.
+ * Add patch kubuntu_10_update-kcmbeagle-desktop.patch to remove
+ deprecated encoding field from the kcmbeagle desktop file.
+
+ -- Albert Damen <albrt@gmx.net> Tue, 08 Apr 2008 21:50:06 +0200
+
+kerry (1:0.2.1-0ubuntu4) hardy; urgency=low
+
+ * Rebuild for libbeagle0 -> libbeagle1 transition (LP: #192262).
+
+ -- Andrea Colangelo <warp10@libero.it> Sat, 16 Feb 2008 00:02:29 +0100
+
+kerry (1:0.2.1-0ubuntu3) gutsy; urgency=low
+
+ * Added kubuntu_06_knotes_integration.patch to fix knotes integration
+ failing to open a note, opening an empty note instead
+ * kubuntu_07_french_translation.patch for complete french translation
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 30 Jun 2007 01:14:05 +0200
+
+kerry (1:0.2.1-0ubuntu2) feisty; urgency=low
+
+ * Build-Depends on libbeagle-dev instead of beagle-dev to actually compile
+ kerry (Closes: Malone #76773)
+
+ -- Adrien Cunin <adri2000@gmail.com> Thu, 18 Jan 2007 12:33:38 +0100
+
+kerry (1:0.2.1-0ubuntu1) feisty; urgency=low
+
+ * New upstream release.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 05 Dec 2006 18:03:31 +0100
+
+kerry (1:0.1-0ubuntu2) dapper; urgency=low
+
+ * kubuntu_05_shortkey.diff: Change main key combo to stop clashing with
+ YaKuake this time.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 09 Apr 2006 21:14:46 +0200
+
+kerry (1:0.1-0ubuntu1) dapper; urgency=low
+
+ * New upstream release.
+ * Patched up patches.
+ * Removed makebuilddir/kerry from debian/rules: no longer necessary.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 09 Apr 2006 11:35:34 +0200
+
+kerry (0.09-0ubuntu4) dapper; urgency=low
+
+ * Added kubuntu_05_shortkey.diff: Remove Alt-Space shortcut to stop
+ conflicting with Katapult.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Fri, 07 Apr 2006 21:11:45 +0200
+
+kerry (0.09-0ubuntu3) dapper; urgency=low
+
+ * Added kubuntu_04_no_core_kmenu_entry.desktop.patch to avoid double entry
+ in Kmenu
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 29 Mar 2006 3:30:37 +0100
+
+kerry (0.09-0ubuntu2) dapper; urgency=low
+
+ * Switched to cdbs
+ * Added kubuntu_01_kdepot.patch for pot file extraction to Rosetta
+ * kubuntu_01_kerry.diff becomes kubuntu_02_fix_shutdown_script_path.patch
+ * Added kubuntu_03_no_beagle_autostart.diff to remove autostart desktop file
+ for beagle as new beagle package already has it
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 28 Mar 2006 20:50:37 +0100
+
+kerry (0.09-0ubuntu1) dapper; urgency=low
+
+ * Initial release.
+ * Created kubuntu_01_kerry.diff - install scripts to /usr/bin.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 26 Mar 2006 15:51:20 +0200
diff --git a/debian/_base/applications/kerry/debian/compat b/debian/_base/applications/kerry/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kerry/debian/control b/debian/_base/applications/kerry/debian/control
new file mode 100644
index 000000000..21659ff32
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/control
@@ -0,0 +1,19 @@
+Source: kerry-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, tdelibs14-trinity-dev, libkonq4-trinity-dev, libbeagle-dev (>= 0.3.0), docbook2x, chrpath, automake, autoconf, libtool, libltdl-dev
+Homepage: http://en.opensuse.org/Kerry
+Standards-Version: 3.8.4
+
+Package: kerry-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, beagle (>= 0.2.3)
+Replaces: kerry-trinity (<< 4:14.0.0~)
+Breaks: kerry-trinity (<< 4:14.0.0~)
+Description: a TDE frontend for the Beagle desktop search daemon [Trinity]
+ Kerry is a Trinity frontend for the Beagle desktop search daemon.
+ .
+ A program for indexing and searching user's data. At the moment, it can index
+ filesystems, chat logs, mail and data, RSS and other.
+ .
diff --git a/debian/_base/applications/kerry/debian/copyright b/debian/_base/applications/kerry/debian/copyright
new file mode 100644
index 000000000..96a9180c9
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/copyright
@@ -0,0 +1,35 @@
+This package was debianized by Jonathan Patrick Davies <jpatrick@ubuntu.com> on
+Sun, 26 Mar 2006 15:51:20 +0200.
+
+It was downloaded from http://www.kde-apps.org/content/show.php?content=36832
+
+Upstream Authors: Stephan Binner <binner@kde.org>
+ Debajyoti Bera <dbera.web@gmail.com>
+
+
+Copyright:
+ Copyright (C) 2005 Novell, Inc.
+ Copyright (C) 2005 Petri Damst�n <petri.damsten@iki.fi>
+ Copyright (C) 2005 Debajyoti Bera <dbera.web@gmail.com>
+ Copyright (C) 1998 Kurt Granroth <granroth@kde.org>
+ Copyright (C) 2000 Peter Putzer <putzer@kde.org>
+ Copyright (C) 2005 Jaroslaw Staniek <js@iidea.pl>
+
+License:
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the
+ Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/_base/applications/kerry/debian/kerry.1.docbook b/debian/_base/applications/kerry/debian/kerry.1.docbook
new file mode 100644
index 000000000..c286af6db
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/kerry.1.docbook
@@ -0,0 +1,109 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Jonathan Patrick</firstname>
+ <surname>Davies</surname>
+ <email>jpatrick@ubuntu.com</email>
+ </author>
+ <copyright>
+ <year>2006</year>
+ <holder>Jonathan Patrick Davies</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2006-03-26</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>kerry</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>kerry</refname>
+ <refpurpose>a Beagle frontend for TDE</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>kautoclick</command>
+ <arg choice="opt">
+ <option><replaceable>Qt-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>TDE-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ Kerry is a frontend for Beagle for the <productname>TDE</productname> desktop.
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ All <productname>TDE</productname> and <productname>Qt</productname>
+ programs accept a some common command-line options. Kerry has no
+ application-specific options.
+ </para>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-tde</option> </term>
+ <listitem> <para>Show TDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Jonathan Patrick Davies
+ <email>jpatrick@ubuntu.com</email> for the
+ <productname>Ubuntu</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
diff --git a/debian/_base/applications/kerry/debian/patches/series b/debian/_base/applications/kerry/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/patches/series
diff --git a/debian/_base/applications/kerry/debian/postinst b/debian/_base/applications/kerry/debian/postinst
new file mode 100644
index 000000000..d0ff50431
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/postinst
@@ -0,0 +1,13 @@
+#!/bin/sh
+# postinst script for kerry-trinity
+
+set -e
+
+if [ "$1" = "configure" ] ; then
+ # force ldconfig due to tdeinit library
+ ldconfig
+fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/_base/applications/kerry/debian/postrm b/debian/_base/applications/kerry/debian/postrm
new file mode 100644
index 000000000..d1ae3b96c
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/postrm
@@ -0,0 +1,12 @@
+#!/bin/sh
+# postrm script for kerry-trinity
+
+set -e
+
+if [ "$1" = "remove" ] ; then
+ ldconfig
+fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/_base/applications/kerry/debian/rules b/debian/_base/applications/kerry/debian/rules
new file mode 100755
index 000000000..7e44d25e2
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+# include /usr/share/cdbs/1/class/kde.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_INSTALL_MANPAGES_kerry-trinity = kerry.1
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+build/kerry-trinity::
+ docbook2x-man debian/kerry.1.docbook
+
+clean::
+ rm -f kerry.1
+
+binary-post-install/kerry-trinity::
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/libtdeinit_kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/bin/kerry
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kcm_beagle.so
+ mkdir -p debian/kerry-trinity/opt/trinity/share/man/man1/
+ mv debian/kerry-trinity/usr/share/man/man1/kerry.1 debian/kerry-trinity/opt/trinity/share/man/man1/kerry.1
+ rm -rf debian/kerry-trinity/usr/share/man
diff --git a/debian/_base/applications/kerry/debian/source/format b/debian/_base/applications/kerry/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kerry/debian/source/options b/debian/_base/applications/kerry/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kerry/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*