summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kooldock
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kooldock')
-rw-r--r--debian/_base/applications/kooldock/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--debian/_base/applications/kooldock/debian/cdbs/kde.mk91
-rw-r--r--debian/_base/applications/kooldock/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kooldock/debian/changelog35
-rw-r--r--debian/_base/applications/kooldock/debian/compat1
-rw-r--r--debian/_base/applications/kooldock/debian/control26
-rw-r--r--debian/_base/applications/kooldock/debian/copyright27
-rw-r--r--debian/_base/applications/kooldock/debian/docs4
-rw-r--r--debian/_base/applications/kooldock/debian/menu4
-rwxr-xr-xdebian/_base/applications/kooldock/debian/rules20
-rw-r--r--debian/_base/applications/kooldock/debian/source/format1
-rw-r--r--debian/_base/applications/kooldock/debian/source/options6
12 files changed, 353 insertions, 0 deletions
diff --git a/debian/_base/applications/kooldock/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kooldock/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kooldock/debian/cdbs/kde.mk b/debian/_base/applications/kooldock/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kooldock/debian/cdbs/versions.pl b/debian/_base/applications/kooldock/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kooldock/debian/changelog b/debian/_base/applications/kooldock/debian/changelog
new file mode 100644
index 000000000..fd8cb560a
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/changelog
@@ -0,0 +1,35 @@
+kooldock-trinity (0.4.7-1) squeeze; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Thu, 01 Sep 2015 19:50:25 +0200
+
+kooldock (0.3-1ubuntu3) gutsy; urgency=low
+
+ * debian/control: Update maintainer fields according to debian-
+ maintainer-field spec.
+
+ -- Martin Pitt <martin.pitt@ubuntu.com> Wed, 15 Aug 2007 08:06:56 +0000
+
+kooldock (0.3-1ubuntu2) edgy; urgency=low
+
+ * libgamin0 kubuntu transition
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Wed, 16 Aug 2006 18:01:51 -0500
+
+kooldock (0.3-1ubuntu1) dapper; urgency=low
+
+ * debian/applied-patches/strip-empty-de.po.patch:
+ - po/Makefile.in:
+ - remove de.po and de.gmo
+ - debian/rules:
+ - remove empty po/de.po.
+
+ -- Daniel Holbach <daniel.holbach@ubuntu.com> Mon, 29 May 2006 11:11:26 +0200
+
+kooldock (0.3-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Claudio Moratti <maxer@knio.it> Fri, 23 Sep 2005 18:19:20 +0200
+
diff --git a/debian/_base/applications/kooldock/debian/compat b/debian/_base/applications/kooldock/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kooldock/debian/control b/debian/_base/applications/kooldock/debian/control
new file mode 100644
index 000000000..dd6b6b731
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/control
@@ -0,0 +1,26 @@
+Source: kooldock-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdelibs-trinity-dev
+Standards-Version: 3.8.0
+Homepage: http://sourceforge.net/projects/kooldock/
+
+Package: kooldock-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Dock for TDE with cool visual enhancements
+ KoolDock is a fork of the original work of Dang Viet Dung,.
+ KSmoothDock 2.1. KoolDock is a dock for TDE with cool.
+ visual enhancements and effects.
+ .
+ Some of it features are:
+ * Display quick launchers to your favourite apps
+ * A builtin task bar
+ * Pager and clock. (Not done yet)
+ * Smooth zooming effect (like Apple's OS X dock)
+ * Transparent Background
+ .
+ Homepage: http://sourceforge.net/projects/kooldock/
+
diff --git a/debian/_base/applications/kooldock/debian/copyright b/debian/_base/applications/kooldock/debian/copyright
new file mode 100644
index 000000000..a3797447e
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/copyright
@@ -0,0 +1,27 @@
+This package was debianized by Claudio Moratti <maxer@knio.it> on
+Fri, 23 Sep 2005 18:19:20 +0200.
+
+It was downloaded from http://sourceforge.net/projects/kooldock/
+
+Copyright Holder: Matias Fernandez <radix@kde.cl>
+ Francisco Guidi <francisco@guidi.com>
+
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/kooldock/debian/docs b/debian/_base/applications/kooldock/debian/docs
new file mode 100644
index 000000000..c17f03764
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/docs
@@ -0,0 +1,4 @@
+AUTHORS
+NEWS
+README
+TODO
diff --git a/debian/_base/applications/kooldock/debian/menu b/debian/_base/applications/kooldock/debian/menu
new file mode 100644
index 000000000..785806bc3
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/menu
@@ -0,0 +1,4 @@
+?package(kooldock-trinity):needs="X11"\
+ section="Apps/System"\
+ title="kooldock"\
+ command="/opt/trinity/bin/kooldock"
diff --git a/debian/_base/applications/kooldock/debian/rules b/debian/_base/applications/kooldock/debian/rules
new file mode 100755
index 000000000..e5c16cf8a
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/kooldock/debian/source/format b/debian/_base/applications/kooldock/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kooldock/debian/source/options b/debian/_base/applications/kooldock/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kooldock/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*