summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kstreamripper/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kstreamripper/debian')
-rw-r--r--debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk227
-rw-r--r--debian/_base/applications/kstreamripper/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kstreamripper/debian/changelog62
-rw-r--r--debian/_base/applications/kstreamripper/debian/compat1
-rw-r--r--debian/_base/applications/kstreamripper/debian/control17
-rw-r--r--debian/_base/applications/kstreamripper/debian/copyright25
-rw-r--r--debian/_base/applications/kstreamripper/debian/dirs3
-rw-r--r--debian/_base/applications/kstreamripper/debian/docs2
-rw-r--r--debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu2
-rw-r--r--debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postinst14
-rw-r--r--debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postrm19
-rw-r--r--debian/_base/applications/kstreamripper/debian/kstreamripper.132
-rw-r--r--debian/_base/applications/kstreamripper/debian/patches/.gitignore0
-rwxr-xr-xdebian/_base/applications/kstreamripper/debian/rules19
-rw-r--r--debian/_base/applications/kstreamripper/debian/source/format1
-rw-r--r--debian/_base/applications/kstreamripper/debian/source/options6
16 files changed, 0 insertions, 449 deletions
diff --git a/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk b/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 24191b2cd..000000000
--- a/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,227 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl b/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kstreamripper/debian/changelog b/debian/_base/applications/kstreamripper/debian/changelog
deleted file mode 100644
index 7e7fdb95b..000000000
--- a/debian/_base/applications/kstreamripper/debian/changelog
+++ /dev/null
@@ -1,62 +0,0 @@
-kstreamripper-trinity (0.3.4-0ubuntu0) maverick; urgency=low
-
- * TDE upload
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Tue, 05 Jul 2011 14:35:00 -0600
-
-kstreamripper (0.3.4.debian1-2) unstable; urgency=low
-
- * Fix Desktop file. (Closes: #425028)
-
- -- Michael Ablassmeier <abi@debian.org> Tue, 29 May 2007 08:30:10 +0200
-
-kstreamripper (0.3.4.debian1-1) unstable; urgency=low
-
- * Update debian/copyright
- * New Maintainer E-Mail
- * Repackage as upstream tarball shipped byte compiled python
- modules which lead to FTBFS after python transition (due to
- changes in binary files), add .debian.1 to version.
- * Get rid of those .pyc files, remove them on cleanup.
- * Conforms with latest Standards Version 3.7.2
-
- -- Michael Ablassmeier <abi@debian.org> Thu, 31 Aug 2006 16:51:09 +0200
-
-kstreamripper (0.3.4-2) unstable; urgency=low
-
- * re-upload for transition
- * Bump up Standards-Version.
-
- -- Michael Ablassmeier <abi@grinser.de> Fri, 2 Sep 2005 11:39:28 +0200
-
-kstreamripper (0.3.4-1) unstable; urgency=low
-
- * New upstream release
- * Build-Depend on scons (upstream uses new build system)
- * Small update for debian/copyright
-
- -- Michael Ablassmeier <abi@grinser.de> Sat, 14 May 2005 18:22:57 +0200
-
-kstreamripper (0.3-1) unstable; urgency=low
-
- * New Upstream release (Closes: #265946)
- * Add README.Debian-source
- * Include gnome.mk (dh_desktop ...)
-
- -- Michael Ablassmeier <abi@grinser.de> Tue, 19 Apr 2005 16:36:27 +0200
-
-kstreamripper (0.2-2) unstable; urgency=low
-
- * Do it the cdbs way.
- * Register .desktop file using dh_desktop
- * Slight update for debian/copyright
-
- -- Michael Ablassmeier <abi@grinser.de> Thu, 7 Apr 2005 12:55:16 +0200
-
-kstreamripper (0.2-1) unstable; urgency=low
-
- * Initial Release. (Closes: #245862)
- * Sponsored Upload by Alexander Wirt <formorer@debian.org>
-
- -- Michael Ablassmeier <abi@grinser.de> Sun, 25 Apr 2004 19:52:42 +0200
-
diff --git a/debian/_base/applications/kstreamripper/debian/compat b/debian/_base/applications/kstreamripper/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/debian/_base/applications/kstreamripper/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/_base/applications/kstreamripper/debian/control b/debian/_base/applications/kstreamripper/debian/control
deleted file mode 100644
index 8a6590104..000000000
--- a/debian/_base/applications/kstreamripper/debian/control
+++ /dev/null
@@ -1,17 +0,0 @@
-Source: kstreamripper-trinity
-Section: sound
-Priority: optional
-Maintainer: Michael Ablassmeier <abi@debian.org>
-Build-Depends: debhelper (>= 9~), cdbs, tdelibs14-trinity-dev, cmake, quilt
-Standards-Version: 3.8.4
-
-Package: kstreamripper-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, streamripper
-Replaces: kstreamripper-trinity (<< 4:14.0.0~)
-Breaks: kstreamripper-trinity (<< 4:14.0.0~)
-Description: TDE frontend for streamripper
- KStreamRipper is a small frontend for the streamripper command
- line utility. Streamripper captures internet shoutcast radio streams
- on your harddisk and splits them up in mp3 files. KStreamRipper helps
- you with managing/ripping your preferred streams.
diff --git a/debian/_base/applications/kstreamripper/debian/copyright b/debian/_base/applications/kstreamripper/debian/copyright
deleted file mode 100644
index 61d405298..000000000
--- a/debian/_base/applications/kstreamripper/debian/copyright
+++ /dev/null
@@ -1,25 +0,0 @@
-This package was debianized by Michael Ablassmeier <abi@grinser.de> on
-Sun, 25 Apr 2004 19:52:42 +0200.
-
-It was downloaded from <http://kstreamripper.tuxipuxi.de/>
-
-Copyright Holder: Michael Goettsche <mail@tuxipuxi.de>
-
-License:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/kstreamripper/debian/dirs b/debian/_base/applications/kstreamripper/debian/dirs
deleted file mode 100644
index a59ccc8af..000000000
--- a/debian/_base/applications/kstreamripper/debian/dirs
+++ /dev/null
@@ -1,3 +0,0 @@
-usr/bin
-usr/share/applications
-usr/share/pixmaps
diff --git a/debian/_base/applications/kstreamripper/debian/docs b/debian/_base/applications/kstreamripper/debian/docs
deleted file mode 100644
index 6f12db508..000000000
--- a/debian/_base/applications/kstreamripper/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-AUTHORS
-README
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu
deleted file mode 100644
index f2cfe85c6..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu
+++ /dev/null
@@ -1,2 +0,0 @@
-?package(kstreamripper-trinity): needs="X11" section="Apps/Sound" title="Kstreamripper" \
- longtitle="Streamripper Frontend" command="/opt/trinity/bin/kstreamripper"
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postinst b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postinst
deleted file mode 100644
index f5542ab64..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postinst
+++ /dev/null
@@ -1,14 +0,0 @@
-#! /bin/sh
-set -e
-
-if [ "$1" = "configure" ]; then
- if [ -x /usr/bin/update-desktop-database ] ; then
- /usr/bin/update-desktop-database -q
- fi
-fi
-
-
-#DEBHELPER#
-
-exit 0
-
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postrm b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postrm
deleted file mode 100644
index 5209bcb38..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.postrm
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh
-set -e
-
-case "$1" in
- purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
- if [ -x "`which update-desktop-database 2>/dev/null`" ]; then
- update-desktop-database -q
- fi
- ;;
-
- *)
- echo "postrm called with unknown argument \`$1'" >&2
- exit 1
-
-esac
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper.1 b/debian/_base/applications/kstreamripper/debian/kstreamripper.1
deleted file mode 100644
index 3129be689..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper.1
+++ /dev/null
@@ -1,32 +0,0 @@
-.TH "KSTREAMRIPPER" "1" "Apr 26, 2004" "Michael Ablassmeier" "sound"
-.SH "NAME"
-kstreamripper \- TDE frontend for streamripper
-.SH "SYNOPSIS"
-.B kstreamripper [Qt\-options] [TDE\-options]
-.SH "DESCRIPTION"
-KStreamRipper is a small frontend for the streamripper command
-line utility. Streamripper captures internet shoutcast radio streams
-on your harddisk and splits them up in mp3 files. KStreamRipper helps
-you with managing/ripping your preferred streams.
-
-.SH "OPTIONS"
-.IP "\fB\-\-help\fR"
-Show help about options
-.IP "\fB\-\-help\-qt\fR"
-Show Qt specific options
-.IP "\fB\-\-help\-tde\fR"
-Show TDE specific options
-.IP "\fB\-\-help\-all\fR"
-Show all options
-.IP "\fB\-\-author\fR"
-Show author information
-.IP "\fB\-v, \-\-version\fR"
-Show version information
-.IP "\fB\-\-license\fR"
-Show license information
-.IP "\fB\-\-\fR"
-End of options
-.SH "SEE ALSO"
-streamripper(1)
-.SH "AUTHOR"
-2004 \- Created by Michael Ablassmeier (abi@grinser.de) for the Debian Project.
diff --git a/debian/_base/applications/kstreamripper/debian/patches/.gitignore b/debian/_base/applications/kstreamripper/debian/patches/.gitignore
deleted file mode 100644
index e69de29bb..000000000
--- a/debian/_base/applications/kstreamripper/debian/patches/.gitignore
+++ /dev/null
diff --git a/debian/_base/applications/kstreamripper/debian/rules b/debian/_base/applications/kstreamripper/debian/rules
deleted file mode 100755
index 18aa16b96..000000000
--- a/debian/_base/applications/kstreamripper/debian/rules
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/kstreamripper/debian/source/format b/debian/_base/applications/kstreamripper/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/debian/_base/applications/kstreamripper/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/debian/_base/applications/kstreamripper/debian/source/options b/debian/_base/applications/kstreamripper/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/debian/_base/applications/kstreamripper/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*