summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kxmleditor
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kxmleditor')
-rw-r--r--debian/_base/applications/kxmleditor/debian/cdbs/debian-tde.mk218
-rw-r--r--debian/_base/applications/kxmleditor/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kxmleditor/debian/changelog187
-rw-r--r--debian/_base/applications/kxmleditor/debian/compat1
-rw-r--r--debian/_base/applications/kxmleditor/debian/control18
-rw-r--r--debian/_base/applications/kxmleditor/debian/copyright26
-rw-r--r--debian/_base/applications/kxmleditor/debian/docs3
-rw-r--r--debian/_base/applications/kxmleditor/debian/menu6
-rw-r--r--debian/_base/applications/kxmleditor/debian/patches/series1
-rwxr-xr-xdebian/_base/applications/kxmleditor/debian/rules19
-rw-r--r--debian/_base/applications/kxmleditor/debian/source/format1
-rw-r--r--debian/_base/applications/kxmleditor/debian/source/options6
12 files changed, 0 insertions, 505 deletions
diff --git a/debian/_base/applications/kxmleditor/debian/cdbs/debian-tde.mk b/debian/_base/applications/kxmleditor/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 7a55130b2..000000000
--- a/debian/_base/applications/kxmleditor/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,218 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/debian/_base/applications/kxmleditor/debian/cdbs/versions.pl b/debian/_base/applications/kxmleditor/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/debian/_base/applications/kxmleditor/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kxmleditor/debian/changelog b/debian/_base/applications/kxmleditor/debian/changelog
deleted file mode 100644
index a1da5ef32..000000000
--- a/debian/_base/applications/kxmleditor/debian/changelog
+++ /dev/null
@@ -1,187 +0,0 @@
-kxmleditor-trinity (1.1.4-4debian7.0.0+0) wheezy; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Sat, 26 Mar 2016 11:50:05 +0100
-
-kxmleditor (1.1.4-3.1) unstable; urgency=low
-
- * Non-maintainer upload to fix Failure To Build From Source due to lack of
- compatibility with autoconf2.6. Thanks to Arjan Oosting for the patch.
- (Closes: #379813)
-
- -- Margarita Manterola <marga@debian.org> Wed, 2 Aug 2006 17:57:34 -0300
-
-kxmleditor (1.1.4-3) unstable; urgency=low
-
- * Acknowledge NMU (Closes: #334997), but revert it's changes, because the
- toolchain is fixed, and g++-3.4 is no longer needed to compile on arm,
- hppa and m68k.
- * Fix the installation directory of the user documentation: force it to be
- ${datadir}/doc/kde/HTML by exporting kde_htmldir with that value assigned
- (Closes: #330175).
- * Update libtool and other build system files. (Closes: #343953).
- - Add new patch: 01_admin_update.diff. Updates the admin/ directory to the
- one in branches/KDE/3.5 of the KDE SVN repository (revision 490256).
- - Build-Depend on autotools-dev and libtool, and copy config.guess,
- config.sub, libtool.m4, and ltmain.sh to the source in the clean target
- of debian/rules.
- * Small changes in debian/rules:
- - Use config.status as dependency of the "build" target, and remove the
- "configure" one.
- - Force C collation on sort invocations in debian/rules.
- * Update automake build-dependency to automake1.9.
- * Raise debhelper compatibility level to 5 (no changes required).
- * Update debian/watch to version 3.
- * Use lowercase in the manpage for the name of the program.
- * Raised Standards-Version to 3.7.2.0 (no changes required).
-
- -- Alejandro Exojo Piqueras <suy@badopi.org> Tue, 16 May 2006 14:31:54 +0200
-
-kxmleditor (1.1.4-2.1) unstable; urgency=medium
-
- * NMU during BSP
- * Compile with g++-3.4 on arm/hppa/m68k to work around ICE
- with g++-4.0 (Closes: #334997)
-
- -- Frank Lichtenheld <djpig@debian.org> Fri, 28 Oct 2005 22:14:21 +0200
-
-kxmleditor (1.1.4-2) unstable; urgency=low
-
- * Rebuilt against a kdelibs version compiled with GCC 4 (Closes: #327975).
- * No longer use admin/debianrules and debian/debiandirs (and remove the
- latter from the package). Now the prefix is retrieved using kde-config,
- and DEB_BUILD_OPTIONS is honoured in rules directly: the check for "noopt"
- now sets CXXFLAGS instead of CFLAGS, and the variable is exported before
- configuration. "nostrip" is honoured by dh_strip.
- * Add the patch 04_german_po_fixes.diff, made by Jens Seidel, which fixes
- some mistakes in the German translation (Closes: #314019).
- * Raised Standards-Version to 3.6.2 (no changes required).
-
- -- Alejandro Exojo Piqueras <suy@badopi.org> Sat, 17 Sep 2005 19:10:19 +0200
-
-kxmleditor (1.1.4-1) unstable; urgency=low
-
- * New upstream release (Closes: #277487).
- * New maintainer (Closes: #255299), thanks Mike for the previous work.
- * Added a watch file for DEHS (by Mike Hommey).
- * Corrected the description by a native English speaker. ;-)
- * Moved section from "editors" to "kde".
- * Updated "Build-Depends": changed libqt3-compat-headers to qt3-dev-tools
- greater or equal than 3.3 (because it contains files created with
- designer 3.3) and added automake1.7 and sharutils (for future uuencoded
- diffs).
- * Add "Build-Conflict" with old autoconf/automake versions.
- * Reflex the work of all mantainers, and added the GPL excerpt in
- debian/copyright.
- * Add scapes to unscaped dashes in manpage.
- * Quoted all entries, and deleted obsolete "kderemove" in debian/menu.
- * debian/rules:
- - Keep change from Frank Lichtenheld's NMU, because it is still needed to
- create in the correct place the UIC-generated headers.
- - Delete stamps at the beggining of clean target. (Policy 4.8)
- - Moved the creation of the symbolic link to kxmleditor.links.
- - Add support for build directory different from source directory.
- - Pass --enable-final to configure.
- - Remove dh_installinfo and lintian overrides.
- - Moved DH_COMPAT to debian/compat.
- * Removed shlibs.local and kxmleditor.lintian, aren't necessary anymore.
- * Added a patch-system and two patches:
- - patches/02_part_makefile_am.diff: Fixes LIBADD and installation prefixes.
- - patches/03_include_mocs.diff: Includes MOC files in the source files.
-
- -- Alejandro Exojo Piqueras <suy@badopi.org> Fri, 07 Jan 2005 12:05:07 +0100
-
-kxmleditor (1.0.0-1.1) unstable; urgency=low
-
- * NMU
- * Fix build problems with Qt 3.3 by forcing the regeneration
- of all source files. Fix suggested by Ben Burton (Closes: #265680)
-
- -- Frank Lichtenheld <djpig@debian.org> Thu, 16 Sep 2004 01:39:40 +0200
-
-kxmleditor (1.0.0-1) unstable; urgency=low
-
- * New upstream release
- * debian/rules: fixed once and for all the CFLAGS setting.
-
- -- Mike Hommey <mh@glandium.org> Tue, 27 Jan 2004 16:33:57 +0900
-
-kxmleditor (0.9.2-1) unstable; urgency=low
-
- * New upstream release
- * Bumped Standards-Version to 3.6.1.
- * debian/rules:
- - Removed the unneeded INSTALL_PROGRAM environment variable setting.
- - Removed the alpha workaround, which should not be needed anymore.
- - Fixed the configure call so that the build system works as expected
- (for CFLAGS and arch detection)
- - Added an install-stamp rule.
- - Cleaned up unneeded variables.
-
- -- Mike Hommey <mh@glandium.org> Wed, 14 Jan 2004 19:40:56 +0900
-
-kxmleditor (0.9.1-1) unstable; urgency=low
-
- * New upstream release
-
- -- Mike Hommey <mh@glandium.org> Mon, 5 Jan 2004 16:02:28 +0900
-
-kxmleditor (0.9.0-1) unstable; urgency=low
-
- * New upstream release
-
- -- Mike Hommey <mh@glandium.org> Sat, 27 Dec 2003 18:23:47 +0900
-
-kxmleditor (0.8.4-1) unstable; urgency=low
-
- * New upstream release
-
- -- Mike Hommey <mh@glandium.org> Fri, 12 Dec 2003 13:44:09 +0900
-
-kxmleditor (0.8.1-4) unstable; urgency=low
-
- * NMU
- * Added lintian override for the changed menu
-
- -- Uli Martens <uli@youam.net> Mon, 14 Jul 2003 20:59:39 +0200
-
-kxmleditor (0.8.1-3) unstable; urgency=low
-
- * Modify debian menu so that kxmleditor doesn't appear twice in kde
- menus
-
- -- Mike Hommey <mh@glandium.org> Thu, 10 Apr 2003 01:06:34 +0200
-
-kxmleditor (0.8.1-2) unstable; urgency=low
-
- * Merged libxmleditorpart1 and kxmleditor, since libs are KParts
- components and not shared libraries.
- * Fixed dh_compress usage to avoid compression of kxmleditor documentation.
- * Add lintian overrides.
- * Adjust dependency to debhelper >= 4.0.0.
-
- -- Mike Hommey <mh@glandium.org> Thu, 3 Apr 2003 02:58:42 +0200
-
-kxmleditor (0.8.1-1) unstable; urgency=low
-
- * New maintainer. Closes: #187049
- * New upstream release. Closes: #181833
- * Changed libxmleditor1 to libxmleditorpart1 to fit new upstream
- library name.
- * Updated to Standards-Version 3.5.9.
-
- -- Mike Hommey <mh@glandium.org> Wed, 2 Apr 2003 23:27:23 +0200
-
-kxmleditor (0.7.1-2) unstable; urgency=low
-
- * Added work-around for broken alpha build in debian/rules.
-
- -- Joerg Jaspert <joerg@debian.org> Tue, 30 Apr 2002 23:55:03 +0200
-
-kxmleditor (0.7.1-1) unstable; urgency=low
-
- * Initial Release (closes: #113797)
-
- -- Joerg Jaspert (JJ) <joerg@goliathbbs.dnsalias.net> Thu, 11 Apr 2002 00:09:53 +0200
-
diff --git a/debian/_base/applications/kxmleditor/debian/compat b/debian/_base/applications/kxmleditor/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/debian/_base/applications/kxmleditor/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/debian/_base/applications/kxmleditor/debian/control b/debian/_base/applications/kxmleditor/debian/control
deleted file mode 100644
index c0fef6f7f..000000000
--- a/debian/_base/applications/kxmleditor/debian/control
+++ /dev/null
@@ -1,18 +0,0 @@
-Source: kxmleditor-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-X-Original-Maintainer: Jose Luis Tallon <jltallon@adv-solutions.net>
-Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdelibs-trinity-dev
-Standards-Version: 3.8.0
-
-Package: kxmleditor-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: XML Editor for TDE
- KXML Editor is a simple program, that displays and edits the contents of an
- XML file. It can be embedded in Quanta, and used with DCOP.
- .
- The left side contains a tree representing the XML document structure. The
- right side contains a list of attributes for the selected XML element and its
- contents.
diff --git a/debian/_base/applications/kxmleditor/debian/copyright b/debian/_base/applications/kxmleditor/debian/copyright
deleted file mode 100644
index b3c8ee9e2..000000000
--- a/debian/_base/applications/kxmleditor/debian/copyright
+++ /dev/null
@@ -1,26 +0,0 @@
-This package was debianized by Joerg Jaspert (JJ) <joerg@goliathbbs.dnsalias.net> on
-Tue, 9 Apr 2002 22:29:11 +0200.
-It was mantained by Mike Hommey <mh@glandium.org> since 2 Apr 2003.
-It is actually mantained by Alejandro Exojo Piqueras <suy@badopi.org>
-
-It was downloaded from http://kxmleditor.sourceforge.net/
-
-Upstream Authors: Lumir Vanek <lvanek@users.sourceforge.net>
- Olaf Hartig <olaf@users.sourceforge.net>
- Mateusz Korniak <matkor@users.sourceforge.net>
-
-Copyright: (c) 2001-2004, The KXML Editor Developers
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2
- of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
diff --git a/debian/_base/applications/kxmleditor/debian/docs b/debian/_base/applications/kxmleditor/debian/docs
deleted file mode 100644
index ca0272abf..000000000
--- a/debian/_base/applications/kxmleditor/debian/docs
+++ /dev/null
@@ -1,3 +0,0 @@
-AUTHORS
-README
-TODO
diff --git a/debian/_base/applications/kxmleditor/debian/menu b/debian/_base/applications/kxmleditor/debian/menu
deleted file mode 100644
index 4fdffebfe..000000000
--- a/debian/_base/applications/kxmleditor/debian/menu
+++ /dev/null
@@ -1,6 +0,0 @@
-?package(kxmleditor-trinity):\
- needs="X11"\
- section="Apps/Editors"\
- title="kxmleditor"\
- hints="TDE"\
- command="/opt/trinity/bin/kxmleditor"
diff --git a/debian/_base/applications/kxmleditor/debian/patches/series b/debian/_base/applications/kxmleditor/debian/patches/series
deleted file mode 100644
index 8b1378917..000000000
--- a/debian/_base/applications/kxmleditor/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/debian/_base/applications/kxmleditor/debian/rules b/debian/_base/applications/kxmleditor/debian/rules
deleted file mode 100755
index cee2a3058..000000000
--- a/debian/_base/applications/kxmleditor/debian/rules
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/kxmleditor/debian/source/format b/debian/_base/applications/kxmleditor/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/debian/_base/applications/kxmleditor/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/debian/_base/applications/kxmleditor/debian/source/options b/debian/_base/applications/kxmleditor/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/debian/_base/applications/kxmleditor/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*