summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/potracegui/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/potracegui/debian')
-rw-r--r--debian/_base/applications/potracegui/debian/cdbs/debian-tde.mk218
-rw-r--r--debian/_base/applications/potracegui/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/potracegui/debian/changelog129
-rw-r--r--debian/_base/applications/potracegui/debian/compat1
-rw-r--r--debian/_base/applications/potracegui/debian/control22
-rw-r--r--debian/_base/applications/potracegui/debian/copyright21
-rw-r--r--debian/_base/applications/potracegui/debian/dirs3
-rw-r--r--debian/_base/applications/potracegui/debian/docs2
-rw-r--r--debian/_base/applications/potracegui/debian/potracegui-trinity.menu4
-rwxr-xr-xdebian/_base/applications/potracegui/debian/rules19
-rw-r--r--debian/_base/applications/potracegui/debian/source/format1
-rw-r--r--debian/_base/applications/potracegui/debian/source/options6
12 files changed, 0 insertions, 445 deletions
diff --git a/debian/_base/applications/potracegui/debian/cdbs/debian-tde.mk b/debian/_base/applications/potracegui/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 7a55130b2..000000000
--- a/debian/_base/applications/potracegui/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,218 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/debian/_base/applications/potracegui/debian/cdbs/versions.pl b/debian/_base/applications/potracegui/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/debian/_base/applications/potracegui/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/potracegui/debian/changelog b/debian/_base/applications/potracegui/debian/changelog
deleted file mode 100644
index 87afc2863..000000000
--- a/debian/_base/applications/potracegui/debian/changelog
+++ /dev/null
@@ -1,129 +0,0 @@
-potracegui-trinity (1.3-2.0ubuntu1) karmic; urgency=low
-
- * Karmic rebuild for Trinity
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 06 Mar 2010 06:02:00 -0600
-
-potracegui (1.3-2.3ubuntu2) jaunty; urgency=low
-
- * debian/rules: added --without-arts parameter to configure script call to
- rebuild without arts support (LP: #320915)
-
- -- Fabrice Coutadeur <fabricesp@ubuntu.com> Fri, 17 Apr 2009 05:08:31 +0000
-
-potracegui (1.3-2.3ubuntu1) intrepid; urgency=low
-
- * Merge from Debian unstable (LP: #229066). Remaining Ubuntu changes:
- - debian/control: modify Maintainer to Ubuntu MOTU Developers
- - debian/rules: add dh_icon
- * Update Standards-Version to 3.7.3.
- * Fix debian-rules-ignores-make-clean-error lintian warning.
- * Fix debhelper-script-needs-versioned-build-depends lintian warning.
-
- -- Devid Filoni <d.filoni@techemail.com> Sat, 22 Mar 2008 15:31:50 +0100
-
-potracegui (1.3-2.3) unstable; urgency=medium
-
- * Non-maintainer upload.
- * Fix FTBFS with GCC 4.3 (Closes: #417484).
-
- -- Luk Claes <luk@debian.org> Fri, 14 Mar 2008 19:01:38 +0000
-
-potracegui (1.3-2.2ubuntu3) hardy; urgency=low
-
- * debian/rules: change dh_iconcache to dh_icons to fix FTFBS. (LP: #204263)
-
- -- Andrea Colangelo <warp10@ubuntu.com> Thu, 20 Mar 2008 14:41:57 +0100
-
-potracegui (1.3-2.2ubuntu2) gutsy; urgency=low
-
- * debian/control: Update maintainer fields according to debian-
- maintainer-field spec.
-
- -- Martin Pitt <martin.pitt@ubuntu.com> Wed, 15 Aug 2007 08:09:41 +0000
-
-potracegui (1.3-2.2ubuntu1) dapper; urgency=low
-
- * debian/rules: added dh_iconcache
-
- -- Szilveszter Farkas (Phanatic) <Szilveszter.Farkas@gmail.com> Mon, 8 May 2006 10:26:45 +0200
-
-potracegui (1.3-2.2) unstable; urgency=medium
-
- * Non-maintainer upload.
- * Fix FTBFS due to more restrictive coreutils. (Closes: #340010)
- Patch by Roland Stigge.
-
- -- Adeodato Simó <dato@net.com.org.es> Tue, 13 Dec 2005 03:40:56 +0100
-
-potracegui (1.3-2.1) unstable; urgency=low
-
- * Non-maintainer upload.
- * Rebuild for the Qt/KDE transition (Closes: #327984)
- * German PO file corrections (Closes: #313817)
-
- -- Luk Claes <luk@debian.org> Fri, 30 Sep 2005 17:24:45 +0200
-
-potracegui (1.3-2) unstable; urgency=medium
-
- * Urgency medium, cause without this fix package is almost unusable
- for people using German locale.
- * Closes: #303718: translated text is passed as option to potrace
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Sat, 30 Apr 2005 23:04:34 +0200
-
-potracegui (1.3-1) unstable; urgency=low
-
- * New upstream release
- - german translation
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Sat, 5 Mar 2005 12:46:14 +0100
-
-potracegui (1.2-1) unstable; urgency=low
-
- * New upstream release
- - added support for autotrace
- * added upstream author to manpage
- * Suggests autotrace now
- * mention autotrace in description
- * using dh_installman now
- * added watch file
- * various other minor fixes to make sponsor happy
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Tue, 4 Jan 2005 09:30:40 +0100
-
-potracegui (1.1-1) unstable; urgency=low
-
- * New upstream release
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Wed, 17 Nov 2004 07:04:33 +0100
-
-potracegui (1.0-1) unstable; urgency=low
-
- * new upstream release.
- * removed recommondation for libmagick, as it is no longer needed.
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Tue, 22 Jun 2004 14:56:45 +0200
-
-potracegui (0.5.1-3) unstable; urgency=low
-
- * added autotool-dev to Build-Depends.
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Thu, 10 Jun 2004 16:00:58 +0200
-
-potracegui (0.5.1-2) unstable; urgency=low
-
- * adjusting the copyright file and the package description.
- * fixed Build-Depends.
- * Closes: #253205: ITP: potracegui -- a KDE frontend for potrace.
- * Recommends now imagemagick, needed for displaying tracing results.
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Tue, 8 Jun 2004 09:40:05 +0200
-
-potracegui (0.5.1-1) unstable; urgency=low
-
- * Initial Release.
- * My first debian package.
-
- -- Christoph Wegscheider <christoph.wegscheider@wegi.net> Sat, 5 Jun 2004 14:59:34 +0200
-
diff --git a/debian/_base/applications/potracegui/debian/compat b/debian/_base/applications/potracegui/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/debian/_base/applications/potracegui/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/debian/_base/applications/potracegui/debian/control b/debian/_base/applications/potracegui/debian/control
deleted file mode 100644
index 98ac70cce..000000000
--- a/debian/_base/applications/potracegui/debian/control
+++ /dev/null
@@ -1,22 +0,0 @@
-Source: potracegui-trinity
-Section: graphics
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-XSBC-Original-Maintainer: Christoph Wegscheider <christoph.wegscheider@wegi.net>
-Uploaders: Bartosz Fenski <fenio@debian.org>
-Build-Depends: debhelper (>= 7.0.50~), cdbs, quilt, cmake, tdelibs14-trinity-dev
-Standards-Version: 3.8.4
-
-Package: potracegui-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, potrace
-Replaces: potracegui-trinity (<< 4:14.0.0~)
-Breaks: potracegui-trinity (<< 4:14.0.0~)
-Suggests: autotrace
-Description: TDE frontend for potrace [Trinity]
- A TDE interface for the commandline tracing tools potrace and/or autotrace. It
- supports drag and drop as well as all image types recognized by TDE, which are
- a lot more than the 4 recognized by the potrace commandline tool. Loading of
- remote files (web, ftp, ...) is also supported.
- .
- Homepage: http://potracegui.sourceforge.net
diff --git a/debian/_base/applications/potracegui/debian/copyright b/debian/_base/applications/potracegui/debian/copyright
deleted file mode 100644
index f3437d1cc..000000000
--- a/debian/_base/applications/potracegui/debian/copyright
+++ /dev/null
@@ -1,21 +0,0 @@
-This package was debianized by Christoph Wegscheider <christoph.wegscheider@wegi.net> on
-Thu, 5 Jun 2004 15:05:07 +0200.
-
-It was downloaded from http://potracegui.sourceforge.net/
-
-Upstream Author: Antonio Fasolato <Antonio.Fasolato@poste.it>
-
-Copyright:
-
-Copyright 2004 Antonio Fasolato <Antonio.Fasolato@poste.it>
-
-License:
-
-This program is free software; you can redistribute it and/or modify it
-under the terms of the GNU General Public License as published by the
-Free Software Foundation; either version 2, or (at your option) any
-later version.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in the file `/usr/share/common-licenses/GPL'.
-
diff --git a/debian/_base/applications/potracegui/debian/dirs b/debian/_base/applications/potracegui/debian/dirs
deleted file mode 100644
index 34e17c1b8..000000000
--- a/debian/_base/applications/potracegui/debian/dirs
+++ /dev/null
@@ -1,3 +0,0 @@
-opt/trinity/bin
-opt/trinity/share/applnk/Graphics
-opt/trinity/share/doc/tde
diff --git a/debian/_base/applications/potracegui/debian/docs b/debian/_base/applications/potracegui/debian/docs
deleted file mode 100644
index ba8894c15..000000000
--- a/debian/_base/applications/potracegui/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-README
-
diff --git a/debian/_base/applications/potracegui/debian/potracegui-trinity.menu b/debian/_base/applications/potracegui/debian/potracegui-trinity.menu
deleted file mode 100644
index 04719df19..000000000
--- a/debian/_base/applications/potracegui/debian/potracegui-trinity.menu
+++ /dev/null
@@ -1,4 +0,0 @@
-?package(potracegui-trinity):needs="X11" section="Apps/Graphics"\
- title="potracegui" command="/opt/trinity/bin/potracegui"\
- hints="TDE frontend for tracing programs"
-
diff --git a/debian/_base/applications/potracegui/debian/rules b/debian/_base/applications/potracegui/debian/rules
deleted file mode 100755
index 18aa16b96..000000000
--- a/debian/_base/applications/potracegui/debian/rules
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/potracegui/debian/source/format b/debian/_base/applications/potracegui/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/debian/_base/applications/potracegui/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/debian/_base/applications/potracegui/debian/source/options b/debian/_base/applications/potracegui/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/debian/_base/applications/potracegui/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*