summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tdenetworkmanager/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/tdenetworkmanager/debian')
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/README.source3
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/cdbs/debian-qt-kde.mk99
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/cdbs/kde.mk89
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/changelog5
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/compat1
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/control26
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/copyright34
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/manpages1
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/menu6
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.lintian5
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.postinst12
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/tdenetworkmanager/debian/rules24
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/source/format1
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/source/options6
-rw-r--r--debian/_base/applications/tdenetworkmanager/debian/tdenetworkmanager.1145
17 files changed, 476 insertions, 0 deletions
diff --git a/debian/_base/applications/tdenetworkmanager/debian/README.source b/debian/_base/applications/tdenetworkmanager/debian/README.source
new file mode 100644
index 000000000..96fb271ab
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/README.source
@@ -0,0 +1,3 @@
+This package uses the quilt patch management system.
+
+Please refer to /usr/share/doc/quilt/README.source for further information.
diff --git a/debian/_base/applications/tdenetworkmanager/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/tdenetworkmanager/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..2dff59226
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,99 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/tdenetworkmanager/debian/cdbs/kde.mk b/debian/_base/applications/tdenetworkmanager/debian/cdbs/kde.mk
new file mode 100644
index 000000000..f5d237249
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/cdbs/kde.mk
@@ -0,0 +1,89 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+# include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/tdenetworkmanager/debian/cdbs/versions.pl b/debian/_base/applications/tdenetworkmanager/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/tdenetworkmanager/debian/changelog b/debian/_base/applications/tdenetworkmanager/debian/changelog
new file mode 100644
index 000000000..b54d300ab
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/changelog
@@ -0,0 +1,5 @@
+tdenetworkmanager-trinity (1:0.0-0ubuntu0) karmic; urgency=low
+
+ * Initial release
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 10 Sep 2012 09:02:00 -0600
diff --git a/debian/_base/applications/tdenetworkmanager/debian/compat b/debian/_base/applications/tdenetworkmanager/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/tdenetworkmanager/debian/control b/debian/_base/applications/tdenetworkmanager/debian/control
new file mode 100644
index 000000000..fa2079452
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/control
@@ -0,0 +1,26 @@
+Source: tdenetworkmanager-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: cdbs,
+ debhelper (>= 7.0.50~),
+ pkg-config,
+ tdelibs14-trinity-dev,
+ libiw-dev,
+ libnl-3-dev | libnl-dev (>= 1.1),
+ quilt,
+ libtool, libltdl-dev, cmake
+Standards-Version: 3.8.4
+Homepage: http://www.trinitydesktop.org/
+
+Package: network-manager-tde
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, network-manager (>= 0.7.0)
+Replaces: network-manager-kde-trinity (<< 4:14.0.0~)
+Breaks: network-manager-kde-trinity (<< 4:14.0.0~)
+Recommends: tdewalletmanager-trinity
+Provides: tdenetworkmanager-trinity
+Description: TDE systray applet for controlling networking [Trinity]
+ Systray applet for controlling network connections managed by
+ a TDE network backend. It is mainly written for Trinity but also works for
+ other desktop environments like GNOME or Xfce.
diff --git a/debian/_base/applications/tdenetworkmanager/debian/copyright b/debian/_base/applications/tdenetworkmanager/debian/copyright
new file mode 100644
index 000000000..2490de254
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/copyright
@@ -0,0 +1,34 @@
+This package was debianized by Michael Biebl <biebl@teco.edu> on
+Fri, 3 Feb 2006 05:53:06 +0100.
+
+It was downloaded from http://www.opensuse.org
+
+Upstream Authors:
+ Timo Hoenig <thoenig@suse.de>
+ Will Stephenson <wstephenson@suse.de>
+ Stefan Bogner <sbogner@suse.de>
+ Helmut Schaa <hschaa@suse.de>
+ Valentine Sinitsyn <e_val@inbox.ru>
+
+Copyright:
+ Copyright (C) 2005, 2006 Novell, Inc.
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
diff --git a/debian/_base/applications/tdenetworkmanager/debian/manpages b/debian/_base/applications/tdenetworkmanager/debian/manpages
new file mode 100644
index 000000000..0707d198a
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/manpages
@@ -0,0 +1 @@
+debian/tdenetworkmanager.1
diff --git a/debian/_base/applications/tdenetworkmanager/debian/menu b/debian/_base/applications/tdenetworkmanager/debian/menu
new file mode 100644
index 000000000..7172f7ae8
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/menu
@@ -0,0 +1,6 @@
+?package(network-manager-tde): \
+ needs="X11" \
+ section="Applications/Network/Monitoring" \
+ title="TDENetworkManager" \
+ longtitle="A TDE frontend for NetworkManager" \
+ command="/opt/trinity/bin/tdenetworkmanager"
diff --git a/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.lintian b/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.lintian
new file mode 100644
index 000000000..22bd678da
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.lintian
@@ -0,0 +1,5 @@
+network-manager-tde: no-shlibs-control-file opt/trinity/lib/libtdeinit_tdenetworkmanager.so
+network-manager-tde: package-name-doesnt-match-sonames libtdeinit-tdenetworkmanager
+network-manager-tde: postinst-must-call-ldconfig opt/trinity/lib/libtdeinit_tdenetworkmanager.so
+network-manager-tde: postrm-should-call-ldconfig opt/trinity/lib/libtdeinit_tdenetworkmanager.so
+
diff --git a/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.postinst b/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.postinst
new file mode 100644
index 000000000..df7b9dba2
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/network-manager-tde.postinst
@@ -0,0 +1,12 @@
+#!/bin/sh
+# postinst script for network-manager-tde
+
+set -e
+
+if [ "$1" = "configure" ] ; then
+ ldconfig
+fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/_base/applications/tdenetworkmanager/debian/patches/series b/debian/_base/applications/tdenetworkmanager/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/patches/series
diff --git a/debian/_base/applications/tdenetworkmanager/debian/rules b/debian/_base/applications/tdenetworkmanager/debian/rules
new file mode 100755
index 000000000..e7a182904
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
+-DWITH_OPENVPN="ON" -DWITH_VPNC="ON" -DWITH_PPTP="ON"
+
+DEB_INSTALL_DOCS_ALL := -XNEWS -XTODO
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/_base/applications/tdenetworkmanager/debian/source/format b/debian/_base/applications/tdenetworkmanager/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/tdenetworkmanager/debian/source/options b/debian/_base/applications/tdenetworkmanager/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/tdenetworkmanager/debian/tdenetworkmanager.1 b/debian/_base/applications/tdenetworkmanager/debian/tdenetworkmanager.1
new file mode 100644
index 000000000..0f1abef05
--- /dev/null
+++ b/debian/_base/applications/tdenetworkmanager/debian/tdenetworkmanager.1
@@ -0,0 +1,145 @@
+.\" This file was generated by kdemangen.pl
+.TH TDENETWORKMANAGER 1 "Feb 2006" "Trinity Desktop Environment" "A NetworkManager front-end for TDE"
+.SH NAME
+tdenetworkmanager
+\- A NetworkManager front-end for TDE
+.SH SYNOPSIS
+tdenetworkmanager [Qt\-options] [TDE\-options]
+.SH DESCRIPTION
+A NetworkManager front-end for TDE
+.SH OPTIONS
+.SS Generic options:
+.TP
+.B \-\-help
+Show help about options
+.TP
+.B \-\-help\-qt
+Show Qt specific options
+.TP
+.B \-\-help\-tde
+Show TDE specific options
+.TP
+.B \-\-help\-all
+Show all options
+.TP
+.B \-\-author
+Show author information
+.TP
+.B \-v, \-\-version
+Show version information
+.TP
+.B \-\-license
+Show license information
+.TP
+.B \-\-
+End of options
+.SS
+.SS TDE options:
+.TP
+.B \-\-caption <caption>
+Use 'caption' as name in the titlebar
+.TP
+.B \-\-icon <icon>
+Use 'icon' as the application icon
+.TP
+.B \-\-miniicon <icon>
+Use 'icon' as the icon in the titlebar
+.TP
+.B \-\-config <filename>
+Use alternative configuration file
+.TP
+.B \-\-dcopserver <server>
+Use the DCOP Server specified by 'server'
+.TP
+.B \-\-nocrashhandler
+Disable crash handler, to get core dumps
+.TP
+.B \-\-waitforwm
+Waits for a WM_NET compatible windowmanager
+.TP
+.B \-\-style <style>
+sets the application GUI style
+.TP
+.B \-\-geometry <geometry>
+sets the client geometry of the main widget - see man X for the argument format
+.TP
+.B \-\-nofork
+Don't run in the background.
+.SS Qt options:
+.TP
+.B \-\-display <displayname>
+Use the X-server display 'displayname'
+.TP
+.B \-\-session <sessionId>
+Restore the application for the given 'sessionId'
+.TP
+.B \-\-cmap
+Causes the application to install a private color
+map on an 8-bit display
+.TP
+.B \-\-ncols <count>
+Limits the number of colors allocated in the color
+cube on an 8-bit display, if the application is
+using the QApplication::ManyColor color
+specification
+.TP
+.B \-\-nograb
+tells Qt to never grab the mouse or the keyboard
+.TP
+.B \-\-dograb
+running under a debugger can cause an implicit
+-nograb, use -dograb to override
+.TP
+.B \-\-sync
+switches to synchronous mode for debugging
+.TP
+.B \-\-fn, \-\-font <fontname>
+defines the application font
+.TP
+.B \-\-bg, \-\-background <color>
+sets the default background color and an
+application palette (light and dark shades are
+calculated)
+.TP
+.B \-\-fg, \-\-foreground <color>
+sets the default foreground color
+.TP
+.B \-\-btn, \-\-button <color>
+sets the default button color
+.TP
+.B \-\-name <name>
+sets the application name
+.TP
+.B \-\-title <title>
+sets the application title (caption)
+.TP
+.B \-\-visual TrueColor
+forces the application to use a TrueColor visual on
+an 8-bit display
+.TP
+.B \-\-inputstyle <inputstyle>
+sets XIM (X Input Method) input style. Possible
+values are onthespot, overthespot, offthespot and
+root
+.TP
+.B \-\-im <XIM server>
+set XIM server
+.TP
+.B \-\-noxim
+disable XIM
+.TP
+.B \-\-reverse
+mirrors the whole layout of widgets
+.SS
+
+.SH SEE ALSO
+.BR networkmanager (1)
+.SH AUTHORS
+.nf
+Timo Hoenig <thoenig@suse.de>
+.br
+Stefan Bogner <sbogner@suse.de>
+.br
+Will Stephenson <wstephenson@suse.de>
+.br
+