summaryrefslogtreecommitdiffstats
path: root/debian/_base/core/tdeaddons/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/core/tdeaddons/debian/rules')
-rwxr-xr-xdebian/_base/core/tdeaddons/debian/rules45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/_base/core/tdeaddons/debian/rules b/debian/_base/core/tdeaddons/debian/rules
new file mode 100755
index 000000000..9dca91731
--- /dev/null
+++ b/debian/_base/core/tdeaddons/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --without-xmms --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --mandir=/opt/trinity/share/man
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
+DEB_DH_STRIP_ARGS := --dbg-package=tdeaddons-trinity-dbg
+
+DOC_HTML_PRUNE := konq-plugins-trinity/smbmounter
+
+binary-install/tdeaddons-tdefile-plugins-trinity::
+ install -p -D -m644 renamedlgplugins/README \
+ debian/$(cdbs_curpkg)/opt/trinity/share/doc/tdeaddons-tdefile-plugins/README.renamedlgplugins
+
+binary-install/knewsticker-scripts-trinity::
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/knewsticker/scripts/*.pl
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/knewsticker/scripts/*.py
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/knewsticker/scripts
+
+binary-install/kate-plugins-trinity::
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/kate/scripts/html-tidy.sh
+
+binary-install/konq-plugins-trinity::
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/imagerotation