summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies')
-rw-r--r--debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk2
-rw-r--r--debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk2
-rwxr-xr-xdebian/_base/dependencies/arts/debian/rules4
-rw-r--r--debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk2
4 files changed, 6 insertions, 4 deletions
diff --git a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
index 4eeb672b0..7a55130b2 100644
--- a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
@@ -95,6 +95,8 @@ ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
cdbs_kde_enable_debug = --enable-debug=full
endif
+DEB_BUILD_PARALLEL ?= true
+
cdbs_configure_flags += \
--with-qt-dir=/usr/share/qt3 \
--disable-rpath \
diff --git a/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
index 4eeb672b0..7a55130b2 100644
--- a/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
@@ -95,6 +95,8 @@ ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
cdbs_kde_enable_debug = --enable-debug=full
endif
+DEB_BUILD_PARALLEL ?= true
+
cdbs_configure_flags += \
--with-qt-dir=/usr/share/qt3 \
--disable-rpath \
diff --git a/debian/_base/dependencies/arts/debian/rules b/debian/_base/dependencies/arts/debian/rules
index 7f5debe08..c3167d04f 100755
--- a/debian/_base/dependencies/arts/debian/rules
+++ b/debian/_base/dependencies/arts/debian/rules
@@ -15,10 +15,6 @@ include debian/cdbs/debian-tde.mk
DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" -DWITH_GCC_VISIBILITY="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
-# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
-# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL = true
-
DEB_DH_STRIP_ARGS := --dbg-package=arts-trinity-dbg
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
diff --git a/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
index 4eeb672b0..7a55130b2 100644
--- a/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
@@ -95,6 +95,8 @@ ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
cdbs_kde_enable_debug = --enable-debug=full
endif
+DEB_BUILD_PARALLEL ?= true
+
cdbs_configure_flags += \
--with-qt-dir=/usr/share/qt3 \
--disable-rpath \