summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kchmviewer/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/applications/kchmviewer/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kchmviewer/debian/rules18
1 files changed, 4 insertions, 14 deletions
diff --git a/debian/lenny/applications/kchmviewer/debian/rules b/debian/lenny/applications/kchmviewer/debian/rules
index 72c3fd5bb..a496effa9 100755
--- a/debian/lenny/applications/kchmviewer/debian/rules
+++ b/debian/lenny/applications/kchmviewer/debian/rules
@@ -42,11 +42,10 @@ endif
-include debian/debiandirs
-build: patch debian/build-kde
+build: debian/build-kde
-patch: patch-stamp
-patch-stamp:
- dpatch apply-all
+debian/build-kde:
+ dh_testdir
! [ -f /usr/share/libtool/ltmain.sh ] || \
cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
! [ -f /usr/share/libtool/config/ltmain.sh ] || \
@@ -54,15 +53,6 @@ patch-stamp:
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
- touch patch-stamp
-
-unpatch:
- dpatch deapply-all
- $(RM) -rf patch-stamp debian/patched
-
-debian/build-kde:
- dh_testdir
# automake
# autoconf
test -e config.sub -a -L config.sub || \
@@ -74,7 +64,7 @@ debian/build-kde:
$(MAKE) -C build-kde
touch debian/build-kde
-clean: unpatch
+clean:
dh_testdir
dh_testroot
$(RM) -f build-stamp