summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/kmyfirewall/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/squeeze/applications/kmyfirewall/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/kmyfirewall/debian/rules128
1 files changed, 9 insertions, 119 deletions
diff --git a/debian/squeeze/applications/kmyfirewall/debian/rules b/debian/squeeze/applications/kmyfirewall/debian/rules
index 58260e9ca..bae3f5cf7 100755
--- a/debian/squeeze/applications/kmyfirewall/debian/rules
+++ b/debian/squeeze/applications/kmyfirewall/debian/rules
@@ -1,12 +1,11 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
@@ -16,116 +15,7 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
--include debian/debiandirs
-
-# To be used with kde-style admin subdirectories if desired.
-#debian/debiandirs: admin/debianrules
-# perl -w admin/debianrules echodirs > debian/debiandirs
-
-
-config.status:
- dh_testdir
-
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub admin/config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess admin/config.guess
-endif
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to configure the package.
- CFLAGS="$(CFLAGS)" PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
-
- dh_clean config.guess config.sub KMFIPTInterface/Makefile KMFSysTray/Makefile kmyfirewall/compilers/pf/Makefile
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
-
- # Add here commands to install the package into debian/kmyfirewall.
- env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde $(MAKE) install DESTDIR=$(CURDIR)/debian/kmyfirewall-trinity
-
- rm -f debian/kmyfirewall-trinity/opt/trinity/lib/*.so
- chrpath -d debian/kmyfirewall-trinity/opt/trinity/bin/kmyfirewall debian/kmyfirewall-trinity/opt/trinity/lib/*.so.* debian/kmyfirewall-trinity/opt/trinity/lib/trinity/*.so
- chmod +x debian/kmyfirewall-trinity/opt/trinity/share/apps/kmyfirewall/scripts/installer/linux/*.sh
- dh_install
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_icons
- dh_desktop
- dh_installmenu
- dh_installman
- mv debian/kmyfirewall-trinity/usr/share/man debian/kmyfirewall-trinity/opt/trinity/share/
- dh_link
- dh_strip
- dh_compress -X.bz2 -X.css -X.dcl -X.docbook -X-license -X.tag
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+binary-install/kmyfirewall-trinity::
+ rm -f debian/$(cdbs_curpkg)/opt/trinity/lib/*.so
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+ chmod +x debian/$(cdbs_curpkg)/opt/trinity/share/apps/kmyfirewall/scripts/installer/linux/*.sh