summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/dependencies/tqt3/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/squeeze/dependencies/tqt3/debian/rules')
-rwxr-xr-xdebian/squeeze/dependencies/tqt3/debian/rules17
1 files changed, 15 insertions, 2 deletions
diff --git a/debian/squeeze/dependencies/tqt3/debian/rules b/debian/squeeze/dependencies/tqt3/debian/rules
index a2d5e0a8d..42f031168 100755
--- a/debian/squeeze/dependencies/tqt3/debian/rules
+++ b/debian/squeeze/dependencies/tqt3/debian/rules
@@ -51,7 +51,8 @@ CONFIGURE_OPTS = \
-datadir "/usr/share/tqt3" \
-headerdir "/usr/include/tqt3" \
-docdir "/usr/share/tqt3/doc" \
- -plugindir "/usr/lib/tqt3/plugins" \
+ -libdir "/usr/lib/$(DEB_HOST_MULTIARCH)" \
+ -plugindir "/usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins" \
-translationdir "/usr/share/tqt3/translations" \
\
-thread \
@@ -220,6 +221,12 @@ clean::
cd examples/ && find . -name '.obj' | xargs rm -rf
+ # revert multi-arch path in install files
+ for a in debian/*install debian/*links; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
dh_clean
install: build
@@ -230,8 +237,14 @@ install: build
dh_clean -i
dh_installdirs
+ # update multi-arch path in install files
+ for a in debian/*install debian/*links; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
# fix .prl files
- for a in $(TMP_INSTALL)/usr/lib/*prl; do cat "$$a" | sed \
+ for a in $(TMP_INSTALL)/usr/lib/$(DEB_HOST_MULTIARCH)/*prl; do cat "$$a" | sed \
"s#$(QTDIR)#/usr/share/tqt3#g" > "$$a".new && mv "$$a".new "$$a"; done
dh_install $(IBASE) --sourcedir=$(TMP_INSTALL)