summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/applications/kdiff3/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/wheezy/applications/kdiff3/debian')
-rwxr-xr-xdebian/wheezy/applications/kdiff3/debian/rules7
-rw-r--r--debian/wheezy/applications/kdiff3/debian/source/options4
2 files changed, 7 insertions, 4 deletions
diff --git a/debian/wheezy/applications/kdiff3/debian/rules b/debian/wheezy/applications/kdiff3/debian/rules
index bc64fcc06..19ea44a07 100755
--- a/debian/wheezy/applications/kdiff3/debian/rules
+++ b/debian/wheezy/applications/kdiff3/debian/rules
@@ -11,6 +11,9 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -97,7 +100,7 @@ binary-indep: build install
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
# Build architecture-dependent files here.
binary-arch: build install
@@ -118,7 +121,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/wheezy/applications/kdiff3/debian/source/options b/debian/wheezy/applications/kdiff3/debian/source/options
index 9d7c8e036..72f1f5450 100644
--- a/debian/wheezy/applications/kdiff3/debian/source/options
+++ b/debian/wheezy/applications/kdiff3/debian/source/options
@@ -1,5 +1,5 @@
-# Use bzip2 instead of gzip
-compression = "bzip2"
+# Use xz instead of gzip
+compression = "xz"
compression-level = 9
# Don't run differences