summaryrefslogtreecommitdiffstats
path: root/dilos/core/tdeadmin/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/core/tdeadmin/debian/rules')
-rwxr-xr-xdilos/core/tdeadmin/debian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/dilos/core/tdeadmin/debian/rules b/dilos/core/tdeadmin/debian/rules
new file mode 100755
index 000000000..f5bb91a19
--- /dev/null
+++ b/dilos/core/tdeadmin/debian/rules
@@ -0,0 +1,35 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /usr/include
+DEB_CONFIGURE_MANDIR := /usr/share/man
+DEB_CONFIGURE_PREFIX := /usr
+DEB_CONFIGURE_INFODIR := /usr/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_STRIP_ARGS := --dbg-package=tdeadmin-trinity-dbg
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+ --without-rpm --with-pam=tde --with-shadow --with-nis \
+ --with-private-groups --prefix=/usr --with-extra-libs=/usr/lib
+
+CPPFLAGS+= -D__dilos__
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON" \
+ -DKU_USERPRIVATEGROUP="true" \
+ -DCMAKE_C_COMPILER=gcc \
+ -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" \
+ -DBUILD_KDAT="OFF"