summaryrefslogtreecommitdiffstats
path: root/dilos/dependencies/python-tqt/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/dependencies/python-tqt/debian/control')
-rw-r--r--dilos/dependencies/python-tqt/debian/control80
1 files changed, 77 insertions, 3 deletions
diff --git a/dilos/dependencies/python-tqt/debian/control b/dilos/dependencies/python-tqt/debian/control
index 9fc68128b..91a6636d9 100644
--- a/dilos/dependencies/python-tqt/debian/control
+++ b/dilos/dependencies/python-tqt/debian/control
@@ -4,8 +4,10 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Bernd Zeimetz <bzed@debian.org>, Michael Casadevall <mcasadevall@debian.org>
-Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), libtqtinterface-dev, tqt3-dev-tools, tqt3-apps-dev, python-sip-tqt-dev, python-sip-tqt-dbg [!solaris-any], libtqscintilla-dev, python-support (>= 0.7.1) | python-dev (>= 2.6.6-3~), python-all-dbg [!solaris-any], dh-python
+Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), python-all-dbg [!solaris-any], python3-all-dev, python3-all-dbg [!solaris-any], libtqtinterface-dev, tqt3-dev-tools, tqt3-apps-dev, python3-sip-tqt-dev, python3-sip-tqt-dbg, python-sip-tqt-dev, python-sip-tqt-dbg [!solaris-any], libtqscintilla-dev, python-support (>= 0.7.1) | dh-python
Standards-Version: 3.8.4
+XS-Python-Version: >= 2.3
+X-Python3-Version: >= 3.0
Package: python-tqt
Architecture: any
@@ -38,6 +40,33 @@ Description: TQt bindings for Python (debug extension)
.
This package contains the extension built for the Python debug interpreter.
+Package: python3-tqt
+Architecture: any
+Depends: ${shlibs:Depends}, ${python3:Depends}, ${sip-tqt:Depends}, ${misc:Depends}
+Suggests: python3-tqt-gl, python-tqt-doc, libtqt3-mt-mysql|libtqt3-mt-odbc|libtqt3-mt-psql
+Provides: ${python3:Provides}
+Description: TQt bindings for Python 3
+ Python binding module that allows use of TQt X Window toolkit v3.
+ You can use it to create portable graphics-capable scripts (there
+ are PyTQt versions for Linux, Windows and MacOS X).
+ .
+ At this moment PyTQt offers a vast subset of TQt API. There are
+ some minor issues related to the differences between C++ and Python
+ (types, etc), but usually you'll be able to write code pretty much the
+ same way in both languages (with syntax differences, of course)
+
+Package: python3-tqt-dbg
+Architecture: any
+Priority: extra
+Section: debug
+Depends: ${shlibs:Depends}, python3-all-dbg, python3-tqt (= ${binary:Version}), python3-sip-tqt-dbg, ${misc:Depends}
+Description: TQt bindings for Python 3 (debug extension)
+ Python binding module that allows use of TQt X Window toolkit v3.
+ You can use it to create portable graphics-capable scripts (there
+ are PyTQt versions for Linux, Windows and MacOS X).
+ .
+ This package contains the extension built for the Python debug interpreter.
+
Package: python-tqt-gl
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt (= ${binary:Version}), python-opengl (>= 2.0.1.09-2.2), ${misc:Depends}
@@ -66,6 +95,30 @@ Description: TQt OpenGL bindings for Python (debug extension)
.
This package contains the extension built for the Python debug interpreter.
+Package: python3-tqt-gl
+Architecture: any
+Depends: ${shlibs:Depends}, ${python3:Depends}, python3-tqt (= ${binary:Version}), python3-opengl, ${misc:Depends}
+Suggests: python-tqt-doc
+Provides: ${python3:Provides}
+Description: TQt OpenGL bindings for Python 3
+ Python binding module that allows use of the OpenGL facilities
+ offered by the TQt X Window toolkit v3. You can use it to create
+ portable graphics-capable scripts (there are PyTQt versions for
+ Linux, Windows and MacOS X).
+
+Package: python3-tqt-gl-dbg
+Priority: extra
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, python3-all-dbg, python3-tqt-gl (= ${binary:Version}), python3-tqt-dbg (= ${binary:Version}), ${misc:Depends}
+Description: TQt OpenGL bindings for Python 3 (debug extension)
+ Python binding module that allows use of the OpenGL facilities
+ offered by the TQt X Window toolkit v3. You can use it to create
+ portable graphics-capable scripts (there are PyTQt versions for
+ Linux, Windows and MacOS X).
+ .
+ This package contains the extension built for the Python debug interpreter.
+
Package: python-tqtext
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt (= ${binary:Version}), ${misc:Depends}
@@ -91,6 +144,27 @@ Description: TQt debug extensions for PyTQt
* QScintilla: a featureful TQt source code editing component based
on Scintilla.
+Package: python3-tqtext
+Architecture: any
+Depends: ${shlibs:Depends}, ${python3:Depends}, python3-tqt (= ${binary:Version}), ${misc:Depends}
+Provides: ${python3:Provides}
+Description: TQt extensions for PyTQt
+ PyTQt Extensions. Contains:
+ .
+ * QScintilla: a featureful TQt source code editing component based
+ on Scintilla.
+
+Package: python3-tqtext-dbg
+Priority: extra
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, python3-all-dbg, python3-tqtext (= ${binary:Version}), python3-tqt-dbg (= ${binary:Version}), ${misc:Depends}
+Description: TQt debug extensions for PyTQt
+ PyTQt debug Extensions. Contains:
+ .
+ * QScintilla: a featureful TQt source code editing component based
+ on Scintilla.
+
Package: pytqt-tools
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
@@ -104,8 +178,8 @@ Description: pyuic and pylupdate for TQt
Linguist translation files from Python code.
Package: python-tqt-dev
-Depends: python-tqt (= ${binary:Version}), ${python:Depends}, ${misc:Depends}
-Suggests: python-sip-tqt-dev
+Depends: python3-tqt (= ${binary:Version}) | python-tqt (= ${binary:Version}), ${python:Depends}, ${misc:Depends}
+Suggests: python3-sip-tqt-dev | python-sip-tqt-dev
Replaces: python-tqt-dev (<< 4:14.0.0~)
Breaks: python-tqt-dev (<< 4:14.0.0~)
Architecture: all