summaryrefslogtreecommitdiffstats
path: root/dilos/libraries/pytdeextensions/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/libraries/pytdeextensions/debian/rules')
-rwxr-xr-xdilos/libraries/pytdeextensions/debian/rules21
1 files changed, 7 insertions, 14 deletions
diff --git a/dilos/libraries/pytdeextensions/debian/rules b/dilos/libraries/pytdeextensions/debian/rules
index 009b362ca..93913921a 100755
--- a/dilos/libraries/pytdeextensions/debian/rules
+++ b/dilos/libraries/pytdeextensions/debian/rules
@@ -1,17 +1,13 @@
#!/usr/bin/make -f
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DEB_PYTHON2_MODULE_PACKAGES=pytdeextensions-trinity libpythonize0-trinity
+
+DEB_PYTHON_SYSTEM = /usr/bin/dh_python3
+DEB_PYTHON3_MODULE_PACKAGES=pytdeextensions-trinity libpythonize0-trinity
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
include /usr/share/cdbs/1/rules/debhelper.mk
-ifeq (pysupport, $(DEB_PYTHON_SYSTEM))
- include debian/python-distutils-jaunty.mk
-else
- include /usr/share/cdbs/1/class/python-distutils.mk
-endif
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/utils.mk
DEB_CONFIGURE_INCLUDEDIR := /usr/include
@@ -27,6 +23,9 @@ DEB_PYTHON_INSTALL_ARGS_ALL += \
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+# Make sure to build only for the default python version
+cdbs_curpythonflavors := python$(shell py3versions -vd)
+
DEB_DH_INSTALL_ARGS = --sourcedir=debian/tmp
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/usr --with-extra-libs=/usr/lib/$(DEB_HOST_MULTIARCH) --with-extra-includes=/usr/include
@@ -40,12 +39,6 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
endif
-post-patches::
- # make sure that python binary exists
- # since the existing code is still dependent on python2
- # and cdbs uses python as the default binary name
- test -x /usr/bin/python || ln -s python2 /usr/bin/python
-
install/pytdeextensions-trinity::
# We have no idea if the built product is site-packages or dist-packages
cd debian/tmp/usr/lib/python*/ && mv site-packages/ dist-packages/ || echo "site-packages --> dist-packages"