summaryrefslogtreecommitdiffstats
path: root/dilos/tdenetwork/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/tdenetwork/debian/patches')
-rw-r--r--dilos/tdenetwork/debian/patches/common/04_am_maintainer_mode.diff11
-rw-r--r--dilos/tdenetwork/debian/patches/common/06_disable_no_undefined.diff18
-rw-r--r--dilos/tdenetwork/debian/patches/common/kubuntu_01_kdepot.diff26
-rw-r--r--dilos/tdenetwork/debian/patches/dilos.patch177
-rw-r--r--dilos/tdenetwork/debian/patches/series4
5 files changed, 236 insertions, 0 deletions
diff --git a/dilos/tdenetwork/debian/patches/common/04_am_maintainer_mode.diff b/dilos/tdenetwork/debian/patches/common/04_am_maintainer_mode.diff
new file mode 100644
index 000000000..391a80285
--- /dev/null
+++ b/dilos/tdenetwork/debian/patches/common/04_am_maintainer_mode.diff
@@ -0,0 +1,11 @@
+--- a/admin/configure.in.min
++++ b/admin/configure.in.min
+@@ -38,6 +38,8 @@
+ dnl Automake doc recommends to do this only here. (Janos)
+ AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
+
++AM_MAINTAINER_MODE
++
+ KDE_SET_PREFIX
+
+ dnl generate the config header
diff --git a/dilos/tdenetwork/debian/patches/common/06_disable_no_undefined.diff b/dilos/tdenetwork/debian/patches/common/06_disable_no_undefined.diff
new file mode 100644
index 000000000..05c932c3c
--- /dev/null
+++ b/dilos/tdenetwork/debian/patches/common/06_disable_no_undefined.diff
@@ -0,0 +1,18 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -1689,15 +1689,6 @@
+ KDE_USE_CLOSURE_TRUE="#"
+ KDE_USE_CLOSURE_FALSE=""
+ KDE_NO_UNDEFINED=""
+- case $host in
+- *-*-linux-gnu)
+- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
+- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
+- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
+- [KDE_NO_UNDEFINED=""])],
+- [KDE_NO_UNDEFINED=""])
+- ;;
+- esac
+ fi
+ AC_SUBST(KDE_USE_CLOSURE_TRUE)
+ AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/dilos/tdenetwork/debian/patches/common/kubuntu_01_kdepot.diff b/dilos/tdenetwork/debian/patches/common/kubuntu_01_kdepot.diff
new file mode 100644
index 000000000..28c95742b
--- /dev/null
+++ b/dilos/tdenetwork/debian/patches/common/kubuntu_01_kdepot.diff
@@ -0,0 +1,26 @@
+--- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
++++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
+@@ -537,6 +537,8 @@
+ if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
+ export EXTRACTRC PREPARETIPS
+
++kdepotpath=/usr/include/tde/tde.pot
++
+ for subdir in $dirs; do
+ test -z "$VERBOSE" || echo "Making messages in $subdir"
+ (cd $subdir
+@@ -554,10 +556,10 @@
+ fi
+ perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
+
+- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
+- if ! test -f $kdepotpath; then
+- kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
+- fi
++# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
++# if ! test -f $kdepotpath; then
++# kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
++# fi
+
+ $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
+ XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages
diff --git a/dilos/tdenetwork/debian/patches/dilos.patch b/dilos/tdenetwork/debian/patches/dilos.patch
new file mode 100644
index 000000000..a2b1be093
--- /dev/null
+++ b/dilos/tdenetwork/debian/patches/dilos.patch
@@ -0,0 +1,177 @@
+Index: tdenetwork/ConfigureChecks.cmake
+===================================================================
+--- tdenetwork.orig/ConfigureChecks.cmake
++++ tdenetwork/ConfigureChecks.cmake
+@@ -38,7 +38,10 @@ if( BUILD_KOPETE OR BUILD_KTALKD )
+ endif( )
+
+ if( WITH_SLP )
++ tde_save( CMAKE_REQUIRED_LIBRARIES )
++ set( CMAKE_REQUIRED_LIBRARIES socket )
+ check_library_exists( slp "SLPOpen" "" HAVE_SLP )
++ tde_restore( CMAKE_REQUIRED_LIBRARIES )
+ if( HAVE_SLP )
+ set(LIB_SLP slp )
+ else( )
+Index: tdenetwork/libtdevnc/CMakeLists.txt
+===================================================================
+--- tdenetwork.orig/libtdevnc/CMakeLists.txt
++++ tdenetwork/libtdevnc/CMakeLists.txt
+@@ -175,14 +175,20 @@ check_function_exists(vprintf LI
+ check_function_exists(mmap LIBVNCSERVER_HAVE_MMAP)
+ check_function_exists(fork LIBVNCSERVER_HAVE_FORK)
+ check_function_exists(ftime LIBVNCSERVER_HAVE_FTIME)
++tde_save( CMAKE_REQUIRED_LIBRARIES )
++set( CMAKE_REQUIRED_LIBRARIES nsl )
+ check_function_exists(gethostbyname LIBVNCSERVER_HAVE_GETHOSTBYNAME)
++tde_restore( CMAKE_REQUIRED_LIBRARIES )
+ check_function_exists(gethostname LIBVNCSERVER_HAVE_GETHOSTNAME)
+ check_function_exists(inet_ntoa LIBVNCSERVER_HAVE_INET_NTOA)
+ check_function_exists(memmove LIBVNCSERVER_HAVE_MEMMOVE)
+ check_function_exists(memset LIBVNCSERVER_HAVE_MEMSET)
+ check_function_exists(mkfifo LIBVNCSERVER_HAVE_MKFIFO)
+ check_function_exists(select LIBVNCSERVER_HAVE_SELECT)
++tde_save( CMAKE_REQUIRED_LIBRARIES )
++set( CMAKE_REQUIRED_LIBRARIES socket )
+ check_function_exists(socket LIBVNCSERVER_HAVE_SOCKET)
++tde_restore( CMAKE_REQUIRED_LIBRARIES )
+ check_function_exists(strchr LIBVNCSERVER_HAVE_STRCHR)
+ check_function_exists(strcspn LIBVNCSERVER_HAVE_STRCSPN)
+ check_function_exists(strdup LIBVNCSERVER_HAVE_STRDUP)
+Index: tdenetwork/cmake/modules/TDEMacros.cmake
+===================================================================
+--- tdenetwork.orig/cmake/modules/TDEMacros.cmake
++++ tdenetwork/cmake/modules/TDEMacros.cmake
+@@ -833,7 +833,7 @@ macro( tde_add_library _arg_target )
+
+ # set embedded archives
+ if( _embed )
+- list( INSERT _link 0 -Wl,-whole-archive ${_embed} -Wl,-no-whole-archive )
++ list( INSERT _link 0 -Wl,-zallextract ${_embed} -Wl,-zdefaultextract )
+ endif( _embed )
+
+ # set link libraries
+@@ -1878,7 +1878,7 @@ macro( tde_setup_architecture_flags )
+ check_cxx_compiler_flag( -fPIE HAVE_PIE_SUPPORT )
+ if( HAVE_PIE_SUPPORT )
+ set( TDE_PIE_CFLAGS -fPIE )
+- set( TDE_PIE_LDFLAGS -pie )
++# set( TDE_PIE_LDFLAGS -pie )
+ endif( HAVE_PIE_SUPPORT )
+ endmacro( )
+
+Index: tdenetwork/kopete/protocols/jabber/jingle/libjingle/talk/base/network.cc
+===================================================================
+--- tdenetwork.orig/kopete/protocols/jabber/jingle/libjingle/talk/base/network.cc
++++ tdenetwork/kopete/protocols/jabber/jingle/libjingle/talk/base/network.cc
+@@ -42,6 +42,9 @@
+ extern "C" {
+ #include <sys/utsname.h>
+ #include <sys/ioctl.h>
++#ifdef __dilos__
++#include <sys/sockio.h>
++#endif /* __dilos__ */
+ #include <net/if.h>
+ #include <unistd.h>
+ #include <errno.h>
+Index: tdenetwork/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/CMakeLists.txt
+===================================================================
+--- tdenetwork.orig/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/CMakeLists.txt
++++ tdenetwork/kopete/protocols/jabber/jingle/libjingle/talk/p2p/base/CMakeLists.txt
+@@ -36,7 +36,7 @@ tde_add_executable( relayserver
+ SOURCES
+ relayserver.cc relayserver_main.cc
+ LINK
+- cricketbase-static cricketp2pbase-static pthread
++ cricketbase-static cricketp2pbase-static pthread socket nsl
+ DESTINATION ${BIN_INSTALL_DIR}
+ )
+
+@@ -47,6 +47,6 @@ tde_add_executable( stunserver
+ SOURCES
+ stunserver.cc stunserver_main.cc
+ LINK
+- cricketbase-static cricketp2pbase-static pthread
++ cricketbase-static cricketp2pbase-static pthread socket nsl
+ DESTINATION ${BIN_INSTALL_DIR}
+ )
+Index: tdenetwork/kppp/kpppconfig.h
+===================================================================
+--- tdenetwork.orig/kppp/kpppconfig.h
++++ tdenetwork/kppp/kpppconfig.h
+@@ -26,7 +26,10 @@
+ #ifndef _KPPPCONFIG_H_
+ #define _KPPPCONFIG_H_
+
+-#if defined(__svr4__)
++#if defined(__dilos__)
++#define STREAMS
++#define _XOPEN_SOURCE_EXTENDED 1
++#elif defined(__svr4__)
+ #define STREAMS
+ #define _XOPEN_SOURCE 1
+ #define _XOPEN_SOURCE_EXTENDED 1
+Index: tdenetwork/ktalkd/ktalkd/find_user.cpp
+===================================================================
+--- tdenetwork.orig/ktalkd/ktalkd/find_user.cpp
++++ tdenetwork/ktalkd/ktalkd/find_user.cpp
+@@ -375,8 +375,8 @@ int find_user(char *name, char *tty, cha
+ #ifdef USE_UT_HOST
+ if (Options.debug_mode) {
+ syslog(LOG_DEBUG, "I wanna this:%s", ttyFound);
+- syslog(LOG_DEBUG, "ut_host=%s", ubuf.ut_host);
+- syslog(LOG_DEBUG, "%s", ubuf.ut_line);
++ syslog(LOG_DEBUG, "ut_host=%s", ubuf->ut_host);
++ syslog(LOG_DEBUG, "%s", ubuf->ut_line);
+ }
+ #endif
+ break;
+Index: tdenetwork/ktalkd/mail.local/CMakeLists.txt
+===================================================================
+--- tdenetwork.orig/ktalkd/mail.local/CMakeLists.txt
++++ tdenetwork/ktalkd/mail.local/CMakeLists.txt
+@@ -18,5 +18,6 @@ include_directories(
+
+ tde_add_executable( mail.local
+ SOURCES mail.local.c
++ LINK socket nsl
+ DESTINATION ${BIN_INSTALL_DIR}
+ )
+Index: tdenetwork/lanbrowsing/lisa/CMakeLists.txt
+===================================================================
+--- tdenetwork.orig/lanbrowsing/lisa/CMakeLists.txt
++++ tdenetwork/lanbrowsing/lisa/CMakeLists.txt
+@@ -26,7 +26,7 @@ install( FILES README DESTINATION ${DATA
+
+ tde_add_executable( lisa
+ SOURCES main.cpp
+- LINK lisa-static
++ LINK lisa-static socket nsl
+ DESTINATION ${BIN_INSTALL_DIR}
+ )
+
+@@ -35,7 +35,7 @@ tde_add_executable( lisa
+
+ tde_add_executable( reslisa
+ SOURCES strictmain.cpp
+- LINK lisa-static
++ LINK lisa-static socket nsl
+ DESTINATION ${BIN_INSTALL_DIR}
+ )
+
+Index: tdenetwork/krfb/ConfigureChecks.cmake
+===================================================================
+--- tdenetwork.orig/krfb/ConfigureChecks.cmake
++++ tdenetwork/krfb/ConfigureChecks.cmake
+@@ -17,8 +17,11 @@ if( NOT XTST_FOUND )
+ tde_message_fatal( "xtst is required, but was not found on your system" )
+ endif( )
+
++tde_save( CMAKE_REQUIRED_LIBRARIES )
++set( CMAKE_REQUIRED_LIBRARIES socket nsl )
+ check_function_exists( getnameinfo HAVE_GETNAMEINFO )
+ check_function_exists( getifaddrs HAVE_GETIFADDRS )
++tde_restore( CMAKE_REQUIRED_LIBRARIES )
+ check_include_file( sys/sockio.h HAVE_SYS_SOCKIO_H )
+
+ check_struct_has_member(
diff --git a/dilos/tdenetwork/debian/patches/series b/dilos/tdenetwork/debian/patches/series
new file mode 100644
index 000000000..8e96568f3
--- /dev/null
+++ b/dilos/tdenetwork/debian/patches/series
@@ -0,0 +1,4 @@
+common/04_am_maintainer_mode.diff
+common/06_disable_no_undefined.diff
+common/kubuntu_01_kdepot.diff
+dilos.patch