summaryrefslogtreecommitdiffstats
path: root/gentoo/app-mobilephone/gsmlib
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/app-mobilephone/gsmlib')
m---------gentoo0
-rw-r--r--gentoo/app-mobilephone/gsmlib/Manifest4
-rw-r--r--gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc41.patch52
-rw-r--r--gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc43.patch67
-rw-r--r--gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch52
-rw-r--r--gentoo/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild31
-rw-r--r--gentoo/app-mobilephone/gsmlib/metadata.xml6
7 files changed, 0 insertions, 212 deletions
diff --git a/gentoo b/gentoo
new file mode 160000
+Subproject 644110a847c5911c2eb04eb53c93031740561ef
diff --git a/gentoo/app-mobilephone/gsmlib/Manifest b/gentoo/app-mobilephone/gsmlib/Manifest
deleted file mode 100644
index e3792f037..000000000
--- a/gentoo/app-mobilephone/gsmlib/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX gsmlib-1.11-gcc41.patch 2110 SHA256 382dfa6e005cee54d14700191d326d3063e1db0f9f8106f9883a1e4790ae83a6 SHA512 75335091d6dccc7babbd5f55f5c2a51cd51dc22a2b4571641e3beec4d35f5d34938a73c3ae2cf91f759521f05a299a628c70bdd6fc3a8a9948023a9f67ab5efa WHIRLPOOL f7039292deb7d4aacc7ba1b35e2fe90af3a0ad2d1f0b83874f4314f04bc49482b5e07fe10b9c57bb95ab293030ce7eda9e117e0327012f038c0a6a17e8aedcc2
-AUX gsmlib-1.11-gcc43.patch 2342 SHA256 a6647855cc4a4100c45ae4a3d4515d3de92113e7140bf49b55ad211629da454a SHA512 1fe3e11cd45de5a29bdf440733aadbd41635d85793d3f0c1fa0d43fab3cdd9d58c9c6d9a32ba5e2600c85095bf614ff0b2e00db3724f3e2031a460b2abc9ecc6 WHIRLPOOL fc49802ba435f029d164081a79fded10c9918294971d4950a17215b0988e1bc998305c85e174d9d981a7fc0fda9620719fff9c3ca3f5170e3cc05c060b85014a
-AUX gsmlib-1.11-include-gcc34-fix.patch 1436 SHA256 59de49fcf775aad7e4d693274500d629bf399d5738f304804e25069745e3d0fd SHA512 1945d62185b3ac6d63763c3547ef2e264626b808c5254d450a415c20451a9d3c360cae95e9469c424d7abcf3abdc4b2ace9ae3d089dcdef8f64b8d64456e241a WHIRLPOOL 5474569e82b5c5aa6278170404427471d94f7a071e43f654ecbd09d111496b619b17be91ccb8cea4ff35b602d8908bec9fe80bd2749bad7129fe3d516b94c5d3
-DIST gsmlib-pre1.11-041028.tar.gz 499052 SHA256 2dae164cdaa3b6ce41cfe4e41501f44bc665296349a5be4d5d10cb260a87231f SHA512 9009fce488b7ed7aeb0a0581f0586a3898911ea042b92369e0242dc8b0292ca82f913058cfd958a7af121be57cf925598dc26822817ccf81027917abe6b6096a WHIRLPOOL 6970eeeca15dfa14204d02f0f3e55e30e9e43808554df5bc2cb9d16496f1e422cf72373906a8b216df61cbe14d619f35dfa3b04fd676caad5d9d983897adcbe9
diff --git a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc41.patch b/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc41.patch
deleted file mode 100644
index a7414e36b..000000000
--- a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc41.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -ur gsmlib-1.11-orig/gsmlib/gsm_map_key.h gsmlib-1.11/gsmlib/gsm_map_key.h
---- gsmlib-1.11-orig/gsmlib/gsm_map_key.h 2006-02-25 19:20:52.000000000 -0500
-+++ gsmlib-1.11/gsmlib/gsm_map_key.h 2006-02-25 19:23:01.000000000 -0500
-@@ -78,7 +78,7 @@
- // MapKey members
-
- template <class SortedStore>
-- bool gsmlib::operator<(const MapKey<SortedStore> &x,
-+ bool operator<(const MapKey<SortedStore> &x,
- const MapKey<SortedStore> &y)
- {
- assert(&x._myStore == &y._myStore);
-@@ -103,7 +103,7 @@
- }
-
- template <class SortedStore>
-- bool gsmlib::operator==(const MapKey<SortedStore> &x,
-+ bool operator==(const MapKey<SortedStore> &x,
- const MapKey<SortedStore> &y)
- {
- assert(&x._myStore == &y._myStore);
-diff -ur gsmlib-1.11-orig/gsmlib/gsm_me_ta.h gsmlib-1.11/gsmlib/gsm_me_ta.h
---- gsmlib-1.11-orig/gsmlib/gsm_me_ta.h 2006-02-25 19:20:52.000000000 -0500
-+++ gsmlib-1.11/gsmlib/gsm_me_ta.h 2006-02-25 19:21:48.000000000 -0500
-@@ -294,8 +294,8 @@
- // 3 disable phone receive RF circuits only
- // 4 disable phone both transmit and receive RF circuits
- // 5...127 implementation-defined
-- int MeTa::getFunctionalityLevel() throw(GsmException);
-- void MeTa::setFunctionalityLevel(int level) throw(GsmException);
-+ int getFunctionalityLevel() throw(GsmException);
-+ void setFunctionalityLevel(int level) throw(GsmException);
-
- // return battery charge status (+CBC):
- // 0 ME is powered by the battery
-@@ -389,13 +389,13 @@
- void setCallWaitingLockStatus(FacilityClass cl,
- bool lock)throw(GsmException);
-
-- void MeTa::setCLIRPresentation(bool enable) throw(GsmException);
-+ void setCLIRPresentation(bool enable) throw(GsmException);
- //(+CLIR)
-
- // 0:according to the subscription of the CLIR service
- // 1:CLIR invocation
- // 2:CLIR suppression
-- int MeTa::getCLIRPresentation() throw(GsmException);
-+ int getCLIRPresentation() throw(GsmException);
-
- friend class Phonebook;
- friend class SMSStore;
-
diff --git a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc43.patch b/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc43.patch
deleted file mode 100644
index ddd78c6db..000000000
--- a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-gcc43.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Naurp gsmlib-1.11-orig/gsmlib/gsm_me_ta.cc gsmlib-1.11/gsmlib/gsm_me_ta.cc
---- gsmlib-1.11-orig/gsmlib/gsm_me_ta.cc 2003-08-26 02:01:36.000000000 -0600
-+++ gsmlib-1.11/gsmlib/gsm_me_ta.cc 2008-02-24 15:09:58.000000000 -0600
-@@ -19,6 +19,8 @@
- #include <gsmlib/gsm_parser.h>
- #include <gsmlib/gsm_sysdep.h>
-
-+#include <cstdlib>
-+
- using namespace std;
- using namespace gsmlib;
-
-diff -Naurp gsmlib-1.11-orig/gsmlib/gsm_sms_codec.cc gsmlib-1.11/gsmlib/gsm_sms_codec.cc
---- gsmlib-1.11-orig/gsmlib/gsm_sms_codec.cc 2004-10-27 17:06:06.000000000 -0600
-+++ gsmlib-1.11/gsmlib/gsm_sms_codec.cc 2008-02-24 15:10:44.000000000 -0600
-@@ -23,6 +23,7 @@
- #ifdef HAVE_STRING_H
- #include <string.h>
- #endif
-+#include <climits>
- #include <string>
- using namespace std;
- using namespace gsmlib;
-diff -Naurp gsmlib-1.11-orig/gsmlib/gsm_util.cc gsmlib-1.11/gsmlib/gsm_util.cc
---- gsmlib-1.11-orig/gsmlib/gsm_util.cc 2004-10-27 17:05:53.000000000 -0600
-+++ gsmlib-1.11/gsmlib/gsm_util.cc 2008-02-24 15:09:36.000000000 -0600
-@@ -35,6 +35,7 @@
- #define __USE_GNU
- #define _GNU_SOURCE
- #endif
-+#include <cstdlib>
- #include <stdio.h>
- #include <sys/stat.h>
-
-diff -Naurp gsmlib-1.11-orig/gsmlib/gsm_unix_serial.cc gsmlib-1.11/gsmlib/gsm_unix_serial.cc
---- gsmlib-1.11-orig/gsmlib/gsm_unix_serial.cc 2004-10-27 16:57:35.000000000 -0600
-+++ gsmlib-1.11/gsmlib/gsm_unix_serial.cc 2008-02-24 15:19:03.000000000 -0600
-@@ -28,6 +28,7 @@
- #include <pthread.h>
- #include <cassert>
- #include <assert.h>
-+#include <cstring>
-
- using namespace std;
- using namespace gsmlib;
-diff -Naurp gsmlib-1.11-orig/gsmlib/gsm_sorted_phonebook.cc gsmlib-1.11/gsmlib/gsm_sorted_phonebook.cc
---- gsmlib-1.11-orig/gsmlib/gsm_sorted_phonebook.cc 2002-05-14 13:38:12.000000000 -0600
-+++ gsmlib-1.11/gsmlib/gsm_sorted_phonebook.cc 2008-02-24 15:22:52.000000000 -0600
-@@ -20,6 +20,7 @@
- #include <iostream>
- #include <fstream>
- #include <limits.h>
-+#include <cstring>
-
- const int MAX_LINE_SIZE = 1000;
-
-diff -Naurp gsmlib-1.11-orig/apps/gsmsmsd.cc gsmlib-1.11/apps/gsmsmsd.cc
---- gsmlib-1.11-orig/apps/gsmsmsd.cc 2003-08-26 00:47:47.000000000 -0600
-+++ gsmlib-1.11/apps/gsmsmsd.cc 2008-02-24 15:25:54.000000000 -0600
-@@ -40,6 +40,7 @@
- #include <iostream>
- #include <gsmlib/gsm_me_ta.h>
- #include <gsmlib/gsm_event.h>
-+#include <cstring>
-
- using namespace std;
- using namespace gsmlib;
diff --git a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch b/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch
deleted file mode 100644
index dda545124..000000000
--- a/gentoo/app-mobilephone/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch
+++ /dev/null
@@ -1,52 +0,0 @@
---- gsmlib-1.11/gsmlib/gsm_map_key.h 2002-05-14 23:38:12.000000000 +0400
-+++ gsmlib-1.11-fixed/gsmlib/gsm_map_key.h 2004-08-02 00:56:40.997784696 +0400
-@@ -25,6 +25,16 @@
-
- // wrapper for map key, can access Sortedtore to get sortOrder()
-
-+ // compare two keys
-+ template <class SortedStore> class MapKey;
-+
-+ template <class SortedStore>
-+ bool operator<(const MapKey<SortedStore> &x,
-+ const MapKey<SortedStore> &y);
-+ template <class SortedStore>
-+ bool operator==(const MapKey<SortedStore> &x,
-+ const MapKey<SortedStore> &y);
-+
- template <class SortedStore> class MapKey
- {
- SortedStore &_myStore; // my store
-@@ -47,20 +57,16 @@
-
- friend
- bool operator<
--#ifndef WIN32
-- <>
--#endif
-+ <SortedStore>
- (const MapKey<SortedStore> &x,
- const MapKey<SortedStore> &y);
- friend
- bool operator==
--#ifndef WIN32
-- <>
--#endif
-+ <SortedStore>
- (const MapKey<SortedStore> &x,
- const MapKey<SortedStore> &y);
- };
--
-+/*
- // compare two keys
- template <class SortedStore>
- extern bool operator<(const MapKey<SortedStore> &x,
-@@ -68,7 +74,7 @@
- template <class SortedStore>
- extern bool operator==(const MapKey<SortedStore> &x,
- const MapKey<SortedStore> &y);
--
-+ */
- // MapKey members
-
- template <class SortedStore>
diff --git a/gentoo/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild b/gentoo/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild
deleted file mode 100644
index 2b9a496e2..000000000
--- a/gentoo/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils
-
-DESCRIPTION="Library and applications to access GSM mobile phones"
-SRC_URI="http://www.pxh.de/fs/gsmlib/snapshots/${PN}-pre${PV%_pre*}-${PV#*_pre}.tar.gz"
-HOMEPAGE="http://www.pxh.de/fs/gsmlib/"
-
-IUSE=""
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
-
-RESTRICT="test"
-
-S="${WORKDIR}/${PN}-${PV%_pre*}"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}/${P%_pre*}-include-gcc34-fix.patch"
- epatch "${FILESDIR}/${P%_pre*}-gcc41.patch"
- epatch "${FILESDIR}"/${P%_pre*}-gcc43.patch
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README
-}
diff --git a/gentoo/app-mobilephone/gsmlib/metadata.xml b/gentoo/app-mobilephone/gsmlib/metadata.xml
deleted file mode 100644
index 957f16029..000000000
--- a/gentoo/app-mobilephone/gsmlib/metadata.xml
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>Library and applications to access GSM mobile phones.</longdescription>
-</pkgmetadata>