summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild')
-rw-r--r--gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild b/gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild
new file mode 100644
index 000000000..3e9cfadda
--- /dev/null
+++ b/gentoo/trinity-base/kcheckpass/kcheckpass-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS=
+IUSE="pam"
+
+RDEPEND="
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam PAM)
+ )
+
+ trinity-meta_src_configure
+}