summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kdesktop
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kdesktop')
-rw-r--r--gentoo/trinity-base/kdesktop/Manifest2
-rw-r--r--gentoo/trinity-base/kdesktop/files/kdesktop-3.5.13.1-onlyshowin-tde.patch19
l---------gentoo/trinity-base/kdesktop/files/shared1
-rw-r--r--gentoo/trinity-base/kdesktop/kdesktop-3.5.13.1.ebuild46
-rw-r--r--gentoo/trinity-base/kdesktop/kdesktop-3.5.13.2.ebuild46
-rw-r--r--gentoo/trinity-base/kdesktop/kdesktop-9999.ebuild42
-rw-r--r--gentoo/trinity-base/kdesktop/metadata.xml11
7 files changed, 167 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kdesktop/Manifest b/gentoo/trinity-base/kdesktop/Manifest
new file mode 100644
index 000000000..381340c4b
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/Manifest
@@ -0,0 +1,2 @@
+DIST kdebase-3.5.13.1.tar.gz 29403228 SHA256 ddd4bd4b508ad027b9d1af2701c6ba64bfc9f8f1d32099e6dd5e7866714f759e SHA512 e1aac19c941a5f2b43a57928fdb43e5ebd646f49c60911d9d317550df96642870792c4e77ecd06e123244e2425ccd4bcb00f0a21011ba7e651d7fcf4553e79cf WHIRLPOOL 931debbf6a65c280221025dcbc02cbb3387b66eb72eddd28a510ee8f97075cd2cc96535dde25d0a32280c399e4a868e9c027772f5d28e7e79b7c1a9080c58034
+DIST kdebase-trinity-3.5.13.2.tar.xz 25890636 SHA256 b9d552226daff64437dfb9699669b95dd7ebc2ca7c43755ba71c10cc6c9ed789 SHA512 df545d44c7d4550d1d77ff6504572b622853c2b8d80062b1aee1a5bdca19f0e708cde35cff54cf2d5098f06a41bde0c89522a3958dea9bb18205dea87c11b797 WHIRLPOOL 79144273bc7985c59a593a3394b12a2053532d2c4c890ce96adad21f6de0413baf3c6270d6d06173ec4546b20d401aa0cc81603d01b8ee41dbdefc825b39b2b1
diff --git a/gentoo/trinity-base/kdesktop/files/kdesktop-3.5.13.1-onlyshowin-tde.patch b/gentoo/trinity-base/kdesktop/files/kdesktop-3.5.13.1-onlyshowin-tde.patch
new file mode 100644
index 000000000..ff73afdea
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/files/kdesktop-3.5.13.1-onlyshowin-tde.patch
@@ -0,0 +1,19 @@
+diff --git a/kdesktop/kdiconview.cc b/kdesktop/kdiconview.cc
+index 0997069..bdbaaa7 100644
+--- a/kdesktop/kdiconview.cc
++++ b/kdesktop/kdiconview.cc
+@@ -1009,12 +1009,12 @@ bool KDIconView::makeFriendlyText( KFileIVI *fileIVI )
+ TQStringList tmpList;
+ if (cfg.hasKey("OnlyShowIn"))
+ {
+- if (!cfg.readListEntry("OnlyShowIn", ';').contains("KDE"))
++ if (!cfg.readListEntry("OnlyShowIn", ';').contains("TDE"))
+ return false;
+ }
+ if (cfg.hasKey("NotShowIn"))
+ {
+- if (cfg.readListEntry("NotShowIn", ';').contains("KDE"))
++ if (cfg.readListEntry("NotShowIn", ';').contains("TDE"))
+ return false;
+ }
+ if (cfg.hasKey("TryExec"))
diff --git a/gentoo/trinity-base/kdesktop/files/shared b/gentoo/trinity-base/kdesktop/files/shared
new file mode 120000
index 000000000..ffc286806
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/files/shared
@@ -0,0 +1 @@
+../../../eclass/trinity-shared-files \ No newline at end of file
diff --git a/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.1.ebuild b/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.1.ebuild
new file mode 100644
index 000000000..795ef7d2a
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The part of TDE ui that handles icons, desktop, screensaver etc"
+KEYWORDS="x86 amd64"
+IUSE="pam xscreensaver"
+
+DEPEND="x11-libs/libXrender
+ x11-libs/libXcursor
+ >=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/kcontrol-${PV}:${SLOT}
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ >=trinity-base/kcheckpass-${PV}:${SLOT}
+ >=trinity-base/kdialog-${PV}:${SLOT}
+ >=trinity-base/konqueror-${PV}:${SLOT}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ pam? ( trinity-base/tdebase-pam )"
+
+TSM_EXTRACT_ALSO="kcheckpass/"
+
+PATCHES=( "$FILESDIR/${PN}-3.5.13.1-onlyshowin-tde.patch")
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCURSORS=ON
+ -DWITH_XRENDER=ON
+ $(cmake-utils_use_with pam PAM)
+ $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ )
+
+ trinity-meta_src_configure
+}
+
+src_install() {
+ trinity-meta_src_install
+ trinity-base_fix_desktop_files "${D}${TDEDIR}/share/apps/kdesktop/Desktop/"*
+}
diff --git a/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.2.ebuild b/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.2.ebuild
new file mode 100644
index 000000000..00ad2bdc0
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/kdesktop-3.5.13.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The part of TDE ui that handles icons, desktop, screensaver etc"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam xscreensaver"
+
+DEPEND="x11-libs/libXrender
+ x11-libs/libXcursor
+ >=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/kcontrol-${PV}:${SLOT}
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ >=trinity-base/kcheckpass-${PV}:${SLOT}
+ >=trinity-base/kdialog-${PV}:${SLOT}
+ >=trinity-base/konqueror-${PV}:${SLOT}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ pam? ( trinity-base/tdebase-pam )"
+
+TSM_EXTRACT_ALSO="kcheckpass/"
+
+PATCHES=( "$FILESDIR/${PN}-3.5.13.1-onlyshowin-tde.patch")
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCURSORS=ON
+ -DWITH_XRENDER=ON
+ $(cmake-utils_use_with pam PAM)
+ $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ )
+
+ trinity-meta_src_configure
+}
+
+src_install() {
+ trinity-meta_src_install
+ trinity-base_fix_desktop_files "${D}${TDEDIR}/share/apps/kdesktop/Desktop/"*
+}
diff --git a/gentoo/trinity-base/kdesktop/kdesktop-9999.ebuild b/gentoo/trinity-base/kdesktop/kdesktop-9999.ebuild
new file mode 100644
index 000000000..43531a0df
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/kdesktop-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The part of TDE ui that handles icons, desktop, screensaver etc"
+KEYWORDS=
+IUSE="pam xscreensaver"
+
+COMMON_DEPEND="x11-libs/libXrender
+ x11-libs/libXcursor
+ >=trinity-base/libkonq-${PV}:${SLOT}
+ >=trinity-base/kcontrol-${PV}:${SLOT}
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+DEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ xscreensaver? ( x11-misc/xscreensaver )"
+# TODO remove x11-misc/xscreensaver after TDE bug # will be fixed
+RDEPEND="${COMMON_DEPEND}
+ >=trinity-base/kcheckpass-${PV}:${SLOT}
+ >=trinity-base/kdialog-${PV}:${SLOT}
+ >=trinity-base/konqueror-${PV}:${SLOT}
+ pam? ( trinity-base/tdebase-pam )"
+
+TSM_EXTRACT_ALSO="kcheckpass/"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCURSORS=ON
+ -DWITH_XRENDER=ON
+ $(cmake-utils_use_with pam PAM)
+ $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ )
+
+ trinity-meta_src_configure
+}
diff --git a/gentoo/trinity-base/kdesktop/metadata.xml b/gentoo/trinity-base/kdesktop/metadata.xml
new file mode 100644
index 000000000..04b5336cd
--- /dev/null
+++ b/gentoo/trinity-base/kdesktop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+ <longdescription>
+ KDesktop is the Trinity interface that handles icons, desktop popup menus and screensaver system.
+ </longdescription>
+</pkgmetadata>