summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild')
-rw-r--r--gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild b/gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild
new file mode 100644
index 000000000..64fd8d860
--- /dev/null
+++ b/gentoo/trinity-base/kmilo/kmilo-3.5.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdeutils"
+
+inherit trinity-meta
+
+DESCRIPTION="kded module supports some hardware input devices, such as special keys"
+KEYWORDS="x86 amd64"
+IUSE="asus-laptop dell-laptop powerbook-laptop thinkpad-laptop vaio-laptop lm_sensors"
+
+DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
+RDEPEND="${DEPEND}
+ lm_sensors? ( sys-apps/lm_sensors )"
+
+PATCHES=( "$FILESDIR/${TRINITY_MODULE_NAME}-${PV}-${PN}-fix-powerbook.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with asus-laptop ASUS)
+ $(cmake-utils_use_with dell-laptop I8K)
+ $(cmake-utils_use_with powerbook-laptop POWERBOOK2)
+ $(cmake-utils_use_with thinkpad-laptop THINKPAD)
+ $(cmake-utils_use_with vaio-laptop VAIO)
+ $(cmake-utils_use_with lm_sensors SENSORS)
+ )
+
+ trinity-meta_src_configure
+}