summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/libkonq
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/libkonq')
-rw-r--r--gentoo/trinity-base/libkonq/Manifest2
-rw-r--r--gentoo/trinity-base/libkonq/files/libkonq-3.5.13.1-onlyshowin-tde.patch20
l---------gentoo/trinity-base/libkonq/files/shared1
-rw-r--r--gentoo/trinity-base/libkonq/libkonq-3.5.13.1.ebuild22
-rw-r--r--gentoo/trinity-base/libkonq/libkonq-3.5.13.2.ebuild22
-rw-r--r--gentoo/trinity-base/libkonq/libkonq-9999.ebuild12
-rw-r--r--gentoo/trinity-base/libkonq/metadata.xml8
7 files changed, 87 insertions, 0 deletions
diff --git a/gentoo/trinity-base/libkonq/Manifest b/gentoo/trinity-base/libkonq/Manifest
new file mode 100644
index 000000000..381340c4b
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/Manifest
@@ -0,0 +1,2 @@
+DIST kdebase-3.5.13.1.tar.gz 29403228 SHA256 ddd4bd4b508ad027b9d1af2701c6ba64bfc9f8f1d32099e6dd5e7866714f759e SHA512 e1aac19c941a5f2b43a57928fdb43e5ebd646f49c60911d9d317550df96642870792c4e77ecd06e123244e2425ccd4bcb00f0a21011ba7e651d7fcf4553e79cf WHIRLPOOL 931debbf6a65c280221025dcbc02cbb3387b66eb72eddd28a510ee8f97075cd2cc96535dde25d0a32280c399e4a868e9c027772f5d28e7e79b7c1a9080c58034
+DIST kdebase-trinity-3.5.13.2.tar.xz 25890636 SHA256 b9d552226daff64437dfb9699669b95dd7ebc2ca7c43755ba71c10cc6c9ed789 SHA512 df545d44c7d4550d1d77ff6504572b622853c2b8d80062b1aee1a5bdca19f0e708cde35cff54cf2d5098f06a41bde0c89522a3958dea9bb18205dea87c11b797 WHIRLPOOL 79144273bc7985c59a593a3394b12a2053532d2c4c890ce96adad21f6de0413baf3c6270d6d06173ec4546b20d401aa0cc81603d01b8ee41dbdefc825b39b2b1
diff --git a/gentoo/trinity-base/libkonq/files/libkonq-3.5.13.1-onlyshowin-tde.patch b/gentoo/trinity-base/libkonq/files/libkonq-3.5.13.1-onlyshowin-tde.patch
new file mode 100644
index 000000000..9be02ad7c
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/files/libkonq-3.5.13.1-onlyshowin-tde.patch
@@ -0,0 +1,20 @@
+diff --git a/libkonq/konq_popupmenu.cc b/libkonq/konq_popupmenu.cc
+index 6cd19e5..f58f2e1 100644
+--- a/libkonq/konq_popupmenu.cc
++++ b/libkonq/konq_popupmenu.cc
+@@ -883,13 +883,13 @@ void KonqPopupMenu::setup(KonqPopupFlags kpf)
+ const TQString onlyShowIn = service->property("OnlyShowIn", TQVariant::String).toString();
+ if ( !onlyShowIn.isEmpty() ) {
+ const TQStringList aList = TQStringList::split(';', onlyShowIn);
+- if (!aList.contains("KDE"))
++ if (!aList.contains("TDE"))
+ continue;
+ }
+ const TQString notShowIn = service->property("NotShowIn", TQVariant::String).toString();
+ if ( !notShowIn.isEmpty() ) {
+ const TQStringList aList = TQStringList::split(';', notShowIn);
+- if (aList.contains("KDE"))
++ if (aList.contains("TDE"))
+ continue;
+ }
+
diff --git a/gentoo/trinity-base/libkonq/files/shared b/gentoo/trinity-base/libkonq/files/shared
new file mode 120000
index 000000000..ffc286806
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/files/shared
@@ -0,0 +1 @@
+../../../eclass/trinity-shared-files \ No newline at end of file
diff --git a/gentoo/trinity-base/libkonq/libkonq-3.5.13.1.ebuild b/gentoo/trinity-base/libkonq/libkonq-3.5.13.1.ebuild
new file mode 100644
index 000000000..f34eaa4bd
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/libkonq-3.5.13.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The embeddable part of konqueror"
+KEYWORDS="x86 amd64"
+IUSE="arts"
+DEPEND="arts? ( >=trinity-base/arts-${PV}:${SLOT} )"
+RDEPEND="$DEPEND"
+PATCHES=( "$FILESDIR/${PN}-3.5.13.1-onlyshowin-tde.patch")
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with arts ARTS)
+ )
+
+ trinity-meta_src_configure
+}
diff --git a/gentoo/trinity-base/libkonq/libkonq-3.5.13.2.ebuild b/gentoo/trinity-base/libkonq/libkonq-3.5.13.2.ebuild
new file mode 100644
index 000000000..7919747e5
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/libkonq-3.5.13.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="The embeddable part of konqueror"
+KEYWORDS="~amd64 ~x86"
+IUSE="arts"
+DEPEND="arts? ( >=trinity-base/arts-${PV}:${SLOT} )"
+RDEPEND="$DEPEND"
+PATCHES=( "$FILESDIR/${PN}-3.5.13.1-onlyshowin-tde.patch")
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with arts ARTS)
+ )
+
+ trinity-meta_src_configure
+}
diff --git a/gentoo/trinity-base/libkonq/libkonq-9999.ebuild b/gentoo/trinity-base/libkonq/libkonq-9999.ebuild
new file mode 100644
index 000000000..45b06ee57
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/libkonq-9999.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+need-arts optional
+
+DESCRIPTION="The embeddable part of konqueror"
+KEYWORDS=
diff --git a/gentoo/trinity-base/libkonq/metadata.xml b/gentoo/trinity-base/libkonq/metadata.xml
new file mode 100644
index 000000000..6e9f5e4a1
--- /dev/null
+++ b/gentoo/trinity-base/libkonq/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+</pkgmetadata>