summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/lisa
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/lisa')
-rw-r--r--gentoo/trinity-base/lisa/Manifest1
-rw-r--r--gentoo/trinity-base/lisa/files/lisa19
-rw-r--r--gentoo/trinity-base/lisa/files/lisa-3.5.13.1-6f85c0c-fix-references-to-user-profile-directory.patch52
-rw-r--r--gentoo/trinity-base/lisa/files/lisa.conf11
-rw-r--r--gentoo/trinity-base/lisa/files/reslisa19
-rw-r--r--gentoo/trinity-base/lisa/files/reslisa.conf8
-rw-r--r--gentoo/trinity-base/lisa/lisa-3.5.13.1.ebuild31
-rw-r--r--gentoo/trinity-base/lisa/lisa-9999.ebuild28
-rw-r--r--gentoo/trinity-base/lisa/metadata.xml8
9 files changed, 177 insertions, 0 deletions
diff --git a/gentoo/trinity-base/lisa/Manifest b/gentoo/trinity-base/lisa/Manifest
new file mode 100644
index 000000000..1d49700dc
--- /dev/null
+++ b/gentoo/trinity-base/lisa/Manifest
@@ -0,0 +1 @@
+DIST kdenetwork-3.5.13.1.tar.gz 8794225 SHA256 21e69e8cb2550561c26913a5cccdc376115f50cffd43f9a94f7a660a303f46f9 SHA512 b3189a9f5e9cddd130b24a82b95ef90db1ec3c7afa280a46101ba7cbf6f9d92f60a536401f648a96459ba87f70ede5f7ae4affe894515a8e858b40ee79cb1b69 WHIRLPOOL de678ab30e3aa8dc3068c895fd000fdab1bc046e272273bf44196a198210efab82ddde3c5e0ffaa863061e9c56e3a8a68ca2f8f03cd77136755f66688f878c65
diff --git a/gentoo/trinity-base/lisa/files/lisa b/gentoo/trinity-base/lisa/files/lisa
new file mode 100644
index 000000000..eeeae68c7
--- /dev/null
+++ b/gentoo/trinity-base/lisa/files/lisa
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting lisa"
+ start-stop-daemon --start -x _TDEDIR_/bin/lisa -q -- $LISACONF 1>/dev/null
+ eend $? "Failed to start lisa"
+}
+
+stop() {
+ ebegin "Stopping lisa"
+ start-stop-daemon --stop -x _TDEDIR_/bin/lisa -q
+ eend $? "Failed to stop lisa"
+}
diff --git a/gentoo/trinity-base/lisa/files/lisa-3.5.13.1-6f85c0c-fix-references-to-user-profile-directory.patch b/gentoo/trinity-base/lisa/files/lisa-3.5.13.1-6f85c0c-fix-references-to-user-profile-directory.patch
new file mode 100644
index 000000000..ea9dbbeba
--- /dev/null
+++ b/gentoo/trinity-base/lisa/files/lisa-3.5.13.1-6f85c0c-fix-references-to-user-profile-directory.patch
@@ -0,0 +1,52 @@
+diff --git a/lanbrowsing/lisa/README b/lanbrowsing/lisa/README
+index c6d5d1b..5b7c328 100644
+--- a/lanbrowsing/lisa/README
++++ b/lanbrowsing/lisa/README
+@@ -382,7 +382,7 @@ For reslisa the file is named reslisarc instead lisarc.
+ -u, --unix search at first for $HOME/.lisarc, then
+ for /etc/lisarc, this is the default behaviour
+
+--k, --kde1 search at first for $HOME/.kde/share/config/lisarc,
++-k, --kde1 search at first for $HOME/.trinity/share/config/lisarc,
+ then for $KDEDIR/share/config/lisarc
+
+ -K, --kde2 looks for the file lisarc in every directory
+diff --git a/lanbrowsing/lisa/main.cpp b/lanbrowsing/lisa/main.cpp
+index 7de5938..fd96d04 100644
+--- a/lanbrowsing/lisa/main.cpp
++++ b/lanbrowsing/lisa/main.cpp
+@@ -198,7 +198,7 @@ int main(int argc, char** argv)
+ "--kde1, --kde2 and --unix are not supported anymore.\n"\
+ "Lisa will always first look for $(HOME)/.lisarc , then for /etc/lisarc.\n"\
+ "If your lisa configuration file was created using an older version of \n"\
+- "the KDE control center, copy the /root/.kde/share/config/lisarc to /etc and \n"\
++ "the KDE control center, copy the /root/.trinity/share/config/lisarc to /etc and \n"\
+ "then start lisa without any command line options.\n"<<std::endl;
+ return 0;
+ break;
+diff --git a/lanbrowsing/lisa/netmanager.cpp b/lanbrowsing/lisa/netmanager.cpp
+index e652ce9..ad905e3 100644
+--- a/lanbrowsing/lisa/netmanager.cpp
++++ b/lanbrowsing/lisa/netmanager.cpp
+@@ -338,7 +338,7 @@ MyString NetManager::getConfigFileName()
+ /* else if (m_configStyle==KDE1CONFIGSTYLE)
+ {
+ tmpFilename=getenv("HOME");
+- tmpFilename+=MyString("/.kde/share/config/")+tmpBase;
++ tmpFilename+=MyString("/.trinity/share/config/")+tmpBase;
+ if (fileReadable(tmpFilename))
+ return tmpFilename;
+ tmpFilename=getenv("KDEDIR");
+diff --git a/lanbrowsing/lisa/strictmain.cpp b/lanbrowsing/lisa/strictmain.cpp
+index a948d6d..07f5b9b 100644
+--- a/lanbrowsing/lisa/strictmain.cpp
++++ b/lanbrowsing/lisa/strictmain.cpp
+@@ -187,7 +187,7 @@ int main(int argc, char** argv)
+ "--kde1, --kde2 and --unix are not supported anymore.\n"\
+ "ResLisa will always first look for $(HOME)/.reslisarc , then for /etc/reslisarc.\n"\
+ "If your lisa configuration file was created using an older version of \n"\
+- "the KDE control center, copy the $(HOME)/.kde/share/config/reslisarc to $(HOME)/.reslisarc.\n"<<std::endl;
++ "the KDE control center, copy the $(HOME)/.trinity/share/config/reslisarc to $(HOME)/.reslisarc.\n"<<std::endl;
+ break;
+
+ case 'c':
diff --git a/gentoo/trinity-base/lisa/files/lisa.conf b/gentoo/trinity-base/lisa/files/lisa.conf
new file mode 100644
index 000000000..bad3fa826
--- /dev/null
+++ b/gentoo/trinity-base/lisa/files/lisa.conf
@@ -0,0 +1,11 @@
+# Note: this is NOT the main lisa configuratio file. That is in /etc/lisarc.
+# This merely sets startup options for the gentoo lisa initscript.
+# Add anything you want to $LISACONF.
+
+# config file to use; overrides default
+# note that default checks /etc/lisarc and ~/.lisarc
+# LISACONF="$LISACONF --config=myfile"
+
+# port to use; overrides default of 7741
+# I think all lisas on the network have to use the same port
+# LISACONF="$LISACONF --port 7741" \ No newline at end of file
diff --git a/gentoo/trinity-base/lisa/files/reslisa b/gentoo/trinity-base/lisa/files/reslisa
new file mode 100644
index 000000000..dcb2c6560
--- /dev/null
+++ b/gentoo/trinity-base/lisa/files/reslisa
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting reslisa"
+ start-stop-daemon --start -x _TDEDIR_/bin/reslisa -q -- 1>/dev/null
+ eend $? "Failed to start reslisa"
+}
+
+stop() {
+ ebegin "Stopping reslisa"
+ start-stop-daemon --stop -x _TDEDIR_/bin/reslisa -q
+ eend $? "Failed to stop reslisa"
+}
diff --git a/gentoo/trinity-base/lisa/files/reslisa.conf b/gentoo/trinity-base/lisa/files/reslisa.conf
new file mode 100644
index 000000000..0a74c6cae
--- /dev/null
+++ b/gentoo/trinity-base/lisa/files/reslisa.conf
@@ -0,0 +1,8 @@
+# Note: this is NOT the main reslisa configuratio file. That is in /etc/reslisarc.
+# This merely sets startup options for the gentoo reslisa initscript.
+# Add anything you want to $RESLISACONF.
+
+# config file to use; overrides default
+# note that default checks /etc/reslisarc and ~/.reslisarc
+# RESLISACONF="$RESLISACONF --config=myfile"
+
diff --git a/gentoo/trinity-base/lisa/lisa-3.5.13.1.ebuild b/gentoo/trinity-base/lisa/lisa-3.5.13.1.ebuild
new file mode 100644
index 000000000..56319dfb4
--- /dev/null
+++ b/gentoo/trinity-base/lisa/lisa-3.5.13.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdenetwork"
+TRINITY_SUBMODULE="lanbrowsing"
+inherit trinity-meta
+
+DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
+KEYWORDS="amd64 x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/lisa-3.5.13.1-6f85c0c-fix-references-to-user-profile-directory.patch" )
+
+src_install() {
+ trinity-meta_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/lisa" > "${T}/lisa"
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${FILESDIR}/lisa.conf" lisa
+ newconfd "${FILESDIR}/reslisa.conf" reslisa
+
+ echo '# Default lisa configfile' > "$D/etc/lisarc"
+ echo '# Default reslisa configfile' > "$D/etc/reslisarc"
+}
diff --git a/gentoo/trinity-base/lisa/lisa-9999.ebuild b/gentoo/trinity-base/lisa/lisa-9999.ebuild
new file mode 100644
index 000000000..4b01ce18e
--- /dev/null
+++ b/gentoo/trinity-base/lisa/lisa-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdenetwork"
+TRINITY_SUBMODULE="lanbrowsing"
+inherit trinity-meta
+
+DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
+KEYWORDS=
+IUSE=""
+
+src_install() {
+ trinity-meta_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/lisa" > "${T}/lisa"
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${FILESDIR}/lisa.conf" lisa
+ newconfd "${FILESDIR}/reslisa.conf" reslisa
+
+ echo '# Default lisa configfile' > "$D/etc/lisarc"
+ echo '# Default reslisa configfile' > "$D/etc/reslisarc"
+}
diff --git a/gentoo/trinity-base/lisa/metadata.xml b/gentoo/trinity-base/lisa/metadata.xml
new file mode 100644
index 000000000..6e9f5e4a1
--- /dev/null
+++ b/gentoo/trinity-base/lisa/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+</pkgmetadata>