summaryrefslogtreecommitdiffstats
path: root/redhat/applications/amarok/amarok-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/amarok/amarok-14.0.0.spec')
-rw-r--r--redhat/applications/amarok/amarok-14.0.0.spec10
1 files changed, 5 insertions, 5 deletions
diff --git a/redhat/applications/amarok/amarok-14.0.0.spec b/redhat/applications/amarok/amarok-14.0.0.spec
index c17360fff..9ca3797ac 100644
--- a/redhat/applications/amarok/amarok-14.0.0.spec
+++ b/redhat/applications/amarok/amarok-14.0.0.spec
@@ -364,13 +364,13 @@ export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
# Specific path for RHEL4
if [ -d /usr/X11R6 ]; then
- export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
+ export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
-%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
-%__mkdir_p build
-cd build
-%endif
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
# Warning: GCC visibility causes FTBFS [Bug #1285]
%cmake \