summaryrefslogtreecommitdiffstats
path: root/redhat/applications/development/kscope/kscope.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/development/kscope/kscope.spec')
-rw-r--r--redhat/applications/development/kscope/kscope.spec190
1 files changed, 190 insertions, 0 deletions
diff --git a/redhat/applications/development/kscope/kscope.spec b/redhat/applications/development/kscope/kscope.spec
new file mode 100644
index 000000000..36bade6eb
--- /dev/null
+++ b/redhat/applications/development/kscope/kscope.spec
@@ -0,0 +1,190 @@
+#
+# spec file for package kscope (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.1.0
+%endif
+%define tde_pkg kscope
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.6.2
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: Source editing environment for TDE
+Group: Applications/Internet
+URL: http://kscope.sourceforge.net
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+Requires: cscope
+
+BuildRequires: trinity-tde-cmake >= %{tde_version}
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+BuildRequires: flex
+BuildRequires: bison
+
+
+%description
+KScope is a TDE front-end to Cscope. It provides a source-editing environment
+for large C projects. KScope is focused on source editing and analysis.
+
+KScope is built around an efficient mechanism for code-navigation, which
+allows the user to run queries on the code.
+
+The types of queries KScope can run include:
+* Get all references to a symbol
+* Find the definition of a symbol
+* Find all functions called by or calling to a function
+* Find an EGrep pattern
+* Find all files #including some file
+
+These queries are handled by an underlying Cscope process. KScope simply
+serves as a front-end to this process, feeding it with queries, and parsing
+its output into result lists. The items in those lists can later be selected
+to open an editor at the matching line.
+
+Main Features:
+* Multiple editor windows (using your favourite TDE editor)
+* Project management
+* Front-end to most Cscope queries
+* Tag list for every open editor
+* Call-tree window
+* Session management, including saving and restoring queries
+* Works with externally-built cscope.out files
+
+
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
+%debug_package
+%endif
+
+##########
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+# Warning: GCC visibility causes FTBFS [Bug #1285]
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS}" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS}" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_SKIP_INSTALL_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_NO_BUILTIN_CHRPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DBIN_INSTALL_DIR=%{tde_bindir} \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ \
+ -DWITH_ALL_OPTIONS=ON \
+ -DBUILD_ALL=ON \
+ ..
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+%__rm -rf $RPM_BUILD_ROOT
+%__make install DESTDIR=$RPM_BUILD_ROOT -C build
+
+%find_lang %{tde_pkg}
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file %{tde_pkg} Development IDE
+%endif
+
+
+%clean
+%__rm -rf $RPM_BUILD_ROOT
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING README.md ChangeLog
+%{tde_bindir}/kscope
+%{tde_tdeappdir}/kscope.desktop
+%{tde_datadir}/apps/kscope/
+%{tde_tdedocdir}/HTML/en/kscope/
+%{tde_datadir}/icons/hicolor/*/apps/kscope.png
+%{tde_datadir}/icons/locolor/*/apps/kscope.png
+%{tde_mandir}/man1/kscope.1*
+
+
+%changelog