summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kasablanca/kasablanca-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kasablanca/kasablanca-14.0.0.spec')
-rw-r--r--redhat/applications/kasablanca/kasablanca-14.0.0.spec103
1 files changed, 68 insertions, 35 deletions
diff --git a/redhat/applications/kasablanca/kasablanca-14.0.0.spec b/redhat/applications/kasablanca/kasablanca-14.0.0.spec
index 799da2d99..49bce921b 100644
--- a/redhat/applications/kasablanca/kasablanca-14.0.0.spec
+++ b/redhat/applications/kasablanca/kasablanca-14.0.0.spec
@@ -1,50 +1,85 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# Default version for this component
-%define tde_pkg kasablanca
+#
+# spec file for package kasablanca (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# TDE specific building variables
+%define tde_pkg kasablanca
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: Graphical FTP client
+Epoch: %{tde_epoch}
Version: 0.4.0.2
-Release: %{?!preversion:4}%{?preversion:3_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
-Url: http://kasablanca.berlios.de/
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Graphical FTP client for Trinity
Group: Applications/Internet
+Url: http://kasablanca.berlios.de/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-Patch1: kasablanca-14.0.0-fix_ftp.patch
+Patch0: %{tde_pkg}-%{tde_version}.patch
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
BuildRequires: gettext
+
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# OPENSSL support
BuildRequires: openssl-devel
+# UTEMPTER support
%if 0%{?suse_version}
BuildRequires: utempter-devel
%else
@@ -65,14 +100,18 @@ Kasablanca is an ftp client, among its features are currently:
* small nifty features, like a skiplist.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%patch1 -p1 -b .ftpthread
+%patch0 -p1 -b .orig
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
@@ -82,7 +121,6 @@ Kasablanca is an ftp client, among its features are currently:
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
## Needed(?) for older/legacy setups, harmless otherwise
if pkg-config openssl ; then
@@ -116,6 +154,11 @@ export PATH="%{tde_bindir}:${PATH}"
# locale's
%find_lang %{tde_pkg}
+# Fix desktop files (openSUSE only)
+%if 0%{?suse_version}
+%suse_update_desktop_file kasablanca Network FileTransfer
+%endif
+
%clean
%__rm -rf $RPM_BUILD_ROOT
@@ -144,19 +187,9 @@ gtk-update-icon-cache %{tde_datadir}/icons/hicolor &> /dev/null || :
%{tde_datadir}/config.kcfg/kbconfig.kcfg
%{tde_datadir}/icons/hicolor/*/apps/kasablanca.png
%{tde_tdedocdir}/HTML/en/kasablanca/
-%{tde_datadir}/applnk/Utilities/kasablanca.desktop
+%{tde_tdeappdir}/kasablanca.desktop
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.4.0.2-4
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:0.4.0.2-1
- Initial release for TDE 14.0.0
-
-* Sat Jan 19 2013 Francois Andriot <francois.andriot@free.fr> - 0.4.0.2-3
-- Initial release for TDE 3.5.13.2
-
-* Wed Oct 03 2012 Francois Andriot <francois.andriot@free.fr> - 0.4.0.2-2
-- Initial release for TDE 3.5.13.1
-
-* Sun Dec 04 2011 Francois Andriot <francois.andriot@free.fr> - 0.4.0.2-1
-- Initial release for RHEL 5, RHEL 6, Fedora 15, Fedora 16
-- Based on Fedora 12 Spec 'kasablanca-0.4.0.2-17'