summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbarcode/trinity-kbarcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbarcode/trinity-kbarcode.spec')
-rw-r--r--redhat/applications/kbarcode/trinity-kbarcode.spec107
1 files changed, 68 insertions, 39 deletions
diff --git a/redhat/applications/kbarcode/trinity-kbarcode.spec b/redhat/applications/kbarcode/trinity-kbarcode.spec
index 507e0b1a5..83e71e5a2 100644
--- a/redhat/applications/kbarcode/trinity-kbarcode.spec
+++ b/redhat/applications/kbarcode/trinity-kbarcode.spec
@@ -1,25 +1,32 @@
# Default version for this component
%define kdecomp kbarcode
-%define version 2.0.6
-%define release 1
# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?_prefix}" != "/usr"
+%if "%{?tde_prefix}" != "/usr"
%define _variant .opt
-%define _docdir %{_prefix}/share/doc
%endif
# TDE 3.5.13 specific building variables
-BuildRequires: autoconf automake libtool m4
-%define tde_docdir %{_docdir}/kde
-%define tde_includedir %{_includedir}/kde
-%define tde_libdir %{_libdir}/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/kde
+%define tde_tdedocdir %{tde_docdir}/kde
+%define tde_tdeincludedir %{tde_includedir}/kde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
Name: trinity-%{kdecomp}
Summary: barcode and label printing application for Trinity
-Version: %{?version}
-Release: %{?release}%{?dist}%{?_variant}
+Version: 2.0.6
+Release: 1%{?dist}%{?_variant}
License: GPLv2+
Group: Applications/Utilities
@@ -28,14 +35,22 @@ Vendor: Trinity Project
Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.kbarcode.net
-Prefix: %{_prefix}
+Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{kdecomp}-3.5.13.tar.gz
+# [kbarcode] Fix 'format not a string literal' error [Commit #14ba7d8a]
+Patch1: kbarcode-3.5.13-fix_format_not_a_string_literal.patch
+# [kbarcode] Fix FTBFS [Commit #62777d27]
+Patch2: kbarcode-3.5.13-fix_ftbfs.patch
+# [kbarcode] Fix remaining string format errors [Commit #b8dc3f57]
+Patch3: kbarcode-3.5.13-fix_remaining_string_literal.patch
+
+
BuildRequires: tqtinterface-devel
-BuildRequires: trinity-kdelibs-devel
-BuildRequires: trinity-kdebase-devel
+BuildRequires: trinity-tdelibs-devel
+BuildRequires: trinity-tdebase-devel
BuildRequires: desktop-file-utils
BuildRequires: gettext
@@ -62,32 +77,41 @@ to use them in another application.
%prep
%setup -q -n applications/%{kdecomp}
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
# Ugly hack to modify TQT include directory inside autoconf files.
# If TQT detection fails, it fallbacks to TQT4 instead of TQT3 !
-%__sed -i admin/acinclude.m4.in \
- -e "s|/usr/include/tqt|%{_includedir}/tqt|g" \
- -e "s|kde_htmldir='.*'|kde_htmldir='%{tde_docdir}/HTML'|g"
+%__sed -i "admin/acinclude.m4.in" \
+ -e "s|/usr/include/tqt|%{tde_includedir}/tqt|g" \
+ -e "s|kde_htmldir='.*'|kde_htmldir='%{tde_tdedocdir}/HTML'|g"
%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f admin/Makefile.common
+%__make -f "admin/Makefile.common"
%build
-export PATH="%{_bindir}:${PATH}"
-export LDFLAGS="-L%{_libdir} -I%{_includedir}"
+unset QTDIR; . /etc/profile.d/qt.sh
+export PATH="%{tde_bindir}:${PATH}"
+export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
%configure \
- --disable-rpath \
- --with-extra-includes=%{_includedir}/tqt:%{tde_includedir}
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --libdir=%{tde_libdir} \
+ --datadir=%{tde_datadir} \
+ --disable-rpath \
+ --with-extra-includes=%{_includedir}/tqt
# SMP safe !
%__make %{?_smp_mflags}
%install
-export PATH="%{_bindir}:${PATH}"
+export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot}
@@ -101,30 +125,35 @@ export PATH="%{_bindir}:${PATH}"
%post
-touch --no-create %{_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
-/sbin/ldconfig || :
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+update-desktop-database %{tde_appdir} &> /dev/null
%postun
-touch --no-create %{_datadir}/icons/hicolor || :
-gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
-/sbin/ldconfig || :
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+update-desktop-database %{tde_appdir} &> /dev/null
%files -f %{kdecomp}.lang
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
-%{_bindir}/kbarcode
-%{tde_libdir}/kfile_kbarcode.la
-%{tde_libdir}/kfile_kbarcode.so
-%{_datadir}/applications/kde/kbarcode-batch.desktop
-%{_datadir}/applications/kde/kbarcode-editor.desktop
-%{_datadir}/applications/kde/kbarcode-label.desktop
-%{_datadir}/applications/kde/kbarcode-single.desktop
-%{_datadir}/applications/kde/kbarcode.desktop
-%{_datadir}/apps/kbarcode
-%{_datadir}/icons/hicolor/*/*/*.png
-%{_datadir}/services/kfile_kbarcode.desktop
+%{tde_bindir}/kbarcode
+%{tde_tdelibdir}/kfile_kbarcode.la
+%{tde_tdelibdir}/kfile_kbarcode.so
+%{tde_tdeappdir}/kbarcode-batch.desktop
+%{tde_tdeappdir}/kbarcode-editor.desktop
+%{tde_tdeappdir}/kbarcode-label.desktop
+%{tde_tdeappdir}/kbarcode-single.desktop
+%{tde_tdeappdir}/kbarcode.desktop
+%{tde_datadir}/apps/kbarcode/
+%{tde_datadir}/icons/hicolor/*/actions/barcode.png
+%{tde_datadir}/icons/hicolor/*/actions/kbarcodeellipse.png
+%{tde_datadir}/icons/hicolor/*/actions/kbarcodegrid.png
+%{tde_datadir}/icons/hicolor/*/actions/kbarcodelinetool.png
+%{tde_datadir}/icons/hicolor/*/actions/kbarcoderect.png
+%{tde_datadir}/icons/hicolor/*/apps/kbarcode.png
+%{tde_datadir}/services/kfile_kbarcode.desktop
%Changelog