summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbfx/kbfx-3.5.13.1.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbfx/kbfx-3.5.13.1.spec')
-rw-r--r--redhat/applications/kbfx/kbfx-3.5.13.1.spec169
1 files changed, 169 insertions, 0 deletions
diff --git a/redhat/applications/kbfx/kbfx-3.5.13.1.spec b/redhat/applications/kbfx/kbfx-3.5.13.1.spec
new file mode 100644
index 000000000..78b6bd502
--- /dev/null
+++ b/redhat/applications/kbfx/kbfx-3.5.13.1.spec
@@ -0,0 +1,169 @@
+# Default version for this component
+%define kdecomp kbfx
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+
+# TDE 3.5.13 specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/kde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{kdecomp}
+Summary: an alternative to K-Menu for KDE [Trinity]
+Version: 0.4.9.3.1
+Release: 2%{?dist}%{?_variant}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{kdecomp}-3.5.13.1.tar.gz
+
+# [kbfx] Some files are installed in wrong directories ...
+Patch2: kbfx-3.5.13.1-fix_install_directories.patch
+
+
+BuildRequires: trinity-tqtinterface-devel >= 3.5.13.1
+BuildRequires: trinity-tdelibs-devel >= 3.5.13.1
+BuildRequires: trinity-tdebase-devel >= 3.5.13.1
+BuildRequires: desktop-file-utils
+
+%description
+KBFX is an alternative to the classical K-Menu button and its menu.
+It improves the user experience by enabling him to set a bigger (and thus more
+visible) start button and by finally replacing the Win95-like K-Menu.
+If you still want the old menu, because you're used to it, it is still
+available as an option in kbfx. We recommend, however, that you give the Spinx
+bar a try.
+
+Homepage: http://www.kbfx.org
+
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+
+%prep
+%setup -q -n %{kdecomp}-3.5.13.1
+%patch2 -p1 -b .dir
+
+# Fix TDE executable path in 'CMakeLists.txt' ...
+%__sed -i "CMakeLists.txt" \
+ -e "s|/usr/bin/uic-tqt|%{tde_bindir}/uic-tqt|" \
+ -e "s|/usr/bin/tmoc|%{tde_bindir}/tmoc|" \
+ -e "s|/usr/include/tqt|%{tde_includedir}/tqt|"
+
+%build
+unset QTDIR || : ; . /etc/profile.d/qt3.sh
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+export CMAKE_INCLUDE_PATH="%{tde_includedir}:%{tde_tdeincludedir}:%{tde_includedir}/tqt"
+
+%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
+%__mkdir_p build
+cd build
+%endif
+
+%cmake \
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DINCLUDE_INSTALL_DIR=%{tde_tdeincludedir} \
+ -DDATA_INSTALL_DIR=%{tde_datadir}/apps \
+ -DMIME_INSTALL_DIR=%{tde_datadir}/mimelnk \
+ -DXDG_APPS_INSTALL_DIR=%{tde_tdeappdir} \
+ -DDOC_INSTALL_DIR=%{tde_tdedocdir} \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DUSE_STRIGI=OFF \
+ -DUSE_MENUDRAKE=OFF \
+ -DBUILD_DOC=ON \
+ -DBUILD_ALL=OFF \
+ ..
+
+# Not SMP safe !
+%__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build VERBOSE=1
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+/sbin/ldconfig
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+update-desktop-database %{tde_appdir} &> /dev/null
+
+%postun
+/sbin/ldconfig
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+update-desktop-database %{tde_appdir} &> /dev/null
+
+
+%files
+%defattr(-,root,root,-)
+%{tde_bindir}/kbfxconfigapp
+%{tde_tdeincludedir}/kbfx/
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadataplasmoid.la
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadataplasmoid.so
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadatasettings.la
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadatasettings.so
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadatastub.la
+%{tde_libdir}/kbfx/plugins/libkbfxplasmadatastub.so
+%{tde_libdir}/kbfx/plugins/libkbfxplasmarecentstuff.la
+%{tde_libdir}/kbfx/plugins/libkbfxplasmarecentstuff.so
+%{tde_libdir}/libkbfxcommon.la
+%{tde_libdir}/libkbfxcommon.so
+%{tde_libdir}/libkbfxdata.la
+%{tde_libdir}/libkbfxdata.so
+%{tde_tdelibdir}/kbfxspinx.la
+%{tde_tdelibdir}/kbfxspinx.so
+%{tde_tdeappdir}/kbfx_theme.desktop
+%{tde_tdeappdir}/kbfxconfigapp.desktop
+%{tde_datadir}/apps/kbfx/skins/*/*
+%{tde_datadir}/apps/kbfxconfigapp/kbfxconfigappui.rc
+%{tde_datadir}/apps/kicker/applets/kbfxspinx.desktop
+%{tde_datadir}/apps/konqueror/servicemenus/kbfx_install_theme.desktop
+%{tde_datadir}/apps/konqueror/servicemenus/kbfx_prepare_theme.desktop
+#%{tde_tdedocdir}/HTML/en/common/kbfx-*.jpg
+#%{tde_tdedocdir}/HTML/en/kbfxconfigapp/
+%{tde_tdedocdir}/kbfx/
+%{tde_datadir}/icons/hicolor/*/apps/kbfx.png
+%{tde_datadir}/icons/hicolor/*/apps/kbfxconfigapp.png
+#%{tde_datadir}/locale/*/LC_MESSAGES/kbfxconfigapp.mo
+%{tde_datadir}/mimelnk/application/x-kbfxtheme.desktop
+
+
+%changelog
+* Wed Oct 03 2012 Francois Andriot <francois.andriot@free.fr> - 0.4.9.3.1-2
+- Initial build for TDE 3.5.13.1
+
+* Sun Nov 20 2011 Francois Andriot <francois.andriot@free.fr> - 0.4.9.3.1-1
+- Initial build for RHEL 5, RHEL 6, Fedora 15, Fedora 16