summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kdmtheme/trinity-kdmtheme.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kdmtheme/trinity-kdmtheme.spec')
-rw-r--r--redhat/applications/kdmtheme/trinity-kdmtheme.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/redhat/applications/kdmtheme/trinity-kdmtheme.spec b/redhat/applications/kdmtheme/trinity-kdmtheme.spec
new file mode 100644
index 000000000..05f4b43a5
--- /dev/null
+++ b/redhat/applications/kdmtheme/trinity-kdmtheme.spec
@@ -0,0 +1,108 @@
+# Default version for this component
+%define kdecomp kdmtheme
+%define version 1.2.2
+%define release 1
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?_prefix}" != "/usr"
+%define _variant .opt
+%define _docdir %{_prefix}/share/doc
+%endif
+
+# TDE 3.5.13 specific building variables
+BuildRequires: autoconf automake libtool m4
+%define tde_docdir %{_docdir}/kde
+%define tde_includedir %{_includedir}/kde
+%define tde_libdir %{_libdir}/trinity
+
+
+Name: trinity-%{kdecomp}
+Summary: theme manager for KDM [Trinity]
+Version: %{?version}
+Release: %{?release}%{?dist}%{?_variant}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://beta.smileaf.org/projects
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{kdecomp}-3.5.13.tar.gz
+Source1: kdmtheme.lintian-overrides
+
+BuildRequires: tqtinterface-devel
+BuildRequires: trinity-kdelibs-devel
+BuildRequires: trinity-kdebase-devel
+BuildRequires: desktop-file-utils
+BuildRequires: gettext
+
+
+%description
+kdmtheme is a theme manager for KDM. It provides a KDE Control Module (KCM)
+that allows you to easily install, remove and change your KDM themes.
+
+
+
+%prep
+%setup -q -n applications/%{kdecomp}
+
+# Ugly hack to modify TQT include directory inside autoconf files.
+# If TQT detection fails, it fallbacks to TQT4 instead of TQT3 !
+%__sed -i admin/acinclude.m4.in \
+ -e "s,/usr/include/tqt,%{_includedir}/tqt,g" \
+ -e "s,kde_htmldir='.*',kde_htmldir='%{tde_docdir}/HTML',g"
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+export PATH="%{_bindir}:${PATH}"
+export LDFLAGS="-L%{_libdir} -I%{_includedir}"
+
+%configure \
+ --disable-rpath \
+ --with-extra-includes=%{_includedir}/tqt
+
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+%__install -D -p -m644 %{SOURCE1} %{buildroot}%{_datadir}/lintian/overrides/kdmtheme-trinity
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+touch --no-create %{_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+
+%postun
+touch --no-create %{_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+
+
+%files
+%defattr(-,root,root,-)
+%{tde_libdir}/kcm_kdmtheme.la
+%{tde_libdir}/kcm_kdmtheme.so
+%{_datadir}/applications/kde/kdmtheme.desktop
+%{tde_docdir}/HTML/en/kdmtheme/common
+%{tde_docdir}/HTML/en/kdmtheme/index.cache.bz2
+%{tde_docdir}/HTML/en/kdmtheme/index.docbook
+%{_datadir}/lintian/overrides/kdmtheme-trinity
+
+
+%Changelog
+* Fri Nov 25 2011 Francois Andriot <francois.andriot@free.fr> - 1.2.2-1
+- Initial build for RHEL 5, RHEL 6, Fedora 15, Fedora 16