summaryrefslogtreecommitdiffstats
path: root/redhat/applications/keep/keep-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/keep/keep-14.0.0.spec')
-rw-r--r--redhat/applications/keep/keep-14.0.0.spec100
1 files changed, 68 insertions, 32 deletions
diff --git a/redhat/applications/keep/keep-14.0.0.spec b/redhat/applications/keep/keep-14.0.0.spec
index dbd4d6243..112cdcae7 100644
--- a/redhat/applications/keep/keep-14.0.0.spec
+++ b/redhat/applications/keep/keep-14.0.0.spec
@@ -1,56 +1,83 @@
-# Default version for this component
-%define tde_pkg keep
+#
+# spec file for package keep (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg keep
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-Name: trinity-%{tde_pkg}
-Summary: backup system for TDE [Trinity]
-Version: 0.4.0
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 0.4.0
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Backup system for TDE [Trinity]
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
BuildRequires: gettext
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
Requires: rdiff-backup
+
%description
Keep is an automatic backup program that allows users to set the parameters of
the backup, including the frequency and the number of backups.
@@ -58,10 +85,14 @@ the backup, including the frequency and the number of backups.
Homepage: http://jr.falleri.free.fr/keep
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -74,7 +105,6 @@ Homepage: http://jr.falleri.free.fr/keep
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
%configure \
--prefix=%{tde_prefix} \
@@ -103,6 +133,12 @@ export PATH="%{tde_bindir}:${PATH}"
%find_lang %{tde_pkg}
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r "keep" System Backup
+%endif
+
+
%clean
%__rm -rf %{buildroot}
@@ -110,12 +146,12 @@ export PATH="%{tde_bindir}:${PATH}"
%post
touch --no-create %{tde_datadir}/icons/hicolor || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_appdir} &> /dev/null
+update-desktop-database %{tde_tdeappdir} &> /dev/null
%postun
touch --no-create %{tde_datadir}/icons/hicolor || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
-update-desktop-database %{tde_appdir} &> /dev/null
+update-desktop-database %{tde_tdeappdir} &> /dev/null
%files -f %{tde_pkg}.lang
@@ -132,5 +168,5 @@ update-desktop-database %{tde_appdir} &> /dev/null
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.4.0-6
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:0.4.0-1
- Initial release for TDE 14.0.0