summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec')
-rw-r--r--redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec207
1 files changed, 207 insertions, 0 deletions
diff --git a/redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec b/redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec
new file mode 100644
index 000000000..5a0cde153
--- /dev/null
+++ b/redhat/applications/kmyfirewall/kmyfirewall-3.5.13.spec
@@ -0,0 +1,207 @@
+# Default version for this component
+%define kdecomp kmyfirewall
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+
+# TDE 3.5.13 specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/kde
+%define tde_tdedocdir %{tde_docdir}/kde
+%define tde_tdeincludedir %{tde_includedir}/kde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{kdecomp}
+Summary: iptables based firewall configuration tool for KDE [Trinity]
+Version: 1.1.1
+Release: 2%{?dist}%{?_variant}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{kdecomp}-3.5.13.tar.gz
+
+# [kmyfirewall] GCC 4.7 fixes. [Commit #88d2d2a7]
+Patch1: kmyfirewall-3.5.13-fix_gcc47_compilation.patch
+# [kmyfirefall] Missing LDFLAGS cause FTBFS
+Patch2: kmyfirewall-3.5.13-missing_ldflags.patch
+
+BuildRequires: tqtinterface-devel
+BuildRequires: trinity-tdelibs-devel
+BuildRequires: trinity-tdebase-devel
+BuildRequires: desktop-file-utils
+
+
+%description
+KMyFirewall attempts to make it easier to setup iptables based firewalls on
+Linux systems. It will be the right tool if you like to have a so called
+"Personal Firewall" running on your Linux box, but don't have the time and/or
+the interest to spend hours in front of the iptables manual just to setup a
+Firewall that keeps the "bad" people out.
+
+There is also the possibility to save entire rule sets, so you only have to
+configure your rule set one time and then you can use it on several computers
+giving each of them a similar configuration (p.e. school networks, office,
+university etc.)
+
+%package devel
+Summary: Development files for %{name}
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+%{summary}
+
+
+%prep
+%setup -q -n applications/%{kdecomp}
+%patch1 -p1
+%patch2 -p1
+
+# Ugly hack to modify TQT include directory inside autoconf files.
+# If TQT detection fails, it fallbacks to TQT4 instead of TQT3 !
+%__sed -i admin/acinclude.m4.in \
+ -e "s|/usr/include/tqt|%{tde_includedir}/tqt|g" \
+ -e "s|kde_htmldir='.*'|kde_htmldir='%{tde_tdedocdir}/HTML'|g"
+
+%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR; . /etc/profile.d/qt.sh
+export PATH="%{tde_bindir}:${PATH}"
+export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
+
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --libdir=%{tde_libdir} \
+ --mandir=%{tde_mandir} \
+ --includedir=%{tde_tdeincludedir} \
+ --disable-rpath \
+ --with-extra-includes=%{tde_includedir}/tqt \
+ --enable-closure
+
+%__make %{?_smp_mflags}
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+update-desktop-database %{tde_appdir} > /dev/null
+for f in hicolor Locolor; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig || :
+
+%postun
+update-desktop-database %{tde_appdir} > /dev/null
+for f in hicolor Locolor; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig || :
+
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING COPYING-DOCS README TODO
+%{tde_bindir}/kmyfirewall
+%{tde_libdir}/libkmfcore.so.*
+%{tde_libdir}/libkmfwidgets.so.*
+%{tde_tdelibdir}/libkmfcompiler_ipt.la
+%{tde_tdelibdir}/libkmfcompiler_ipt.so
+%{tde_tdelibdir}/libkmfgenericinterfacepart.la
+%{tde_tdelibdir}/libkmfgenericinterfacepart.so
+%{tde_tdelibdir}/libkmfinstaller_linux.la
+%{tde_tdelibdir}/libkmfinstaller_linux.so
+%{tde_tdelibdir}/libkmfinstallerplugin.la
+%{tde_tdelibdir}/libkmfinstallerplugin.so
+%{tde_tdelibdir}/libkmfipteditorpart.la
+%{tde_tdelibdir}/libkmfipteditorpart.so
+%{tde_tdelibdir}/libkmfruleoptionedit_custom.la
+%{tde_tdelibdir}/libkmfruleoptionedit_custom.so
+%{tde_tdelibdir}/libkmfruleoptionedit_interface.la
+%{tde_tdelibdir}/libkmfruleoptionedit_interface.so
+%{tde_tdelibdir}/libkmfruleoptionedit_ip.la
+%{tde_tdelibdir}/libkmfruleoptionedit_ip.so
+%{tde_tdelibdir}/libkmfruleoptionedit_limit.la
+%{tde_tdelibdir}/libkmfruleoptionedit_limit.so
+%{tde_tdelibdir}/libkmfruleoptionedit_mac.la
+%{tde_tdelibdir}/libkmfruleoptionedit_mac.so
+%{tde_tdelibdir}/libkmfruleoptionedit_protocol.la
+%{tde_tdelibdir}/libkmfruleoptionedit_protocol.so
+%{tde_tdelibdir}/libkmfruleoptionedit_state.la
+%{tde_tdelibdir}/libkmfruleoptionedit_state.so
+%{tde_tdelibdir}/libkmfruleoptionedit_tos.la
+%{tde_tdelibdir}/libkmfruleoptionedit_tos.so
+%{tde_tdelibdir}/libkmfruletargetoptionedit_log.la
+%{tde_tdelibdir}/libkmfruletargetoptionedit_log.so
+%{tde_tdelibdir}/libkmfruletargetoptionedit_mark.la
+%{tde_tdelibdir}/libkmfruletargetoptionedit_mark.so
+%{tde_tdelibdir}/libkmfruletargetoptionedit_nat.la
+%{tde_tdelibdir}/libkmfruletargetoptionedit_nat.so
+%{tde_tdelibdir}/libkmfruletargetoptionedit_tos.la
+%{tde_tdelibdir}/libkmfruletargetoptionedit_tos.so
+%{tde_tdeappdir}/kmyfirewall.desktop
+%{tde_datadir}/apps/kmfgenericinterfacepart/kmfgenericinterfacepartui.rc
+%{tde_datadir}/apps/kmfipteditorpart/kmfipteditorpartui.rc
+%{tde_datadir}/apps/kmfsystray
+%{tde_datadir}/apps/kmyfirewall
+%{tde_datadir}/config.kcfg/kmfconfig.kcfg
+%{tde_datadir}/config/kmyfirewallrc
+%{tde_tdedocdir}/HTML/en/kmyfirewall/
+%{tde_datadir}/icons/hicolor/*/apps/kmyfirewall.png
+%{tde_datadir}/icons/Locolor/*/apps/kmyfirewall.png
+%{tde_datadir}/mimelnk/application/kmfgrs.desktop
+%{tde_datadir}/mimelnk/application/kmfnet.desktop
+%{tde_datadir}/mimelnk/application/kmfpkg.desktop
+%{tde_datadir}/mimelnk/application/kmfrs.desktop
+%{tde_datadir}/services/kmf*.desktop
+%{tde_datadir}/servicetypes/kmf*.desktop
+
+%files devel
+%{tde_tdeincludedir}/kmyfirewall
+%{tde_libdir}/libkmfcore.la
+%{tde_libdir}/libkmfcore.so
+%{tde_libdir}/libkmfwidgets.la
+%{tde_libdir}/libkmfwidgets.so
+
+%Changelog
+* Wed May 02 2012 Francois Andriot <francois.andriot@free.fr> - 1.1.1-2
+- GCC 4.7 fixes. [Commit #88d2d2a7]
+
+* Sat Dec 03 2011 Francois Andriot <francois.andriot@free.fr> - 1.1.1-1
+- Initial build for RHEL 5, RHEL 6, Fedora 15, Fedora 16
+