summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tde-guidance/tde-guidance-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tde-guidance/tde-guidance-14.0.0.spec')
-rw-r--r--redhat/applications/tde-guidance/tde-guidance-14.0.0.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/redhat/applications/tde-guidance/tde-guidance-14.0.0.spec b/redhat/applications/tde-guidance/tde-guidance-14.0.0.spec
index 02b6c3b33..ebf6e0021 100644
--- a/redhat/applications/tde-guidance/tde-guidance-14.0.0.spec
+++ b/redhat/applications/tde-guidance/tde-guidance-14.0.0.spec
@@ -421,8 +421,13 @@ chmod 0755 %{buildroot}%{python_sitearch}/%{name}/gpmhelper.py
# Replace all '#!' calls to python with /usr/bin/python
# and make them executable
+%if 0%{?fedora} >= 30
+%define python /usr/bin/python2
+%else
+%define python /usr/bin/python
+%endif
for i in `find %{buildroot} -type f`; do
- sed '1s,#!.*python[^ ]*\(.*\),#! /usr/bin/python\1,' \
+ sed '1s,#!.*python[^ ]*\(.*\),#! %python\1,' \
$i > $i.temp;
if cmp --quiet $i $i.temp; then
rm -f $i.temp;