summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec')
-rw-r--r--redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec13
1 files changed, 5 insertions, 8 deletions
diff --git a/redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec b/redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec
index 51d3d6923..b2ba06252 100644
--- a/redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec
+++ b/redhat/applications/tde-style-qtcurve/tde-style-qtcurve-14.0.0.spec
@@ -76,13 +76,10 @@ gtk2-engines-qtcurve.
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-export CXXFLAGS="-I${QTINC} -I%{tde_tdeincludedir} ${CXXFLAGS}"
-
# Shitty hack for RHEL4 ...
if [ -d "/usr/X11R6" ]; then
export CMAKE_INCLUDE_PATH="${CMAKE_INCLUDE_PATH}:/usr/X11R6/include:/usr/X11R6/%{_lib}"
- export CFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
- export CXXFLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
+ export RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -I/usr/X11R6/include -L/usr/X11R6/%{_lib}"
fi
# Error in "po/tr.po"
@@ -90,10 +87,10 @@ fi
%__rm -f "po/tr.po"
%endif
-%if 0%{?rhel} || 0%{?fedora} || 0%{?suse_version}
-%__mkdir_p build
-cd build
-%endif
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
%cmake \
-DCMAKE_BUILD_TYPE="RelWithDebInfo" \