summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/sip4-tqt/sip4-tqt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/sip4-tqt/sip4-tqt.spec')
-rw-r--r--redhat/dependencies/sip4-tqt/sip4-tqt.spec32
1 files changed, 17 insertions, 15 deletions
diff --git a/redhat/dependencies/sip4-tqt/sip4-tqt.spec b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
index a2bf18df4..0c60df09d 100644
--- a/redhat/dependencies/sip4-tqt/sip4-tqt.spec
+++ b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
@@ -77,19 +77,10 @@ BuildRequires: bison
BuildRequires: flex
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
-%global python python2
-%global __python %__python2
-%global python_sitearch %{python2_sitearch}
-%else
-%if 0%{?sle_version} >= 150400
%global python python3
%global __python %__python3
-%else
-%global python python
-%endif
-%endif
-%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%global python_sitearch %{python3_sitearch}
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
BuildRequires: %{python}
BuildRequires: %{python}-devel
@@ -119,7 +110,18 @@ specificity towards C++ and Python.
%files -n sip4-tqt
%defattr(-,root,root,-)
-%{python_sitearch}/sip4_tqt/
+%{python_sitearch}/sip_tqt.so
+%if 0%{?rhel} == 7 || 0%{?suse_version}
+%{python_sitearch}/sip_tqt_config.py*
+%{python_sitearch}/sip_tqt_distutils.py*
+%if 0%{?rhel} == 7
+%{python_sitearch}/__pycache__/sip_tqt_config.*.pyc
+%{python_sitearch}/__pycache__/sip_tqt_distutils.*.pyc
+%endif
+%else
+%pycached %{python_sitearch}/sip_tqt_config.py
+%pycached %{python_sitearch}/sip_tqt_distutils.py
+%endif
##########
@@ -153,8 +155,8 @@ needed to develop Python bindings with sip.
%files -n sip4-tqt-devel
%defattr(-,root,root,-)
-%{tde_bindir}/sip
-%{tde_includedir}/sip.h
+%{tde_bindir}/sip-tqt
+%{tde_includedir}/sip-tqt.h
##########
@@ -176,7 +178,7 @@ mkdir build
cd build
%__python ../configure.py \
-b %{tde_bindir} \
- -d %{python_sitearch}/sip4_tqt \
+ -d %{python_sitearch} \
-e %{tde_includedir} \
-u STRIP="" \
CFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/tqt -I%{_includedir}/tqt3 -I${PWD}/../sipgen -DYYERROR_VERBOSE" \