summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec')
-rw-r--r--redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec8
1 files changed, 3 insertions, 5 deletions
diff --git a/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec b/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
index e6d2a7d20..a0a3c5978 100644
--- a/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
+++ b/redhat/dependencies/tqscintilla/tqscintilla-14.0.0.spec
@@ -193,29 +193,27 @@ export QTDIR=%{_libdir}/tqt3
# Installs supplementary headers
for i in include/*.h; do
- %__install -D -m 644 $i %{buildroot}${QTINC}/private/${i##*/}
+ %__install -D -m 644 $i %{buildroot}${QTINC}/private/${i##*/}
done
# Installs the HTML documentation correctly
for i in doc/html/*; do
- %__install -D -m 644 $i %{buildroot}%{tde_tdedocdir}/HTML/en/%{name}/${i##*/}
+ %__install -D -m 644 $i %{buildroot}%{tde_tdedocdir}/HTML/en/%{name}/${i##*/}
done
# Installs the Designer plugin
for i in designer/*.so; do
- %__install -D -m 644 $i %{buildroot}${QTDIR}/plugins/designer/${i##*/}
+ %__install -D -m 644 $i %{buildroot}${QTDIR}/plugins/designer/${i##*/} || %__install -D -m 644 ${QTDIR}/plugins/$i %{buildroot}${QTDIR}/plugins/designer/${i##*/}
done
# Installs libraries
%__mkdir_p %{buildroot}%{_libdir}
%__mv -f tmplib/* %{buildroot}%{_libdir}
-
# Fix private headers location
%__mv -f %{buildroot}/private %{buildroot}%{_includedir}/tqt3
%__mv -f %{buildroot}%{_includedir}/tqt3 %{buildroot}%{_includedir}/tqscintilla
-
# Fix permissions
chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h
chmod a-x %{buildroot}%{_includedir}/tqscintilla/*.h