summaryrefslogtreecommitdiffstats
path: root/redhat/extras/kpacman/kpacman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/extras/kpacman/kpacman.spec')
-rw-r--r--redhat/extras/kpacman/kpacman.spec158
1 files changed, 158 insertions, 0 deletions
diff --git a/redhat/extras/kpacman/kpacman.spec b/redhat/extras/kpacman/kpacman.spec
new file mode 100644
index 000000000..f52e1c076
--- /dev/null
+++ b/redhat/extras/kpacman/kpacman.spec
@@ -0,0 +1,158 @@
+#
+# spec file for package kpacman (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# Default version for this component
+%define tde_pkg kpacman
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.7
+%endif
+
+# TDE specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{tde_pkg}
+Summary: A pacman game for the Trinity Desktop.
+Version: 0.3.2
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{tde_pkg}-%{tde_version}.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
+BuildRequires: trinity-arts-devel >= 1:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: trinity-libtdegames-devel >= %{tde_version}
+
+BuildRequires: gettext
+
+
+%description
+Pacman is a legendary game with an enthusiastic following from around
+the world. Since its introduction in 1980, Pacman's image has been
+splashed across magazine covers, television screens, T-shirts, and
+bumper stickers. Created by Japan's Namco, and distributed in the
+United States by Bally, Pacman is an icon of 1980's popular culture
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+
+%prep
+%setup -q -n %{tde_pkg}-%{version}
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export kde_confdir="%{tde_confdir}"
+
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --docdir=%{tde_tdedocdir} \
+ --includedir=%{tde_tdeincludedir} \
+ --libdir=%{tde_libdir} \
+ --mandir=%{tde_mandir} \
+ \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-new-ldflags \
+ --enable-final \
+ --enable-closure \
+ --enable-rpath \
+ --disable-gcc-hidden-visibility
+
+%__make %{?_smp_mflags} || %__make
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+%find_lang %{tde_pkg}
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+for f in hicolor locolor ; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig
+
+
+%postun
+for f in hicolor locolor ; do
+ touch --no-create %{tde_datadir}/icons/${f} || :
+ gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
+done
+/sbin/ldconfig
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING README TODO
+%{tde_bindir}/kpacman
+%{tde_datadir}/applnk/Games/kpacman.desktop
+%{tde_datadir}/apps/kpacman/
+%{tde_confdir}/kpacmanrc
+%lang(de) %{tde_tdedocdir}/HTML/de/kpacman/
+%{tde_tdedocdir}/HTML/en/kpacman/
+%{tde_datadir}/icons/hicolor/16x16/apps/kpacman.png
+%{tde_datadir}/icons/hicolor/32x32/apps/kpacman.png
+%{tde_datadir}/icons/locolor/16x16/apps/kpacman.png
+%{tde_datadir}/icons/locolor/32x32/apps/kpacman.png
+
+
+%changelog