summaryrefslogtreecommitdiffstats
path: root/redhat/libraries/pytde/pytde.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/libraries/pytde/pytde.spec')
-rw-r--r--redhat/libraries/pytde/pytde.spec19
1 files changed, 16 insertions, 3 deletions
diff --git a/redhat/libraries/pytde/pytde.spec b/redhat/libraries/pytde/pytde.spec
index 2e38227e1..cfe105cbb 100644
--- a/redhat/libraries/pytde/pytde.spec
+++ b/redhat/libraries/pytde/pytde.spec
@@ -64,6 +64,8 @@ BuildRequires: gcc-c++
# PYTHON support
%global python python3
+%global __python %__python3
+%global python_sitearch %{python3_sitearch}
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
BuildRequires: %{python}
BuildRequires: %{python}-devel
@@ -89,9 +91,20 @@ from tdeio, tdejs, tdehtml and tdeprint.
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README
%{python_sitearch}/*.so
-%{python_sitearch}/dcop*.py*
-%{python_sitearch}/pytde*.py*
-%{python_sitearch}/__pycache__/*.pyc
+%if 0%{?rhel} == 7 || 0%{?suse_version}
+%{python_sitearch}/dcopexport.py*
+%{python_sitearch}/dcopext.py*
+%{python_sitearch}/pytdeconfig.py*
+%if 0%{?rhel} == 7
+%{python_sitearch}/__pycache__/dcopexport.*.pyc
+%{python_sitearch}/__pycache__/dcopext.*.pyc
+%{python_sitearch}/__pycache__/pytdeconfig.*.pyc
+%endif
+%else
+%pycached %{python_sitearch}/dcopexport.py
+%pycached %{python_sitearch}/dcopext.py
+%pycached %{python_sitearch}/pytdeconfig.py
+%endif
##########