summaryrefslogtreecommitdiffstats
path: root/redhat/libraries/pytdeextensions/pytdeextensions.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/libraries/pytdeextensions/pytdeextensions.spec')
-rw-r--r--redhat/libraries/pytdeextensions/pytdeextensions.spec30
1 files changed, 9 insertions, 21 deletions
diff --git a/redhat/libraries/pytdeextensions/pytdeextensions.spec b/redhat/libraries/pytdeextensions/pytdeextensions.spec
index 000f79b48..edab0594a 100644
--- a/redhat/libraries/pytdeextensions/pytdeextensions.spec
+++ b/redhat/libraries/pytdeextensions/pytdeextensions.spec
@@ -62,11 +62,11 @@ BuildRequires: gettext
BuildRequires: autoconf automake libtool m4
BuildRequires: gcc-c++
-BuildRequires: python-tqt-devel >= %{?epoch:%{epoch}:}3.18.1
-BuildRequires: trinity-python-trinity-devel
+BuildRequires: pytqt-devel >= %{?epoch:%{epoch}:}3.18.1
+BuildRequires: trinity-pytde-devel
BuildRequires: trinity-pytqt-tools
-Requires: python-tqt
-Requires: trinity-python-trinity
+Requires: pytqt
+Requires: trinity-pytde
Requires: trinity-libpythonize0 = %{?epoch:%{epoch}:}%{version}-%{release}
@@ -75,14 +75,10 @@ BuildRequires: sip4-tqt-devel >= 4.10.5
Requires: sip4-tqt >= 4.10.5
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
-%global python python2
-%global __python %__python2
-%global python_sitearch %{python2_sitearch}
-%else
-%global python python
-%endif
-%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%global python python3
+%global __python %__python3
+%global python_sitearch %{python3_sitearch}
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
BuildRequires: %{python}
BuildRequires: %{python}-devel
@@ -182,14 +178,6 @@ for f in src/*.py; do
-e "s|/usr/lib/pyshared/python\*|%{python_sitearch}|g"
done
-# Do not look for 'libpython2.x.so' (from -devel) package.
-# Instead look for versioned runtime library.
-LIBPYTHON="$(readlink %{_libdir}/libpython2.*.so)"
-if [ -f "%{_libdir}/${LIBPYTHON}" ]; then
- %__sed -i "src/tdedistutils.py" \
- -e "s|#define LIB_PYTHON \".*\"|#define LIB_PYTHON \"%{_libdir}/${LIBPYTHON}\"|"
-fi
-
# Fix FTBFS on RHEL 5
%if 0%{?rhel} == 5
%__sed -i "src/pythonize."* -e "s|const char \*object|char \*object|g"
@@ -204,7 +192,7 @@ fi
"app_templates/kdeutility/src/kdeutility.py" \
"app_templates/tdeioslave/setup.py" \
"app_templates/tdeioslave/src/tdeioslave.py" \
- -e "s|/usr/bin/python|/usr/bin/env python2|"
+ -e "s|/usr/bin/python|/usr/bin/env %{python}|"
%endif