summaryrefslogtreecommitdiffstats
path: root/redhat/tdebindings/tdebindings-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/tdebindings/tdebindings-14.0.0.spec')
-rw-r--r--redhat/tdebindings/tdebindings-14.0.0.spec110
1 files changed, 71 insertions, 39 deletions
diff --git a/redhat/tdebindings/tdebindings-14.0.0.spec b/redhat/tdebindings/tdebindings-14.0.0.spec
index 2d98f8874..9fc775f48 100644
--- a/redhat/tdebindings/tdebindings-14.0.0.spec
+++ b/redhat/tdebindings/tdebindings-14.0.0.spec
@@ -1,68 +1,94 @@
-# Special note for RHEL4:
-# You must create symlink 'libgcj.so' manually because it does not exist by default.
-# E.g:
-# ln -s /usr/lib/libgcj.so.5.0.0 /usr/lib/jvm/java/lib/libgcj.so
-# or 64 bits:
-# ln -s /usr/lib64/libgcj.so.5.0.0 /usr/lib/jvm/java/lib/libgcj.so
-
+#
+# spec file for package tdebindings (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg tdebindings
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-# RHEL4 specific
-Source91: filter-requires.sh
-%if 0%{?rhel} == 4
-%define _use_internal_dependency_generator 0
-%define __find_requires sh %{SOURCE91}
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
%endif
-Name: trinity-tdebindings
+# Special note for RHEL4:
+# You must create symlink 'libgcj.so' manually because it does not exist by default.
+# E.g:
+# ln -s /usr/lib/libgcj.so.5.0.0 /usr/lib/jvm/java/lib/libgcj.so
+# or 64 bits:
+# ln -s /usr/lib64/libgcj.so.5.0.0 /usr/lib/jvm/java/lib/libgcj.so
+
+Name: trinity-%{tde_pkg}
Summary: TDE bindings to non-C++ languages
Version: %{tde_version}
Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2
Group: User Interface/Desktops
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.trinitydesktop.org/
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
-Patch1: tdebindings-14.0.0-ftbfs.patch
+BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: desktop-file-utils
-# [tdebindings] Function 'rb_frame_this_func' does not exist in RHEL5
-Patch5: kdebindings-3.5.13.1-fix_rhel5_ftbfs.patch
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
-BuildRequires: autoconf automake libtool m4
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
-BuildRequires: desktop-file-utils
+# ZLIB support
BuildRequires: zlib-devel
+
+# PERL module support
BuildRequires: perl(ExtUtils::MakeMaker)
# GTK2 support
@@ -980,7 +1006,7 @@ Development files for the TDE bindings.
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -988,14 +1014,14 @@ Development files for the TDE bindings.
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
-%patch1 -p1 -b .ftbfs
%if "%{?perl_vendorarch}" == ""
exit 1
%endif
+# [tdebindings] Function 'rb_frame_this_func' does not exist in RHEL4/5
%if 0%{?rhel} >= 4 && 0%{?rhel} <= 5
-%patch5 -p1 -b .ruby
+%__sed -i "qtruby/rubylib/qtruby/Qt.cpp" -e "s|rb_frame_this_func|rb_frame_last_func|g"
%endif
# Disable kmozilla, it does not build with recent xulrunner (missing 'libmozjs.so')
@@ -1117,6 +1143,12 @@ if [ -d "%{buildroot}%{_mandir}/man3" ]; then
rm -rf %{buildroot}%{_mandir}
fi
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -u kjscmd Development
+%suse_update_desktop_file -u embedjs Development
+%endif
+
%clean
%__rm -rf $RPM_BUILD_ROOT