summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/codeine/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/codeine/debian')
-rw-r--r--ubuntu/_base/applications/codeine/debian/cdbs/debian-tde.mk227
-rw-r--r--ubuntu/_base/applications/codeine/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/codeine/debian/changelog94
-rw-r--r--ubuntu/_base/applications/codeine/debian/codeine-trinity.menu7
-rw-r--r--ubuntu/_base/applications/codeine/debian/compat1
-rw-r--r--ubuntu/_base/applications/codeine/debian/control18
-rw-r--r--ubuntu/_base/applications/codeine/debian/copyright40
-rw-r--r--ubuntu/_base/applications/codeine/debian/patches/series1
-rwxr-xr-xubuntu/_base/applications/codeine/debian/rules19
-rw-r--r--ubuntu/_base/applications/codeine/debian/source/format1
-rw-r--r--ubuntu/_base/applications/codeine/debian/source/options6
11 files changed, 0 insertions, 433 deletions
diff --git a/ubuntu/_base/applications/codeine/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/codeine/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 24191b2cd..000000000
--- a/ubuntu/_base/applications/codeine/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,227 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/_base/applications/codeine/debian/cdbs/versions.pl b/ubuntu/_base/applications/codeine/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/_base/applications/codeine/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/codeine/debian/changelog b/ubuntu/_base/applications/codeine/debian/changelog
deleted file mode 100644
index b3816312d..000000000
--- a/ubuntu/_base/applications/codeine/debian/changelog
+++ /dev/null
@@ -1,94 +0,0 @@
-codeine-trinity (1.0.1-3.dfsg-3.1) testing; urgency=low
-
- * Initial release for TDE
-
- -- Michele Calgaro <michele.calgaro@yahoo.it> Tue, 24 Jun 2020 16:03:12 +0900
-
-codeine (1.0.1-3.dfsg-3.1) unstable; urgency=low
-
- * Non-maintainer upload.
- * Fix FTBFS with GCC 4.4, patch by Martin Michlmayr (Closes: #505078)
- * Fixed typo in debian/README.Debian
-
- -- David Paleino <dapal@debian.org> Sun, 20 Dec 2009 12:38:59 +0100
-
-codeine (1.0.1-3.dfsg-3) unstable; urgency=low
-
- [ Ana Beatriz Guerrero Lopez ]
-
- * Apply patch from Cyril Brulebois to fix FTBFS with GCC 4.3.
- (Closes: #461666)
- * Add dependency on libxine1-x. (Closes: #448088)
- * Move Homepage into control field.
- * Update to Standards-Version: 3.7.3, no changes required.
-
- [ Mark Purcell ]
-
- * cleanbuilddir common-configure-arch::
- * Add debian/watch
- * debian/rules clean: [ ! -f Makefile ]|| rule
-
- -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sun, 23 Mar 2008 14:07:22 +0100
-
-codeine (1.0.1-3.dfsg-2) unstable; urgency=medium
-
- [ Achim Bohnet ]
-
- * debian/rules: redefine $HOME to a writable (tmp)dir: KDE apps called
- in configure script try to create $HOME/.kde. This fails on some
- autobuild daemons. (Redefining KDEHOME instead of HOME did not work.)
- Closes: #403131: codeine_1.0.1-3.dfsg-1(alpha/unstable): FTBFS with -rsudo
-
- * Set urgency to medium, 'cause RC bug fixed
-
- * Bump StandardsVersion to 3.6.2 -> 3.7.2. No changes necessary
-
- * Add Translation to codeine's desktop file (from kdesvn)
-
- -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sat, 16 Dec 2006 19:15:13 +0100
-
-codeine (1.0.1-3.dfsg-1) unstable; urgency=low
-
- [ Mark Purcell ]
- * Initial release. (Closes: #372113: ITP: codeine -- Simple,
- uncluttered KDE video player - Debian Bug report logs)
- * .dfsg version removes redundant/ FDL doc/ dir
-
- -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sun, 25 Jun 2006 21:46:06 +0100
-
-codeine (1.0.1-3-1) unstable; urgency=low
-
- * New upstream release (Closes: Bug#372113)
-
- [ Achim Bohnet ]
- * fix typos in codeine manpage
- * renamed patches/kubuntu_01_add_translations_to_desktop_file.diff
- to patches/01_add_translations_to_desktop_file.diff. Patch is not
- kubuntu specific
-
- [ Tom Albers ]
- * New upstream release
- * Removed rule for codeine_part.desktop, upstream fixed that
- * Added --play-dvd to man page
- * Added me as debian maintainer for this package
-
- -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Thu, 8 Jun 2006 11:31:26 +0100
-
-codeine (1.0-0ubuntu1) dapper; urgency=low
-
- [ Achim Bohnet ]
-
- * Initial Release.
-
- * patches/kubuntu_01_add_translations_to_desktop_file.diff:
- Replace GenericName "Vidio Player" with "Media Player" as used for
- kaffeine and kmplayer. Add dozends "Media Player" translations
- from kaffeine.desktop to codeine.desktop. Replaces
- patches/kubuntu_01_fix_desktop_file.patch
-
- * rules: codeine_part.desktop is of Type=Service so install it in
- /usr/share/services/ not /usr/share/applications/kde/
-
- * Add codeine.1 manpage
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 17 Jan 2006 23:26:41 +0100
diff --git a/ubuntu/_base/applications/codeine/debian/codeine-trinity.menu b/ubuntu/_base/applications/codeine/debian/codeine-trinity.menu
deleted file mode 100644
index d30aa8074..000000000
--- a/ubuntu/_base/applications/codeine/debian/codeine-trinity.menu
+++ /dev/null
@@ -1,7 +0,0 @@
-?package(codeine-trinity):\
- needs="X11"\
- section="Applications/Video"\
- title="Codeine"\
- command="/opt/trinity/bin/codeine"\
- hints="TDE"
-
diff --git a/ubuntu/_base/applications/codeine/debian/compat b/ubuntu/_base/applications/codeine/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/ubuntu/_base/applications/codeine/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/ubuntu/_base/applications/codeine/debian/control b/ubuntu/_base/applications/codeine/debian/control
deleted file mode 100644
index d1b226457..000000000
--- a/ubuntu/_base/applications/codeine/debian/control
+++ /dev/null
@@ -1,18 +0,0 @@
-Source: codeine-trinity
-Section: tde
-Priority: optional
-Maintainer: TDE team
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake, intltool, tdelibs-trinity-dev, libxine2-dev | libxine-dev, libxtst-dev
-Standards-Version: 3.7.3
-Homepage: http://codeine.sourceforge.net/
-
-Package: codeine-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: Simple TDE video player
- A video player with a different philosophy: simple, uncluttered interface
- .
- Features:
- - Plays DVDs, VCDs, all video formats supported by Xine
- - Bundled with a simple web-page KPart
- - Starts quickly
diff --git a/ubuntu/_base/applications/codeine/debian/copyright b/ubuntu/_base/applications/codeine/debian/copyright
deleted file mode 100644
index c5c11bb09..000000000
--- a/ubuntu/_base/applications/codeine/debian/copyright
+++ /dev/null
@@ -1,40 +0,0 @@
-This package was debianized by Anthony Mercatante
-<anthony.mercatante@laposte.net> on Mon, 24 oct 2005 17:39:28 +0200.
-2006 reworked by Achim Bohnet <ach@mpe.mpg.de>
-
- * .dfsg version removes redundant/ FDL doc/ dir
-
-It was downloaded from: http://www.methylblue.com/codeine/
-
-Upstream Author:
- Max Howell <max.howell@methylblue.com>
-
-License:
-
-All the software and debian/codeine.1.docbook are under the GPL:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- On Debian GNU/Linux systems, the complete text of the GNU General
- Public License can be found in `/usr/share/common-licenses/GPL'.
-
-Copyright
-
-codeine:
-
- (C) 2005-2006 Max Howell <max.howell@methylblue.com>
-
-debian/codeine.1.docbook:
-
- Copyright (C) 2005 by Anthony Mercatante <anthony.mercatante@laposte.net>
- Copyright (C) 2006 by Achim Bohnet <ach@mpe.mpg.de>
- Copyright (C) 2006 by Tom Albers <tomalbers@kde.nl>
-
diff --git a/ubuntu/_base/applications/codeine/debian/patches/series b/ubuntu/_base/applications/codeine/debian/patches/series
deleted file mode 100644
index 8b1378917..000000000
--- a/ubuntu/_base/applications/codeine/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/ubuntu/_base/applications/codeine/debian/rules b/ubuntu/_base/applications/codeine/debian/rules
deleted file mode 100755
index 18aa16b96..000000000
--- a/ubuntu/_base/applications/codeine/debian/rules
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/codeine/debian/source/format b/ubuntu/_base/applications/codeine/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/_base/applications/codeine/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/_base/applications/codeine/debian/source/options b/ubuntu/_base/applications/codeine/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/_base/applications/codeine/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*