summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kdirstat/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/kdirstat/debian')
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/changelog118
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/compat1
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/control22
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/copyright19
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/docs4
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/patches/series0
-rwxr-xr-xubuntu/_base/applications/kdirstat/debian/rules20
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/source/format1
-rw-r--r--ubuntu/_base/applications/kdirstat/debian/source/options6
12 files changed, 420 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kdirstat/debian/cdbs/debian-qt-kde.mk b/ubuntu/_base/applications/kdirstat/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/_base/applications/kdirstat/debian/cdbs/kde.mk b/ubuntu/_base/applications/kdirstat/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/_base/applications/kdirstat/debian/cdbs/versions.pl b/ubuntu/_base/applications/kdirstat/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/kdirstat/debian/changelog b/ubuntu/_base/applications/kdirstat/debian/changelog
new file mode 100644
index 000000000..bf0c6d43b
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/changelog
@@ -0,0 +1,118 @@
+kdirstat-trinity (2.4.4-1ubuntu0) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+kdirstat-trinity (2.4.4-0ubuntu3) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
+
+kdirstat-trinity (2.4.4-0ubuntu2) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 27 Dec 2008 12:49:00 -0600
+
+kdirstat (2.4.4-4) unstable; urgency=low
+
+ * Updated standards version
+ * Added Homepage control field
+ * Removed build dependency on libqt3-compat-headers (patch by Barry
+ deFreese) (closes: #464475)
+
+ -- Peter Eisentraut <petere@debian.org> Thu, 07 Feb 2008 12:34:42 +0100
+
+kdirstat (2.4.4-3) unstable; urgency=low
+
+ * New maintainer (closes: #392205)
+ * Switched to CDBS
+ * Packaging cleanup
+ * Updated standards version
+ * Updated watch file
+ * Changed to Debhelper level 5
+ * Fixed spelling mistake in package description (closes: #364141)
+ * Removed xutils build dependency
+ * Built new man page using kdemangen.pl
+ * Added linker option --as-needed
+
+ -- Peter Eisentraut <petere@debian.org> Thu, 26 Oct 2006 19:59:33 +0200
+
+kdirstat (2.4.4-2) unstable; urgency=low
+
+ * Rebuilt for gcc-4.0 transition. (closes: #328012)
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sat, 3 Sep 2005 15:16:39 -0600
+
+kdirstat (2.4.4-1) unstable; urgency=low
+
+ * New upstream release (closes: #285278)
+ * Upstream configure kde details reorganized. Previous mucking about with
+ docdir and such no longer necessary and extra configure flags that
+ implemented them are removed.
+ * Changed to debhelper 4 [Peter Eisentraut]
+ * Corrected use of configure --build and --host options [Peter Eisentraut]
+ * Do not compress .docbook files (closes: #303809) [Peter Eisentraut]
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Fri, 15 Apr 2005 06:59:26 -0600
+
+kdirstat (2.4.0-2) unstable; urgency=low
+
+ * Patched to fix broken gcc-3.4 build. (closes: #262136)
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sun, 21 Nov 2004 05:57:22 -0700
+
+kdirstat (2.4.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Wed, 1 Oct 2003 12:09:52 -0500
+
+kdirstat (2.3.7-1) unstable; urgency=low
+
+ * New upstream release (closes: #200993, #200995)
+ * Upstream configure fixes /lib64 problem so previous fix discarded.
+ * debian/rules#clean: rm -f po/fr.gmo leftover from make distclean
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sat, 12 Jul 2003 12:47:34 -0500
+
+kdirstat (2.3.6-2) unstable; urgency=low
+
+ * debian/control: Include xutils in Build-Depends to fix broken configure on
+ sparc/s390/arm (closes: #189106)
+ * configure: test for /lib64 disabled to fix broken configure on s390
+ (closes: #190007)
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Tue, 29 Apr 2003 15:03:04 -0500
+
+kdirstat (2.3.6-1) unstable; urgency=low
+
+ * New upstream release (closes: #187039)
+ * debian/rules#clean: rm -f po/ja.gmo leftover from make distclean
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sun, 13 Apr 2003 13:34:47 -0500
+
+kdirstat (2.2.0-1) unstable; urgency=low
+
+ * New upstream release
+ * debian/control: Change Build-Depend for qt3.
+ * debian/rules: --with-qt-includes=... in configure.
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sun, 2 Mar 2003 14:55:48 -0600
+
+kdirstat (2.0.1-1) unstable; urgency=low
+
+ * Initial Release (closes: #162015)
+ * Changed LN_S args at doc/en/Makefile.in:384 to make symbolic link
+ relative.
+ * Added --disable-rpath to configure in rules.
+ * Added check for noopt in DEBIAN_BUILD_OPTIONS in rules.
+ * Changed doc/en/Makefile.in:95 to set kde_htmldir to
+ /share/doc/tde/HTML explicity. configure seems to pick up
+ /share/doc/tde/HTML instead.
+
+ -- Mike Schacht <mschacht@alumni.washington.edu> Sat, 16 Nov 2002 17:56:14 -0600
+
diff --git a/ubuntu/_base/applications/kdirstat/debian/compat b/ubuntu/_base/applications/kdirstat/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/ubuntu/_base/applications/kdirstat/debian/control b/ubuntu/_base/applications/kdirstat/debian/control
new file mode 100644
index 000000000..ee2e0ef40
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/control
@@ -0,0 +1,22 @@
+Source: kdirstat-trinity
+Section: misc
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: cdbs (>= 0.4.41), debhelper (>= 7.0.50~), quilt, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+Homepage: http://kdirstat.sourceforge.net/
+
+Package: kdirstat-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: kdirstat-kde3 (<< 4:14.0.0~), kdirstat-trinity (<< 4:14.0.0~)
+Breaks: kdirstat-kde3 (<< 4:14.0.0~), kdirstat-trinity (<< 4:14.0.0~)
+Description: graphical disk usage display with cleanup facilities [Trinity]
+ KDirStat (TDE Directory Statistics) is a small utility program that sums
+ up disk usage for directory trees, very much like the Unix 'du' command.
+ It displays the disk space used up by a directory tree, both numerically
+ and graphically. It is network transparent (i.e., you can use it to sum
+ up FTP servers), and comes with predefined and user configurable cleanup
+ actions. You can directly open a directory branch in Konqueror or the
+ shell of your choice, compress it to a .tar.bz2 archive, or define your
+ own cleanup actions.
diff --git a/ubuntu/_base/applications/kdirstat/debian/copyright b/ubuntu/_base/applications/kdirstat/debian/copyright
new file mode 100644
index 000000000..5230f7951
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/copyright
@@ -0,0 +1,19 @@
+This package was debianized by Mike Schacht <mschacht@alumni.washington.edu> on
+Fri, 20 Sep 2002 06:11:53 -0500.
+
+It was downloaded from <http://kdirstat.sourceforge.net/download>.
+
+Upstream authors:
+
+ Stefan Hundhammer <sh@suse.de>
+ Alexander Rawass <alexannika@users.sourceforge.net>
+
+Copyright:
+
+ This software is copyright (c) by Stefan Hundhammer and Alexander Rawass.
+
+ You are free to distribute this software under the terms of the GNU
+ General Public License.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in the file /usr/share/common-licenses/GPL.
diff --git a/ubuntu/_base/applications/kdirstat/debian/docs b/ubuntu/_base/applications/kdirstat/debian/docs
new file mode 100644
index 000000000..7f03542b1
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/docs
@@ -0,0 +1,4 @@
+AUTHORS
+CREDITS
+README
+TODO
diff --git a/ubuntu/_base/applications/kdirstat/debian/patches/series b/ubuntu/_base/applications/kdirstat/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/patches/series
diff --git a/ubuntu/_base/applications/kdirstat/debian/rules b/ubuntu/_base/applications/kdirstat/debian/rules
new file mode 100755
index 000000000..18b1c07e2
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/kdirstat/debian/source/format b/ubuntu/_base/applications/kdirstat/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/ubuntu/_base/applications/kdirstat/debian/source/options b/ubuntu/_base/applications/kdirstat/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/_base/applications/kdirstat/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*