summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/rosegarden/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/rosegarden/debian/rules')
-rwxr-xr-xubuntu/_base/applications/rosegarden/debian/rules40
1 files changed, 0 insertions, 40 deletions
diff --git a/ubuntu/_base/applications/rosegarden/debian/rules b/ubuntu/_base/applications/rosegarden/debian/rules
deleted file mode 100755
index 6e3b7df21..000000000
--- a/ubuntu/_base/applications/rosegarden/debian/rules
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DLIB_SUFFIX="" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DBUILD_ALL="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
-
-DEB_COMPRESS_EXCLUDE += .rg .wav .docbook
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-binary-install/rosegarden-trinity::
- dh_testdir
- find debian/rosegarden-trinity/usr/share/doc/rosegarden-trinity/examples -type f -exec chmod 664 {} \;
- cp -Rp debian/rosegarden-trinity/usr/share/man/* debian/rosegarden-trinity/opt/trinity/share/man/
- rm -rf debian/rosegarden-trinity/usr/share/man
-
-clean::
- dh_testdir