summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tdeio-apt/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/tdeio-apt/debian')
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/changelog297
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/compat1
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/control23
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/copyright30
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/docs3
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/patches/series0
-rwxr-xr-xubuntu/_base/applications/tdeio-apt/debian/rules20
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/source/format1
-rw-r--r--ubuntu/_base/applications/tdeio-apt/debian/source/options6
12 files changed, 610 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/cdbs/debian-qt-kde.mk b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/cdbs/kde.mk b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/cdbs/versions.pl b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/changelog b/ubuntu/_base/applications/tdeio-apt/debian/changelog
new file mode 100644
index 000000000..7be1e282b
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/changelog
@@ -0,0 +1,297 @@
+tdeio-apt-trinity (0.13.2-5ubuntu0) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+tdeio-apt-trinity (0.13.2-4ubuntu5) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
+
+tdeio-apt-trinity (0.13.2-4ubuntu4) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 Dec 2008 18:03:00 -0600
+
+kio-apt (0.13.2-2ubuntu7) hardy; urgency=low
+
+ * Make sure debian/patches/01_kubuntufication.dpatch is actually
+ applied (LP: #190567)
+
+ -- Terence Simpson <tsimpson@ubuntu.com> Sun, 10 Feb 2008 03:46:10 +0000
+
+kio-apt (0.13.2-2ubuntu6) hardy; urgency=low
+
+ * Reuploaded as the buildd seems to be fixed
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 12 Nov 2007 14:12:22 +0100
+
+kio-apt (0.13.2-2ubuntu5) hardy; urgency=low
+
+ * Added kubuntu_02_adept_integration.patch:
+ - Makes it possible to install and remove packages
+ while browsing the ioslave
+ - Supports apt:// protocol for one-click-installation
+ - No apt+http:// support yet
+ - Buildprep applied since the patch fixes Makefiles.am files
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 10 Nov 2007 11:19:17 +0100
+
+kio-apt (0.13.2-2ubuntu4) hardy; urgency=low
+
+ * Applied buildprep to fix Makefiles according to previously
+ applied patches
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 01 Nov 2007 19:36:41 +0100
+
+kio-apt (0.13.2-2ubuntu3) hardy; urgency=low
+
+ * Override previous upload, shouldn't have reach the
+ repos
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 22 Oct 2007 10:49:53 +0200
+
+kio-apt (0.13.2-2ubuntu2) gutsy; urgency=low
+
+ * Change header-background-color to white.
+
+ -- Frode M. Døving <frode@ubuntu.com> Fri, 03 Aug 2007 15:22:23 +0200
+
+kio-apt (0.13.2-2ubuntu1) gutsy; urgency=low
+
+ * Merge from Debian unstable.
+ * Remaining Ubuntu changes:
+ - Debian branding, and using Ubuntu releases and URLs.
+ - Add the dpatch CDBS include, and Build-Depend on dpatch.
+ - Store Debian icon uuencoded in debian/, and Build-Depend on sharutils
+ so it can be uudecoded during post-install.
+ - Set Ubuntu maintainer address.
+
+ -- Steve Kowalik <stevenk@ubuntu.com> Sun, 24 Jun 2007 21:40:26 +1000
+
+kio-apt (0.13.2-2) unstable; urgency=low
+
+ * Fix wrong locale dir: usr/share/locale/pl-utf/ (Closes: #429749)
+
+ -- Emmanuel Bouthenot <kolter@openics.org> Wed, 20 Jun 2007 00:06:01 +0200
+
+kio-apt (0.13.2-1ubuntu1) gutsy; urgency=low
+
+ * Manually merge from Debian unstable.
+ * Ubuntu changes kept:
+ - Debian branding, and using Ubuntu releases and URLs.
+ + Add Gutsy to the list of releases.
+ - Set Ubuntu maintainer address.
+ * Ubuntu changes dropped:
+ - Add kubuntu_01_kdepot.diff
+ - Alter debian/rules to create .pot file
+ * Add the dpatch CDBS include, and Build-Depend on dpatch.
+ * Don't patch a uuencoded icon in the Debian branding patch, it makes
+ baby Jesus and me cry. Instead, store it uuencoded in debian/, and
+ uudecode it in the post-install hook. Add a Build-Depends on sharutils
+ as a result.
+
+ -- Steve Kowalik <stevenk@ubuntu.com> Mon, 28 May 2007 20:29:54 +1000
+
+kio-apt (0.13.2-1) unstable; urgency=low
+
+ * Setting me as maintainer in debian/control
+ * Remove workaround in debian/rules against .gmo files not cleaned
+ * Fix spelling in description field (Closes: #399604)
+ * New upstream release
+
+ -- Emmanuel Bouthenot <kolter@openics.org> Wed, 22 Nov 2006 11:09:02 +0100
+
+kio-apt (0.13.1-1) unstable; urgency=low
+
+ * Initial release in debian (Closes: #397618)
+
+ -- Emmanuel Bouthenot <kolter@openics.org> Thu, 2 Nov 2006 21:34:39 +0100
+
+kio-apt (0.13.1) unstable; urgency=low
+
+ * at last, rebuild to use latest KDE library packages
+
+ -- Sylvain Joyeux <sylvain.joyeux@m4x.org> Tue, 29 Aug 2006 22:06:07 +0200
+
+kio-apt (0.13-0ubuntu5) feisty; urgency=low
+
+ * Rebuild for changes in the amd64 toolchain.
+ * Set Ubuntu maintainer address.
+
+ -- Matthias Klose <doko@ubuntu.com> Mon, 5 Mar 2007 01:19:35 +0000
+
+kio-apt (0.13-0ubuntu4) feisty; urgency=low
+
+ * Add Feisty sections.
+ * Add self as Maintainer.
+ * Rename old Maintainer field to X-Original-Maintainer.
+
+ -- Frode M. Doeving <frode@ubuntu.com> Thu, 2 Nov 2006 11:11:29 +0100
+
+kio-apt (0.13-0ubuntu3) edgy; urgency=low
+
+ * Add edgy to the list of distributions.
+
+ -- Frode M. Doeving <frode@lnix.net> Thu, 29 Jun 2006 17:07:41 +0200
+
+kio-apt (0.13-0ubuntu2) dapper; urgency=low
+
+ * Alter debian/rules to create .pot file
+ * Add kubuntu_01_kdepot.diff
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 9 May 2006 17:25:03 +0300
+
+kio-apt (0.13-0ubuntu1) dapper; urgency=low
+
+ * Merge with upstream.
+ * Update 01_kubuntufication.dpatch for Dapper
+
+ -- Frode M. Doeving <frode@lnix.net> Tue, 21 Mar 2006 20:04:29 +0100
+
+kio-apt (0.13) unstable; urgency=low
+
+ * Rebuild for the KDE transition
+
+ -- Sylvain Joyeux <sylvain.joyeux@m4x.org> Thu, 6 Oct 2005 18:29:50 +0200
+
+kio-apt (0.12) unstable; urgency=low
+
+ * Small bugfixes. Fix for APT >= 0.6
+
+ -- Sylvain Joyeux <sylvain.joyeux@m4x.org> Fri, 8 Jul 2005 08:14:25 +0200
+
+kio-apt (0.11-0ubuntu3) dapper; urgency=low
+
+ * Rebuild because libXft.la is gone
+
+ -- Stephan Hermann <sh@sourcecode.de> Sat, 14 Jan 2006 17:21:54 +0100
+
+kio-apt (0.11-0ubuntu2) dapper; urgency=low
+
+ * Rebuild for libstdc++ transition
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 7 Dec 2005 17:09:13 +0000
+
+kio-apt (0.11-0ubuntu1) breezy; urgency=low
+
+ * Build for ubuntu.
+ * Add dpatch capabilities.
+ * [patch]: 01_kubuntufication.dpatch - kubuntu branding. the 16x16 icon is
+ from
+ <http://kubuntu.org/favicon.ico> and the logo in apt:/ is a modified version
+ of the kubuntu logo at https://wiki.ubuntu.com/DebianArtwork
+ * [patch]: 02_gcc4fix.dpatch - gcc4 compile fixes.
+ * Sponsored upload for Frode M. Doeving <frode@lnix.net>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 30 Jun 2005 18:19:35 +0200
+
+kio-apt (0.11) unstable; urgency=low
+
+ * Changes in order to behave better when the view is not
+ so wide (mainly for KPkgManager)
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sat, 3 Apr 2004 10:22:32 +0200
+
+kio-apt (0.10) unstable; urgency=low
+
+ * Released 0.9 too soon. Fixing some bugs related to
+ kpkgmanager (even if I don't know if anybody uses it
+ yet)
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sat, 20 Mar 2004 12:39:41 +0100
+
+kio-apt (0.9) unstable; urgency=low
+
+ * Fixes some details
+ * Adds support for install and remove via KPkgManager
+ * Removes the run-time check for rpm & dpkg, as
+ alien installs /usr/bin/dpkg on RPM systems (and
+ vice-versa). A option for the configure script (build-time)
+ is used instead
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Tue, 16 Mar 2004 16:42:42 +0100
+
+kio-apt (0.8) unstable; urgency=low
+
+ * Release
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sat, 24 Jan 2004 17:16:58 +0100
+
+kio-apt (0.7.2) unstable; urgency=low
+
+ * Bugfixes
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sat, 17 Jan 2004 11:09:51 +0100
+
+kio-apt (0.7.1) unstable; urgency=low
+
+ * Pre-release version for 0.8
+ * Added some of the suggestions that appeared on kde-look:
+ - can show file list in the show? page
+ - can switch between a simple form (only search is available)
+ and a complete one
+ - added online search form (only dpkg from now)
+ * A few bugfixes. Since a lot of refactoring has been done,
+ new ones are likely to appear.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Fri, 16 Jan 2004 19:03:28 +0100
+
+kio-apt (0.7) unstable; urgency=low
+
+ * Bugfixes
+ * Added RPM-specific support
+ * Package-manager specific functionalities like
+ listing files in package are now hidden if the
+ package is not installed
+ * Polish translation
+ * Web shortcuts : apt-search, apt-find for finding
+ a file in packages, apt-files for listing the files
+ of a package.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Thu, 8 Jan 2004 12:46:16 +0100
+
+kio-apt (0.6) unstable; urgency=low
+
+ * Added support for dpkg -L and dpkg -S. Fixed a few bugs which appear
+ when an invalid package is given to show?.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sun, 14 Dec 2003 13:46:50 +0100
+
+kio-apt (0.5) unstable; urgency=low
+
+ * Bugfix release
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Tue, 9 Dec 2003 12:52:28 +0100
+
+kio-apt (0.4) unstable; urgency=low
+
+ * Added forms for query.
+ Thanks to Willy De la Court <wdl@linux-lovers.be> for the idea and
+ the initial patch.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sat, 22 Nov 2003 00:09:59 +0100
+
+kio-apt (0.3) unstable; urgency=low
+
+ * Bugfixes.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Fri, 14 Nov 2003 18:42:27 +0100
+
+kio-apt (0.2) unstable; urgency=low
+
+ * New release, added a policy action and
+ showing policy on the top of show. Bugfixes.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Sun, 12 Oct 2003 20:40:51 +0200
+
+kio-apt (0.1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Sylvain Joyeux <sylvain.joyeux@polytechnique.org> Mon, 6 Oct 2003 10:35:33 +0200
+
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/compat b/ubuntu/_base/applications/tdeio-apt/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/control b/ubuntu/_base/applications/tdeio-apt/debian/control
new file mode 100644
index 000000000..94a7b1583
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/control
@@ -0,0 +1,23 @@
+Source: tdeio-apt-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Emmanuel Bouthenot <kolter@openics.org>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+
+Package: tdeio-apt-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, apt, adept-batch-trinity
+Replaces: kio-apt-kde3 (<< 4:14.0.0~), kio-apt-trinity (<< 4:14.0.0~)
+Breaks: kio-apt-kde3 (<< 4:14.0.0~), kio-apt-trinity (<< 4:14.0.0~)
+Description: an apt-cache ioslave for Trinity
+ tdeio-apt is an ioslave which provides the apt:/ protocol. It
+ integrates apt-cache functionalities into Konqueror, making
+ browsing the packages easier. It provides:
+ - apt-cache search: apt:/search?expression
+ - apt-cache show: apt:/show?package . The show? target
+ prints the policy too.
+ - apt-cache policy: apt:/policy?package
+ .
+ Homepage : http://lpnotfr.free.fr/
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/copyright b/ubuntu/_base/applications/tdeio-apt/debian/copyright
new file mode 100644
index 000000000..b461d84ed
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/copyright
@@ -0,0 +1,30 @@
+This package was debianized by Sylvain Joyeux <sylvain.joyeux@polytechnique.org> on
+Mon, 6 Oct 2003 10:35:33 +0200.
+
+It was downloaded from http://lpnotfr.free.fr
+
+Upstream Author: Sylvain Joyeux <sylvain.joyeux@polytechnique.org>
+
+Copyright: 2003, Sylvain Joyeux <sylvain.joyeux@polytechnique.org>
+
+Others Copyrights :
+ - src/rpm.cpp : 2003, David Maciejak <david.maciejak@kyxar.fr>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/docs b/ubuntu/_base/applications/tdeio-apt/debian/docs
new file mode 100644
index 000000000..ca0272abf
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/docs
@@ -0,0 +1,3 @@
+AUTHORS
+README
+TODO
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/patches/series b/ubuntu/_base/applications/tdeio-apt/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/patches/series
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/rules b/ubuntu/_base/applications/tdeio-apt/debian/rules
new file mode 100755
index 000000000..18b1c07e2
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/source/format b/ubuntu/_base/applications/tdeio-apt/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/ubuntu/_base/applications/tdeio-apt/debian/source/options b/ubuntu/_base/applications/tdeio-apt/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-apt/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*