summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk')
-rw-r--r--ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk
index f36e3527c..aba508624 100644
--- a/ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/applications/tdeio/tdeio-appinfo/debian/cdbs/debian-tde.mk
@@ -82,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \