summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdeadmin/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdeadmin/debian')
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/cdbs/debian-tde.mk30
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/compat2
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/control4
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/patches/common/04_am_maintainer_mode.diff11
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/patches/common/06_disable_no_undefined.diff18
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/patches/common/kubuntu_01_kdepot.diff26
-rw-r--r--ubuntu/_base/core/tdeadmin/debian/patches/series3
-rwxr-xr-xubuntu/_base/core/tdeadmin/debian/rules14
8 files changed, 30 insertions, 78 deletions
diff --git a/ubuntu/_base/core/tdeadmin/debian/cdbs/debian-tde.mk b/ubuntu/_base/core/tdeadmin/debian/cdbs/debian-tde.mk
index 24191b2cd..aba508624 100644
--- a/ubuntu/_base/core/tdeadmin/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/core/tdeadmin/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
endif
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
endif
@@ -73,7 +82,17 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
@@ -117,7 +136,7 @@ endif
echo "# TDE package information" >.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
post-patches:: .tdepkginfo
@@ -183,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
@@ -204,7 +228,7 @@ debian/stamp-kde-apidox:
common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
cleanbuilddir::
-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
diff --git a/ubuntu/_base/core/tdeadmin/debian/compat b/ubuntu/_base/core/tdeadmin/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/core/tdeadmin/debian/compat
+++ b/ubuntu/_base/core/tdeadmin/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/core/tdeadmin/debian/control b/ubuntu/_base/core/tdeadmin/debian/control
index 7e3047835..917184580 100644
--- a/ubuntu/_base/core/tdeadmin/debian/control
+++ b/ubuntu/_base/core/tdeadmin/debian/control
@@ -1,10 +1,10 @@
Source: tdeadmin-trinity
Section: tde
Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Christopher Martin <chrsmrtn@debian.org>, Fathi Boudra <fboudra@free.fr>, Modestas Vainius <geromanas@mailas.com>, Sune Vuorela <debian@pusling.com>
-Build-Depends: libasound2-dev, cdbs (>= 0.4.39-0.1), debhelper (>= 9~), quilt, cmake, intltool, docbook-to-man, gawk, tdelibs14-trinity-dev, libbz2-dev, libpam0g-dev, sharutils, texinfo, rpm, libltdl-dev
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev, libpam0g-dev, docbook-to-man
Standards-Version: 3.8.4
Package: tdeadmin-trinity
diff --git a/ubuntu/_base/core/tdeadmin/debian/patches/common/04_am_maintainer_mode.diff b/ubuntu/_base/core/tdeadmin/debian/patches/common/04_am_maintainer_mode.diff
deleted file mode 100644
index 391a80285..000000000
--- a/ubuntu/_base/core/tdeadmin/debian/patches/common/04_am_maintainer_mode.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/admin/configure.in.min
-+++ b/admin/configure.in.min
-@@ -38,6 +38,8 @@
- dnl Automake doc recommends to do this only here. (Janos)
- AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
-
-+AM_MAINTAINER_MODE
-+
- KDE_SET_PREFIX
-
- dnl generate the config header
diff --git a/ubuntu/_base/core/tdeadmin/debian/patches/common/06_disable_no_undefined.diff b/ubuntu/_base/core/tdeadmin/debian/patches/common/06_disable_no_undefined.diff
deleted file mode 100644
index 05c932c3c..000000000
--- a/ubuntu/_base/core/tdeadmin/debian/patches/common/06_disable_no_undefined.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/admin/acinclude.m4.in
-+++ b/admin/acinclude.m4.in
-@@ -1689,15 +1689,6 @@
- KDE_USE_CLOSURE_TRUE="#"
- KDE_USE_CLOSURE_FALSE=""
- KDE_NO_UNDEFINED=""
-- case $host in
-- *-*-linux-gnu)
-- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
-- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
-- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
-- [KDE_NO_UNDEFINED=""])],
-- [KDE_NO_UNDEFINED=""])
-- ;;
-- esac
- fi
- AC_SUBST(KDE_USE_CLOSURE_TRUE)
- AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/ubuntu/_base/core/tdeadmin/debian/patches/common/kubuntu_01_kdepot.diff b/ubuntu/_base/core/tdeadmin/debian/patches/common/kubuntu_01_kdepot.diff
deleted file mode 100644
index 39dd7745e..000000000
--- a/ubuntu/_base/core/tdeadmin/debian/patches/common/kubuntu_01_kdepot.diff
+++ /dev/null
@@ -1,26 +0,0 @@
---- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
-+++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
-@@ -537,6 +537,8 @@
- if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
- export EXTRACTRC PREPARETIPS
-
-+kdepotpath=/opt/trinity/include/tde/tde.pot
-+
- for subdir in $dirs; do
- test -z "$VERBOSE" || echo "Making messages in $subdir"
- (cd $subdir
-@@ -554,10 +556,10 @@
- fi
- perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
-
-- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
-- if ! test -f $kdepotpath; then
-- kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
-- fi
-+# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
-+# if ! test -f $kdepotpath; then
-+# kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
-+# fi
-
- $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
- XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages
diff --git a/ubuntu/_base/core/tdeadmin/debian/patches/series b/ubuntu/_base/core/tdeadmin/debian/patches/series
index 6b3ddc8ec..e69de29bb 100644
--- a/ubuntu/_base/core/tdeadmin/debian/patches/series
+++ b/ubuntu/_base/core/tdeadmin/debian/patches/series
@@ -1,3 +0,0 @@
-common/04_am_maintainer_mode.diff
-common/06_disable_no_undefined.diff
-common/kubuntu_01_kdepot.diff
diff --git a/ubuntu/_base/core/tdeadmin/debian/rules b/ubuntu/_base/core/tdeadmin/debian/rules
index 692ea7674..21bc8b8ec 100755
--- a/ubuntu/_base/core/tdeadmin/debian/rules
+++ b/ubuntu/_base/core/tdeadmin/debian/rules
@@ -4,22 +4,8 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
DEB_DH_STRIP_ARGS := --dbg-package=tdeadmin-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CONFIGURE_EXTRA_FLAGS := \
- --without-rpm --with-pam=tde --with-shadow --with-nis \
- --with-private-groups --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \