summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdebindings/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdebindings/debian/rules')
-rwxr-xr-xubuntu/_base/core/tdebindings/debian/rules11
1 files changed, 4 insertions, 7 deletions
diff --git a/ubuntu/_base/core/tdebindings/debian/rules b/ubuntu/_base/core/tdebindings/debian/rules
index 63b19e54f..f7d6f4790 100755
--- a/ubuntu/_base/core/tdebindings/debian/rules
+++ b/ubuntu/_base/core/tdebindings/debian/rules
@@ -3,10 +3,6 @@
DEB_QUILT_PATCHDIR_LINK :=
export QUILT_PATCHES=debian/patches
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
-
-
include /usr/share/cdbs/1/rules/debhelper.mk
override DEB_BUILDDIR := $(DEB_SRCDIR)
include debian/cdbs/debian-tde.mk
@@ -33,7 +29,7 @@ endif
DEB_CONFIGURE_EXTRA_FLAGS = $(WITH_JAVA) --prefix=/opt/trinity \
DO_NOT_COMPILE='dcopc dcopperl kalyptus qtsharp xparts python'
-DEB_COMPRESS_EXCLUDE += .java .ui .js .rb .map .wav .bmp .cpp .sk
+DEB_COMPRESS_EXCLUDE_ALL += .java .ui .js .rb .map .wav .bmp .cpp .sk
# These are not all the packages with libraries, but only those that
# need to be in DEB_SHLIBDEPS_INCLUDE...
@@ -111,8 +107,9 @@ common-install-arch:: stamp-install-dcopjava
binary-install/juic-trinity::
sed -i "s|UIXSLDIR=/usr|UIXSLDIR=/opt/trinity|" debian/$(cdbs_curpkg)/opt/trinity/bin/juic
-binary-install/python-dcop-trinity::
- ${DH_PYTHON2} -p$(cdbs_curpkg)
+
+binary-install/python3-dcop-trinity::
+ dh_python3 -p$(cdbs_curpkg)
###