summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/avahi-tqt/debian/rules5
1 files changed, 2 insertions, 3 deletions
diff --git a/ubuntu/_base/dependencies/avahi-tqt/debian/rules b/ubuntu/_base/dependencies/avahi-tqt/debian/rules
index 32d30901d..dc8f0248c 100755
--- a/ubuntu/_base/dependencies/avahi-tqt/debian/rules
+++ b/ubuntu/_base/dependencies/avahi-tqt/debian/rules
@@ -2,6 +2,7 @@
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
@@ -9,10 +10,8 @@ export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DWITH_ALL_OPTIONS="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)