summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/dbus-1-tqt/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/dbus-1-tqt/debian')
-rw-r--r--ubuntu/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk30
-rw-r--r--ubuntu/_base/dependencies/dbus-1-tqt/debian/compat2
-rw-r--r--ubuntu/_base/dependencies/dbus-1-tqt/debian/control4
-rwxr-xr-xubuntu/_base/dependencies/dbus-1-tqt/debian/rules5
4 files changed, 31 insertions, 10 deletions
diff --git a/ubuntu/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk b/ubuntu/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
index 24191b2cd..aba508624 100644
--- a/ubuntu/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
endif
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
endif
@@ -73,7 +82,17 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
@@ -117,7 +136,7 @@ endif
echo "# TDE package information" >.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
post-patches:: .tdepkginfo
@@ -183,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
@@ -204,7 +228,7 @@ debian/stamp-kde-apidox:
common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
cleanbuilddir::
-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
diff --git a/ubuntu/_base/dependencies/dbus-1-tqt/debian/compat b/ubuntu/_base/dependencies/dbus-1-tqt/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/dependencies/dbus-1-tqt/debian/compat
+++ b/ubuntu/_base/dependencies/dbus-1-tqt/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/dependencies/dbus-1-tqt/debian/control b/ubuntu/_base/dependencies/dbus-1-tqt/debian/control
index fda46f7a1..20064441f 100644
--- a/ubuntu/_base/dependencies/dbus-1-tqt/debian/control
+++ b/ubuntu/_base/dependencies/dbus-1-tqt/debian/control
@@ -1,8 +1,8 @@
Source: dbus-1-tqt
Section: devel
Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: cdbs (>= 0.4.43), debhelper (>= 9~), quilt, libtqtinterface-dev, libdbus-1-dev (>= 0.90), cmake
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, libtqtinterface-dev, libdbus-1-dev (>= 0.90)
Build-Depends-Indep: doxygen, graphviz
Standards-Version: 3.8.3
diff --git a/ubuntu/_base/dependencies/dbus-1-tqt/debian/rules b/ubuntu/_base/dependencies/dbus-1-tqt/debian/rules
index 0c9611c12..6621aaf1e 100755
--- a/ubuntu/_base/dependencies/dbus-1-tqt/debian/rules
+++ b/ubuntu/_base/dependencies/dbus-1-tqt/debian/rules
@@ -6,13 +6,10 @@ include debian/cdbs/debian-tde.mk
DEB_KDE_APIDOX := yes
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_APIDOX_HTML_DIRECTORY="usr/share/doc/libdbus-1-tqt/HTML" \
-DWITH_ALL_OPTIONS="ON"